packages: bump uboot-mxs to 2016.01, refresh patches
authorZoltan Herpai <wigyori@uid0.hu>
Tue, 19 Jan 2016 21:50:11 +0000 (21:50 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Tue, 19 Jan 2016 21:50:11 +0000 (21:50 +0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
SVN-Revision: 48374

package/boot/uboot-mxs/Makefile
package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
package/boot/uboot-mxs/patches/100-gcc-5-fix.patch [deleted file]

index 373b8d8f80ed288103c216e296cb973e811d25c7..3b82db59b5f1a829200676d3ac92014613ebec64 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013-2015 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2015.07
+PKG_VERSION:=2016.01
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
+PKG_MD5SUM:=7d4f65fd43d4d706f5c5650e020d899d
 
 PKG_LICENSE:=GPL-2.0 GPL-2.0+
 PKG_LICENSE_FILES:=Licenses/README
@@ -30,11 +30,11 @@ define uboot/Default
 endef
 
 define uboot/mx23_olinuxino
-  TITLE:=U-Boot 2015.07 for the Olinuxino i.MX233
+  TITLE:=U-Boot 2016.01 for the Olinuxino i.MX233
 endef
 
 define uboot/duckbill
-  TITLE:=U-Boot 2015.07 for the I2SE Duckbill
+  TITLE:=U-Boot 2016.01 for the I2SE Duckbill
 endef
 
 UBOOTS := \
index 79138d227f92b8d0847f0b6b0144c36ac6297dac..91f583f36edd3c37376f41b9df962d0b8711ce9a 100644 (file)
@@ -40,11 +40,11 @@ Signed-off-by: Michael Heimpold <mhei@heimpold.de>
 @@ -926,6 +931,7 @@ source "board/genesi/mx51_efikamx/Kconfi
  source "board/gumstix/pepper/Kconfig"
  source "board/h2200/Kconfig"
- source "board/hale/tt01/Kconfig"
+ source "board/hisilicon/hikey/Kconfig"
 +source "board/i2se/duckbill/Kconfig"
- source "board/icpdas/lp8x4x/Kconfig"
  source "board/imx31_phycore/Kconfig"
  source "board/isee/igep0033/Kconfig"
+ source "board/maxbcm/Kconfig"
 --- a/arch/arm/include/asm/mach-types.h
 +++ b/arch/arm/include/asm/mach-types.h
 @@ -1109,6 +1109,7 @@ extern unsigned int __machine_arch_type;
diff --git a/package/boot/uboot-mxs/patches/100-gcc-5-fix.patch b/package/boot/uboot-mxs/patches/100-gcc-5-fix.patch
deleted file mode 100644 (file)
index bec6ee7..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/arm/cpu/arm926ejs/mxs/mxs.c
-+++ b/arch/arm/cpu/arm926ejs/mxs/mxs.c
-@@ -24,7 +24,7 @@
- DECLARE_GLOBAL_DATA_PTR;
- /* Lowlevel init isn't used on i.MX28, so just have a dummy here */
--inline void lowlevel_init(void) {}
-+void lowlevel_init(void) {}
- void reset_cpu(ulong ignored) __attribute__((noreturn));