curl: add nghttp2 support
authorHans Dedecker <dedeckeh@gmail.com>
Fri, 6 Oct 2017 08:53:51 +0000 (10:53 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 7 Oct 2017 17:17:44 +0000 (19:17 +0200)
Add config option support for nghttp2

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/utils/curl/Config.in
package/network/utils/curl/Makefile

index 6f72134731a6932ec0bfb11f9c5d663305d26eec..973da3d964ac633f163b7458481348043a3bc1ad 100644 (file)
@@ -101,6 +101,10 @@ config LIBCURL_TFTP
        bool "TFTP protocol"
        default n
 
+config LIBCURL_NGHTTP2
+       bool "HTTP2 protocol"
+       default n
+
 comment "Miscellaneous"
 
 config LIBCURL_PROXY
index 330d8d518c0f529ef4cf00c895499f869ef7fbf3..634da04657c52ef274a19c07d059af7b476d0882 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
 PKG_VERSION:=7.55.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
@@ -53,6 +53,7 @@ PKG_CONFIG_DEPENDS:= \
   CONFIG_LIBCURL_SMTP \
   CONFIG_LIBCURL_TELNET \
   CONFIG_LIBCURL_TFTP \
+  CONFIG_LIBCURL_NGHTTP2 \
   \
   CONFIG_LIBCURL_COOKIES \
   CONFIG_LIBCURL_CRYPTO_AUTH \
@@ -85,7 +86,8 @@ define Package/libcurl
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:= +LIBCURL_WOLFSSL:libwolfssl +LIBCURL_OPENSSL:libopenssl +LIBCURL_GNUTLS:libgnutls +LIBCURL_MBEDTLS:libmbedtls
-  DEPENDS += +LIBCURL_ZLIB:zlib +LIBCURL_THREADED_RESOLVER:libpthread +LIBCURL_LDAP:libopenldap +LIBCURL_LIBIDN:libidn +LIBCURL_SSH2:libssh2
+  DEPENDS += +LIBCURL_ZLIB:zlib +LIBCURL_THREADED_RESOLVER:libpthread +LIBCURL_LDAP:libopenldap +LIBCURL_LIBIDN:libidn
+  DEPENDS += +LIBCURL_SSH2:libssh2 +LIBCURL_NGHTTP2:libnghttp2
   TITLE:=A client-side URL transfer library
   MENU:=1
 endef
@@ -119,6 +121,7 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LIBCURL_LIBIDN),--with-libidn="$(STAGING_DIR)/usr",--without-libidn) \
        $(if $(CONFIG_LIBCURL_SSH2),--with-libssh2="$(STAGING_DIR)/usr",--without-libssh2) \
        $(if $(CONFIG_LIBCURL_ZLIB),--with-zlib="$(STAGING_DIR)/usr",--without-zlib) \
+       $(if $(CONFIG_LIBCURL_NGHTTP2),--with-nghttp2="$(STAGING_DIR)/usr",--without-nghttp2) \
        \
        $(call autoconf_bool,CONFIG_LIBCURL_DICT,dict) \
        $(call autoconf_bool,CONFIG_LIBCURL_FILE,file) \