fix jffs2 64k and 128k images overwrite each other
authorFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 11:42:17 +0000 (11:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 11:42:17 +0000 (11:42 +0000)
When trying to build images with jffs2 filesystem for ramips platform
there is only one jffs2 image produced instead of two (64k and 128k).

Signed-off-by: Roman Yeryomin <roman@advem.lv>
SVN-Revision: 22435

target/linux/ramips/image/Makefile

index d52c41f0b8487565d8ee1afd5a5057a3041633d2..1addcbf22f13b57acc7ed19bb910129d8beea585 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define imgname
-$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))
+$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)
 endef
 
 VMLINUX:=$(IMG_PREFIX)-vmlinux