kernel: bump 4.9 to 4.9.127
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 17 Sep 2018 09:48:49 +0000 (11:48 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 17 Sep 2018 13:47:44 +0000 (15:47 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.9/950-0074-Update-ds1307-driver-for-device-tree-support.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/ixp4xx/patches-4.9/160-delayed_uart_io.patch
target/linux/layerscape/patches-4.9/804-crypto-support-layerscape.patch
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch
target/linux/layerscape/patches-4.9/815-spi-support-layerscape.patch

index 2bed4274c369943c4735cb5033f6e89c83ac378d..69528c684ee34d015b1565c2a57288f89a5ee99b 100644 (file)
@@ -2,13 +2,13 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .125
 LINUX_VERSION-4.14 = .68
 LINUX_VERSION-3.18 = .122
+LINUX_VERSION-4.9 = .127
 
-LINUX_KERNEL_HASH-4.9.125 = a764deef61bebfac1d07b2ed6890f93a12a9ab6d3fc3c53e3d850ed4681111cb
 LINUX_KERNEL_HASH-4.14.68 = 791dbf1597033bf2b61e83307d78188ffc1ad4bdd1da3234876667edfdd28690
 LINUX_KERNEL_HASH-3.18.122 = 675b1ce36af23caa500cb1d4f0ec2976791fb0a97ebb6486a5e2ebcb5527ade5
+LINUX_KERNEL_HASH-4.9.127 = 9477aeaded97589a40d7cbbfeebfa7a8f863130c0729a8dc5cdbcf48eb6fdd0f
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index d4f7e762c2b5baa94f5b3acad045dd8bcedd73c6..236e55d69a33be8142255d265de8f1c3feef027b 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
 
 --- a/drivers/rtc/rtc-ds1307.c
 +++ b/drivers/rtc/rtc-ds1307.c
-@@ -1675,6 +1675,14 @@ static int ds1307_remove(struct i2c_clie
+@@ -1682,6 +1682,14 @@ static int ds1307_remove(struct i2c_clie
        return 0;
  }
  
index 3268b3407ac0c6a8e7e197daccd594ef43007a8c..0e8e0660db5d9b555885bb69ce553f8f461d37e0 100644 (file)
@@ -1040,7 +1040,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                writel(irq->mask, adpt->base + EMAC_INT_MASK);
 --- a/drivers/net/ethernet/realtek/r8169.c
 +++ b/drivers/net/ethernet/realtek/r8169.c
-@@ -7577,7 +7577,7 @@ static int rtl8169_poll(struct napi_stru
+@@ -7578,7 +7578,7 @@ static int rtl8169_poll(struct napi_stru
        }
  
        if (work_done < budget) {
index c510e42bb6dc7a7c90c44dc5397c8a86a9e7eb9c..8a6495b222189a44cb379ddeec1d3280904363ab 100644 (file)
@@ -18,7 +18,7 @@
                uart->capabilities      = up->capabilities;
 --- a/drivers/tty/serial/serial_core.c
 +++ b/drivers/tty/serial/serial_core.c
-@@ -2233,6 +2233,7 @@ uart_report_port(struct uart_driver *drv
+@@ -2240,6 +2240,7 @@ uart_report_port(struct uart_driver *drv
                snprintf(address, sizeof(address),
                         "I/O 0x%lx offset 0x%x", port->iobase, port->hub6);
                break;
@@ -26,7 +26,7 @@
        case UPIO_MEM:
        case UPIO_MEM16:
        case UPIO_MEM32:
-@@ -2897,6 +2898,7 @@ int uart_match_port(struct uart_port *po
+@@ -2904,6 +2905,7 @@ int uart_match_port(struct uart_port *po
        case UPIO_HUB6:
                return (port1->iobase == port2->iobase) &&
                       (port1->hub6   == port2->hub6);
index 2598cdedbb2d720f6055520e7682cf95230796f3..a143ad566b2522907f59fa00fa46048e61e8085c 100644 (file)
@@ -26382,7 +26382,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        return ret;
  }
  
-@@ -280,6 +291,36 @@ struct device *caam_jr_alloc(void)
+@@ -281,6 +292,36 @@ struct device *caam_jr_alloc(void)
  EXPORT_SYMBOL(caam_jr_alloc);
  
  /**
@@ -26419,7 +26419,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
   * caam_jr_free() - Free the Job Ring
   * @rdev     - points to the dev that identifies the Job ring to
   *             be released.
-@@ -496,15 +537,28 @@ static int caam_jr_probe(struct platform
+@@ -497,15 +538,28 @@ static int caam_jr_probe(struct platform
                return -ENOMEM;
        }
  
@@ -26455,7 +26455,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        /* Identify the interrupt */
        jrpriv->irq = irq_of_parse_and_map(nprop, 0);
-@@ -524,10 +578,12 @@ static int caam_jr_probe(struct platform
+@@ -525,10 +579,12 @@ static int caam_jr_probe(struct platform
  
        atomic_set(&jrpriv->tfm_count, 0);
  
index 050092905c76591d404d1ad986ea181d18f7d66d..816abbb9e784fef9cbb49e06ab43595750307352 100644 (file)
@@ -987,7 +987,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
 --- a/drivers/iommu/intel-iommu.c
 +++ b/drivers/iommu/intel-iommu.c
-@@ -440,6 +440,7 @@ struct dmar_rmrr_unit {
+@@ -441,6 +441,7 @@ struct dmar_rmrr_unit {
        u64     end_address;            /* reserved end address */
        struct dmar_dev_scope *devices; /* target devices */
        int     devices_cnt;            /* target device count */
@@ -995,7 +995,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  };
  
  struct dmar_atsr_unit {
-@@ -4251,27 +4252,40 @@ static inline void init_iommu_pm_ops(voi
+@@ -4267,27 +4268,40 @@ static inline void init_iommu_pm_ops(voi
  int __init dmar_parse_one_rmrr(struct acpi_dmar_header *header, void *arg)
  {
        struct acpi_dmar_reserved_memory *rmrr;
@@ -1041,7 +1041,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  }
  
  static struct dmar_atsr_unit *dmar_find_atsr(struct acpi_dmar_atsr *atsr)
-@@ -4485,6 +4499,7 @@ static void intel_iommu_free_dmars(void)
+@@ -4501,6 +4515,7 @@ static void intel_iommu_free_dmars(void)
        list_for_each_entry_safe(rmrru, rmrr_n, &dmar_rmrr_units, list) {
                list_del(&rmrru->list);
                dmar_free_dev_scope(&rmrru->devices, &rmrru->devices_cnt);
@@ -1049,7 +1049,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                kfree(rmrru);
        }
  
-@@ -5220,6 +5235,45 @@ static void intel_iommu_remove_device(st
+@@ -5236,6 +5251,45 @@ static void intel_iommu_remove_device(st
        iommu_device_unlink(iommu->iommu_dev, dev);
  }
  
@@ -1095,7 +1095,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  #ifdef CONFIG_INTEL_IOMMU_SVM
  #define MAX_NR_PASID_BITS (20)
  static inline unsigned long intel_iommu_get_pts(struct intel_iommu *iommu)
-@@ -5350,19 +5404,21 @@ struct intel_iommu *intel_svm_device_to_
+@@ -5366,19 +5420,21 @@ struct intel_iommu *intel_svm_device_to_
  #endif /* CONFIG_INTEL_IOMMU_SVM */
  
  static const struct iommu_ops intel_iommu_ops = {
index 22904eec9d5d1efb21e89bfbff6f2aa0bebfc4ea..b798a366b0f9023e0950d16394e07e1663c7d226 100644 (file)
@@ -402,10 +402,10 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 +              goto out_master_put;
        }
  
-       dspi_init(dspi);
+       dspi->clk = devm_clk_get(&pdev->dev, "dspi");
 @@ -740,6 +1031,13 @@ static int dspi_probe(struct platform_de
-       if (ret)
-               goto out_master_put;
+               goto out_clk_put;
+       }
  
 +      if (dspi->devtype_data->trans_mode == DSPI_DMA_MODE) {
 +              if (dspi_request_dma(dspi, res->start)) {