brcm63xx: fix F@ST2704V2 image generation
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Wed, 1 Jun 2016 19:47:42 +0000 (21:47 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Wed, 1 Jun 2016 19:47:42 +0000 (21:47 +0200)
This device needs the firmware padded to 4MB.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/brcm63xx/image/Makefile

index e00b6fb9486bb5226b57013c1fa8cd0824904b18..9ea2ea279c323aef2351db77828c70863a07c0be 100644 (file)
@@ -611,7 +611,7 @@ $(eval $(call bcm63xxCfe,FAST2604,F@ST2604,fast2604,F@ST2604,6348))
 # Sagem F@ST2704N V1 / Plusnet F@ST2704N V1
 $(eval $(call bcm63xxCfe,FAST2704N,FAST2704N,fast2704n,F@ST2704N,6318,--pad 4))
 # Sagem F@ST2704V2
 # Sagem F@ST2704N V1 / Plusnet F@ST2704N V1
 $(eval $(call bcm63xxCfe,FAST2704N,FAST2704N,fast2704n,F@ST2704N,6318,--pad 4))
 # Sagem F@ST2704V2
-$(eval $(call bcm63xxCfe,FAST2704V2,F@ST2704V2,fast2704v2,F@ST2704V2,6328))
+$(eval $(call bcm63xxCfe,FAST2704V2,F@ST2704V2,fast2704v2,F@ST2704V2,6328,--pad 4))
 # SFR Neufbox 4
 $(eval $(call bcm63xxCfe,Neufbox4,NEUFBOX4-SER,nb4-ser-r0,96358VW,6358,--rsa-signature "OpenWRT-$(REVISION)"))
 $(eval $(call bcm63xxCfe,Neufbox4,NEUFBOX4-FXC,nb4-fxc-r1,96358VW,6358,--rsa-signature "OpenWRT-$(REVISION)"))
 # SFR Neufbox 4
 $(eval $(call bcm63xxCfe,Neufbox4,NEUFBOX4-SER,nb4-ser-r0,96358VW,6358,--rsa-signature "OpenWRT-$(REVISION)"))
 $(eval $(call bcm63xxCfe,Neufbox4,NEUFBOX4-FXC,nb4-fxc-r1,96358VW,6358,--rsa-signature "OpenWRT-$(REVISION)"))