kernel: add usb-mass-storage-gadget driver package
authorJohn Crispin <john@openwrt.org>
Mon, 19 Oct 2015 10:10:51 +0000 (10:10 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 19 Oct 2015 10:10:51 +0000 (10:10 +0000)
This is another useful gadget driver that can allow an OTG port to act as a
mass storage device.

Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
SVN-Revision: 47225

package/kernel/linux/modules/usb.mk

index 986f53f2265ba1786e8bb10e21b77ebc1e025f13..487a17de109771aad6b3319242bda279649b6297 100644 (file)
@@ -279,6 +279,23 @@ endef
 
 $(eval $(call KernelPackage,usb-serial-gadget))
 
+define KernelPackage/usb-mass-storage-gadget
+  TITLE:=USB Mass Storage support
+  KCONFIG:=CONFIG_USB_MASS_STORAGE
+  DEPENDS:=+kmod-usb-gadget +kmod-usb-lib-composite
+  FILES:= \
+       $(LINUX_DIR)/drivers/usb/gadget/function/usb_f_mass_storage.ko \
+       $(LINUX_DIR)/drivers/usb/gadget/legacy/g_mass_storage.ko
+  AUTOLOAD:=$(call AutoLoad,52,usb_f_mass_storage g_mass_storage)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-mass-storage-gadget/description
+  Kernel support for USB Gadget Mass Storage
+endef
+
+$(eval $(call KernelPackage,usb-mass-storage-gadget))
+
 
 define KernelPackage/usb-uhci
   TITLE:=Support for UHCI controllers