sunxi: add support for linksprite pcDuino3 nano board
authorJiang Yongquan <woxwchc@foxmail.com>
Mon, 11 Jan 2021 15:09:23 +0000 (23:09 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 27 Jan 2021 22:14:30 +0000 (23:14 +0100)
Specifications:

 - SoC: Allwinner A20 @ 1Ghz
 - DRAM: 1GiB DDR3 @ 408MHz (K4B4G1646Q-HYK0)
 - NAND: 4GB MLC NAND (H27UBG8T2BTR-BC)
 - Ethernet: 10/100/1000Mbps Ethernet (Realtek RTL8211E)

Flash instructions:

dd if=openwrt-sunxi-cortexa7-linksprite_pcduino3-nano-ext4-sdcard.img
of=/dev/sdX

Signed-off-by: Jiang Yongquan <woxwchc@foxmail.com>
[Remove CONFIG_REALTEK_PHY from sunxi/cortexa53 config]
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/config-5.4
target/linux/sunxi/cortexa53/config-5.4
target/linux/sunxi/image/cortexa7.mk

index 859a06019b046ec43eaa27d15d3988239a76aba6..38147339a4edd5efa5d7bad8764bcde8f52ef483 100644 (file)
@@ -142,6 +142,12 @@ define U-Boot/Linksprite_pcDuino3
   BUILD_DEVICES:=linksprite_pcduino3
 endef
 
   BUILD_DEVICES:=linksprite_pcduino3
 endef
 
+define U-Boot/Linksprite_pcDuino3_Nano
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=Linksprite pcDuino3 Nano
+  BUILD_DEVICES:=linksprite_pcduino3-nano
+endef
+
 define U-Boot/Lamobo_R1
   BUILD_SUBTARGET:=cortexa7
   NAME:=Lamobo R1
 define U-Boot/Lamobo_R1
   BUILD_SUBTARGET:=cortexa7
   NAME:=Lamobo R1
@@ -317,6 +323,7 @@ UBOOT_TARGETS := \
        OLIMEX_A13_SOM \
        Linksprite_pcDuino \
        Linksprite_pcDuino3 \
        OLIMEX_A13_SOM \
        Linksprite_pcDuino \
        Linksprite_pcDuino3 \
+       Linksprite_pcDuino3_Nano \
        Lamobo_R1 \
        nanopi_m1_plus \
        zeropi \
        Lamobo_R1 \
        nanopi_m1_plus \
        zeropi \
index 7318d5a3e9d093839d390b4f5830ecb38d61a283..fba86b86eef24c0437f101237b807c7d7a74e395 100644 (file)
@@ -443,6 +443,7 @@ CONFIG_PWM_SYSFS=y
 CONFIG_RATIONAL=y
 CONFIG_RCU_NEED_SEGCBLIST=y
 CONFIG_RCU_STALL_COMMON=y
 CONFIG_RATIONAL=y
 CONFIG_RCU_NEED_SEGCBLIST=y
 CONFIG_RCU_STALL_COMMON=y
+CONFIG_REALTEK_PHY=y
 CONFIG_REFCOUNT_FULL=y
 CONFIG_REGMAP=y
 CONFIG_REGMAP_I2C=y
 CONFIG_REFCOUNT_FULL=y
 CONFIG_REGMAP=y
 CONFIG_REGMAP_I2C=y
index 6e1ef221292da63f10a008f970fa521a0096522a..203ab9fa38ffd71f4de72cc49582d1847f0b5adb 100644 (file)
@@ -134,7 +134,6 @@ CONFIG_PINCTRL_SUN50I_H6=y
 CONFIG_PINCTRL_SUN50I_H6_R=y
 CONFIG_QUEUED_RWLOCKS=y
 CONFIG_QUEUED_SPINLOCKS=y
 CONFIG_PINCTRL_SUN50I_H6_R=y
 CONFIG_QUEUED_RWLOCKS=y
 CONFIG_QUEUED_SPINLOCKS=y
-CONFIG_REALTEK_PHY=y
 CONFIG_RODATA_FULL_DEFAULT_ENABLED=y
 # CONFIG_SND_SUN50I_CODEC_ANALOG is not set
 CONFIG_SOUND_OSS_CORE_PRECLAIM=y
 CONFIG_RODATA_FULL_DEFAULT_ENABLED=y
 # CONFIG_SND_SUN50I_CODEC_ANALOG is not set
 CONFIG_SOUND_OSS_CORE_PRECLAIM=y
index d491dbc338d27f8bfd4f4dd180c1cfe27fe88430..baa3e56b44cd6e33016d48884902d735a565d6aa 100644 (file)
@@ -107,6 +107,14 @@ define Device/linksprite_pcduino3
 endef
 TARGET_DEVICES += linksprite_pcduino3
 
 endef
 TARGET_DEVICES += linksprite_pcduino3
 
+define Device/linksprite_pcduino3-nano
+  DEVICE_VENDOR := LinkSprite
+  DEVICE_MODEL := pcDuino3 Nano
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
+  SOC := sun7i-a20
+endef
+TARGET_DEVICES += linksprite_pcduino3-nano
+
 define Device/mele_m9
   DEVICE_VENDOR := Mele
   DEVICE_MODEL := M9
 define Device/mele_m9
   DEVICE_VENDOR := Mele
   DEVICE_MODEL := M9