ar71xx: refresh patches
authorGabor Juhos <juhosg@openwrt.org>
Wed, 1 Dec 2010 18:40:01 +0000 (18:40 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 1 Dec 2010 18:40:01 +0000 (18:40 +0000)
SVN-Revision: 24210

16 files changed:
target/linux/ar71xx/patches-2.6.32/102-mtd_m25p80_add_myloader_parser.patch
target/linux/ar71xx/patches-2.6.32/104-mtd_m25p80_add_redboot_parser.patch
target/linux/ar71xx/patches-2.6.32/109-mtd-wrt160nl-trx-parser.patch
target/linux/ar71xx/patches-2.6.32/990-backport.patch
target/linux/ar71xx/patches-2.6.36/005-ar71xx_mac_driver.patch
target/linux/ar71xx/patches-2.6.36/108-mtd_fix_cfi_cmdset_0002_status_check.patch
target/linux/ar71xx/patches-2.6.36/111-mtd-cfi_cmdset_0002-force-word-write.patch
target/linux/ar71xx/patches-2.6.36/400-2.6.35-fix-nand_scan_ident-options.patch
target/linux/ar71xx/patches-2.6.37/005-ar71xx_mac_driver.patch
target/linux/ar71xx/patches-2.6.37/108-mtd_fix_cfi_cmdset_0002_status_check.patch
target/linux/ar71xx/patches-2.6.37/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
target/linux/ar71xx/patches-2.6.37/111-mtd-cfi_cmdset_0002-force-word-write.patch
target/linux/ar71xx/patches-2.6.37/150-drivers-link-spi-before-mtd.patch
target/linux/ar71xx/patches-2.6.37/205-wndr3700-usb-led-driver.patch
target/linux/ar71xx/patches-2.6.37/207-rb750-led-driver.patch
target/linux/ar71xx/patches-2.6.37/400-2.6.35-fix-nand_scan_ident-options.patch

index 41b97a0f3b43b57b280bdd741a875ba3ccb90061..17ae0fd8d48cb524cdab8efc609275bc74010d79 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -872,6 +872,16 @@ static int __devinit m25p_probe(struct s
+@@ -873,6 +873,16 @@ static int __devinit m25p_probe(struct s
                                        part_probes, &parts, 0);
                }
  
index d736c9a1a4559c157249de3ebfc5e3428642d7eb..338de2668bc93677f784fe80cfdedbf005ccd7d3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -882,6 +882,15 @@ static int __devinit m25p_probe(struct s
+@@ -883,6 +883,15 @@ static int __devinit m25p_probe(struct s
                }
  #endif
  
index 558f047853eeadcb50652401d0e60887e30c5913..38655afa9fce9e8cc0d5557b584959369821cea6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -891,6 +891,16 @@ static int __devinit m25p_probe(struct s
+@@ -892,6 +892,16 @@ static int __devinit m25p_probe(struct s
                                        part_probes, &parts, 0);
                }
  #endif
index 2c1c75c67f20efbf3911824f3a3806027d1adb1e..78b6c79f48ad3163838b9310f857e284eb128b3a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/ag71xx/ag71xx_main.c
 +++ b/drivers/net/ag71xx/ag71xx_main.c
-@@ -685,6 +685,7 @@ static netdev_tx_t ag71xx_hard_start_xmi
+@@ -686,6 +686,7 @@ err_drop:
  
  static int ag71xx_do_ioctl(struct net_device *dev, struct ifreq *ifr, int cmd)
  {
@@ -8,7 +8,7 @@
        struct ag71xx *ag = netdev_priv(dev);
        int ret;
  
-@@ -716,7 +717,7 @@ static int ag71xx_do_ioctl(struct net_de
+@@ -717,7 +718,7 @@ static int ag71xx_do_ioctl(struct net_de
                if (ag->phy_dev == NULL)
                        break;
  
index 01b7a2e14304586f739035f542f270c56badc2ff..1f27e84dcd7baf17427d5373129b4de8b68ddf2d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/Kconfig
 +++ b/drivers/net/Kconfig
-@@ -2045,6 +2045,8 @@ config ACENIC_OMIT_TIGON_I
+@@ -2168,6 +2168,8 @@ config ACENIC_OMIT_TIGON_I
  
          The safe and default value for this is N.
  
index ebb3b1ddf27a21b899eaeb8db52a7699817592d7..64e52b31c11389a503a4768ba7443a6c76c8f24a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1190,8 +1190,8 @@ static int __xipram do_write_oneword(str
+@@ -1218,8 +1218,8 @@ static int __xipram do_write_oneword(str
                        break;
                }
  
@@ -11,7 +11,7 @@
  
                /* Latency issues. Drop the lock, wait a while and retry */
                UDELAY(map, chip, adr, 1);
-@@ -1207,6 +1207,8 @@ static int __xipram do_write_oneword(str
+@@ -1235,6 +1235,8 @@ static int __xipram do_write_oneword(str
  
                ret = -EIO;
        }
@@ -20,7 +20,7 @@
        xip_enable(map, chip, adr);
   op_done:
        chip->state = FL_READY;
-@@ -1553,7 +1555,6 @@ static int cfi_amdstd_write_buffers(stru
+@@ -1581,7 +1583,6 @@ static int cfi_amdstd_write_buffers(stru
        return 0;
  }
  
@@ -28,7 +28,7 @@
  /*
   * Handle devices with one erase region, that only implement
   * the chip erase command.
-@@ -1617,8 +1618,8 @@ static int __xipram do_erase_chip(struct
+@@ -1645,8 +1646,8 @@ static int __xipram do_erase_chip(struct
                        chip->erase_suspended = 0;
                }
  
@@ -39,7 +39,7 @@
  
                if (time_after(jiffies, timeo)) {
                        printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -1638,6 +1639,7 @@ static int __xipram do_erase_chip(struct
+@@ -1666,6 +1667,7 @@ static int __xipram do_erase_chip(struct
                ret = -EIO;
        }
  
@@ -47,7 +47,7 @@
        chip->state = FL_READY;
        xip_enable(map, chip, adr);
        put_chip(map, chip, adr);
-@@ -1705,9 +1707,9 @@ static int __xipram do_erase_oneblock(st
+@@ -1733,9 +1735,9 @@ static int __xipram do_erase_oneblock(st
                        chip->erase_suspended = 0;
                }
  
@@ -59,7 +59,7 @@
                }
  
                if (time_after(jiffies, timeo)) {
-@@ -1729,6 +1731,7 @@ static int __xipram do_erase_oneblock(st
+@@ -1757,6 +1759,7 @@ static int __xipram do_erase_oneblock(st
                ret = -EIO;
        }
  
index 73800738fea659b574e8a4ba07ebee5220cd4985..969cd1aaeefbab082b7edffe154d1d031d8b5e52 100644 (file)
@@ -35,7 +35,7 @@
  
  /* Atmel chips don't use the same PRI format as AMD chips */
  static void fixup_convert_atmel_pri(struct mtd_info *mtd, void *param)
-@@ -1364,6 +1368,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1392,6 +1396,7 @@ static int cfi_amdstd_write_words(struct
  /*
   * FIXME: interleaved mode not tested, and probably not supported!
   */
@@ -43,7 +43,7 @@
  static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
                                    unsigned long adr, const u_char *buf,
                                    int len)
-@@ -1475,7 +1480,6 @@ static int __xipram do_write_buffer(stru
+@@ -1503,7 +1508,6 @@ static int __xipram do_write_buffer(stru
        return ret;
  }
  
@@ -51,7 +51,7 @@
  static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
                                    size_t *retlen, const u_char *buf)
  {
-@@ -1554,6 +1558,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -1582,6 +1586,7 @@ static int cfi_amdstd_write_buffers(stru
  
        return 0;
  }
index dfaad1e0e7d7839c67a32069d98a8c86c626f6ab..696094fdd854b4611ffe3033fb64baf7bda7766e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/nand/rb4xx_nand.c
 +++ b/drivers/mtd/nand/rb4xx_nand.c
-@@ -218,7 +218,7 @@ static int __init rb4xx_nand_probe(struc
+@@ -220,7 +220,7 @@ static int __init rb4xx_nand_probe(struc
  
        platform_set_drvdata(pdev, info);
  
index 909f2ed9cd94277f18fabaafd701711202e84ac2..5664463771e2c09d732659ec73bcd8377f1a5637 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/Kconfig
 +++ b/drivers/net/Kconfig
-@@ -2068,6 +2068,8 @@ config ACENIC_OMIT_TIGON_I
+@@ -2191,6 +2191,8 @@ config ACENIC_OMIT_TIGON_I
  
          The safe and default value for this is N.
  
index 54879baf1db037f11cfaacea250bf76d67c2cf28..dc1bada6ba52ac4933b69d6c5dd1e865e2661d62 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1223,8 +1223,8 @@ static int __xipram do_write_oneword(str
+@@ -1231,8 +1231,8 @@ static int __xipram do_write_oneword(str
                        break;
                }
  
@@ -11,7 +11,7 @@
  
                /* Latency issues. Drop the lock, wait a while and retry */
                UDELAY(map, chip, adr, 1);
-@@ -1240,6 +1240,8 @@ static int __xipram do_write_oneword(str
+@@ -1248,6 +1248,8 @@ static int __xipram do_write_oneword(str
  
                ret = -EIO;
        }
@@ -20,7 +20,7 @@
        xip_enable(map, chip, adr);
   op_done:
        chip->state = FL_READY;
-@@ -1571,7 +1573,6 @@ static int cfi_amdstd_write_buffers(stru
+@@ -1579,7 +1581,6 @@ static int cfi_amdstd_write_buffers(stru
        return 0;
  }
  
@@ -28,7 +28,7 @@
  /*
   * Handle devices with one erase region, that only implement
   * the chip erase command.
-@@ -1635,8 +1636,8 @@ static int __xipram do_erase_chip(struct
+@@ -1643,8 +1644,8 @@ static int __xipram do_erase_chip(struct
                        chip->erase_suspended = 0;
                }
  
@@ -39,7 +39,7 @@
  
                if (time_after(jiffies, timeo)) {
                        printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -1656,6 +1657,7 @@ static int __xipram do_erase_chip(struct
+@@ -1664,6 +1665,7 @@ static int __xipram do_erase_chip(struct
                ret = -EIO;
        }
  
@@ -47,7 +47,7 @@
        chip->state = FL_READY;
        xip_enable(map, chip, adr);
        put_chip(map, chip, adr);
-@@ -1723,9 +1725,9 @@ static int __xipram do_erase_oneblock(st
+@@ -1731,9 +1733,9 @@ static int __xipram do_erase_oneblock(st
                        chip->erase_suspended = 0;
                }
  
@@ -59,7 +59,7 @@
                }
  
                if (time_after(jiffies, timeo)) {
-@@ -1747,6 +1749,7 @@ static int __xipram do_erase_oneblock(st
+@@ -1755,6 +1757,7 @@ static int __xipram do_erase_oneblock(st
                ret = -EIO;
        }
  
index 047239d5ccc5fe1060f35cb4f2c63a6da456dc88..edd9e4e02629d4f3ebb77501b282fe8aa9beff0a 100644 (file)
  /* makes sure the async qh will become idle */
 --- a/drivers/usb/host/ehci.h
 +++ b/drivers/usb/host/ehci.h
-@@ -131,6 +131,7 @@ struct ehci_hcd {                  /* one per controlle
-       unsigned                need_io_watchdog:1;
+@@ -133,6 +133,7 @@ struct ehci_hcd {                  /* one per controlle
        unsigned                broken_periodic:1;
        unsigned                fs_i_thresh:1;  /* Intel iso scheduling */
+       unsigned                use_dummy_qh:1; /* AMD Frame List table quirk*/
 +      unsigned                has_synopsys_hc_bug:1; /* Synopsys HC */
  
        /* required for usb32 quirk */
index e9226e7a6e7b9379edecf8e4dd408fce79b1af0d..9dca6eabd997cf8b6b1f003251be6ddc10e2fd52 100644 (file)
@@ -35,7 +35,7 @@
  
  /* Atmel chips don't use the same PRI format as AMD chips */
  static void fixup_convert_atmel_pri(struct mtd_info *mtd, void *param)
-@@ -1383,6 +1387,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1391,6 +1395,7 @@ static int cfi_amdstd_write_words(struct
  /*
   * FIXME: interleaved mode not tested, and probably not supported!
   */
@@ -43,7 +43,7 @@
  static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
                                    unsigned long adr, const u_char *buf,
                                    int len)
-@@ -1493,7 +1498,6 @@ static int __xipram do_write_buffer(stru
+@@ -1501,7 +1506,6 @@ static int __xipram do_write_buffer(stru
        return ret;
  }
  
@@ -51,7 +51,7 @@
  static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
                                    size_t *retlen, const u_char *buf)
  {
-@@ -1572,6 +1576,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -1580,6 +1584,7 @@ static int cfi_amdstd_write_buffers(stru
  
        return 0;
  }
index eb922dd43166302ea0ebfe6490637d52f90164ca..1d9bf9e3b5eb54a41e402d92696164167defd077 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/Makefile
 +++ b/drivers/Makefile
-@@ -45,8 +45,8 @@ obj-y                                += macintosh/
+@@ -46,8 +46,8 @@ obj-y                                += macintosh/
  obj-$(CONFIG_IDE)             += ide/
  obj-$(CONFIG_SCSI)            += scsi/
  obj-$(CONFIG_ATA)             += ata/
index 4b0fe30906337b2452f50553c2da842713c7f42e..cfbea70c53d8c0b7a9ec66cf245afd655e3b20c1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -329,6 +329,13 @@ config LEDS_TRIGGERS
+@@ -347,6 +347,13 @@ config LEDS_TRIGGERS
  
  if LEDS_TRIGGERS
  
@@ -16,7 +16,7 @@
  config LEDS_TRIGGER_TIMER
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -31,6 +31,7 @@ obj-$(CONFIG_LEDS_DA903X)            += leds-da903
+@@ -33,6 +33,7 @@ obj-$(CONFIG_LEDS_DA903X)            += leds-da903
  obj-$(CONFIG_LEDS_WM831X_STATUS)      += leds-wm831x-status.o
  obj-$(CONFIG_LEDS_WM8350)             += leds-wm8350.o
  obj-$(CONFIG_LEDS_PWM)                        += leds-pwm.o
index d53ff8a3c19e407575f109b986159db27d8b0250..6614fb933149ee144b2ab4272dcce715efb30cac 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -336,6 +336,10 @@ config LEDS_WNDR3700_USB
+@@ -354,6 +354,10 @@ config LEDS_WNDR3700_USB
          This option enables support for the USB LED found on the
          NETGEAR WNDR3700 board.
  
@@ -13,7 +13,7 @@
  config LEDS_TRIGGER_TIMER
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -38,6 +38,7 @@ obj-$(CONFIG_LEDS_LT3593)            += leds-lt359
+@@ -40,6 +40,7 @@ obj-$(CONFIG_LEDS_LT3593)            += leds-lt359
  obj-$(CONFIG_LEDS_ADP5520)            += leds-adp5520.o
  obj-$(CONFIG_LEDS_DELL_NETBOOKS)      += dell-led.o
  obj-$(CONFIG_LEDS_MC13783)            += leds-mc13783.o
index dfaad1e0e7d7839c67a32069d98a8c86c626f6ab..696094fdd854b4611ffe3033fb64baf7bda7766e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/nand/rb4xx_nand.c
 +++ b/drivers/mtd/nand/rb4xx_nand.c
-@@ -218,7 +218,7 @@ static int __init rb4xx_nand_probe(struc
+@@ -220,7 +220,7 @@ static int __init rb4xx_nand_probe(struc
  
        platform_set_drvdata(pdev, info);