ipq40xx: Adjust SoC name of AVM Fritz!Box 4040
authorSven Eckelmann <sven@narfation.org>
Mon, 19 Mar 2018 19:53:09 +0000 (20:53 +0100)
committerMathias Kresin <dev@kresin.me>
Fri, 23 Mar 2018 19:31:49 +0000 (20:31 +0100)
The AVM Fritz!Box 4040 uses an IPQ4018 as SoC and not an IPQ4019. The DTS
must be adjusted to reflect this.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4018-fritz4040.dts [new file with mode: 0644]
target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4019-fritz4040.dts [deleted file]
target/linux/ipq40xx/image/Makefile
target/linux/ipq40xx/patches-4.14/069-arm-boot-add-dts-files.patch

diff --git a/target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4018-fritz4040.dts b/target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4018-fritz4040.dts
new file mode 100644 (file)
index 0000000..4b5cbca
--- /dev/null
@@ -0,0 +1,322 @@
+/* Copyright (c) 2015, The Linux Foundation. All rights reserved.
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include "qcom-ipq4019.dtsi"
+#include "qcom-ipq4019-bus.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "AVM FRITZ!Box 4040";
+       compatible = "avm,fritzbox-4040", "qcom,ipq4019";
+
+       aliases {
+               led-boot = &power;
+               led-failsafe = &flash;
+               led-running = &power;
+               led-upgrade = &flash;
+       };
+
+       reserved-memory {
+               #address-cells = <0x1>;
+               #size-cells = <0x1>;
+               ranges;
+
+               tz_apps@87b80000 {
+                       reg = <0x87b80000 0x280000>;
+                       reusable;
+               };
+
+               smem@87e00000 {
+                       reg = <0x87e00000 0x080000>;
+                       no-map;
+               };
+
+               tz@87e80000 {
+                       reg = <0x87e80000 0x180000>;
+                       no-map;
+               };
+       };
+
+       soc {
+               mdio@90000 {
+                       status = "okay";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               usb2@60f8800 {
+                       status = "okay";
+               };
+
+               serial@78af000 {
+                       pinctrl-0 = <&serial_pins>;
+                       pinctrl-names = "default";
+                       status = "okay";
+               };
+
+               usb3@8af8800 {
+                       status = "okay";
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               wifi@a000000 {
+                       status = "okay";
+               };
+
+               wifi@a800000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               qca8075: ess-switch@c000000 {
+                       status = "okay";
+
+                       #gpio-cells = <2>;
+                       gpio-controller;
+
+                       enable-usb-power {
+                               gpio-hog;
+                               line-name = "enable USB3 power";
+                               gpios = <7 GPIO_ACTIVE_HIGH>;
+                               output-high;
+                       };
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+       };
+
+       gpio-keys {
+               compatible = "gpio-keys";
+
+               wlan {
+                       label = "wlan";
+                       gpios = <&tlmm 58 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RFKILL>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               wlan {
+                       label = "fritz4040:green:wlan";
+                       gpios = <&qca8075 1 GPIO_ACTIVE_HIGH>;
+               };
+
+               panic: info_red {
+                       label = "fritz4040:red:info";
+                       gpios = <&qca8075 3 GPIO_ACTIVE_HIGH>;
+                       panic-indicator;
+               };
+
+               wan {
+                       label = "fritz4040:green:wan";
+                       gpios = <&qca8075 5 GPIO_ACTIVE_HIGH>;
+               };
+
+               power: power {
+                       label = "fritz4040:green:power";
+                       gpios = <&qca8075 11 GPIO_ACTIVE_HIGH>;
+               };
+
+               lan {
+                       label = "fritz4040:green:lan";
+                       gpios = <&qca8075 13 GPIO_ACTIVE_HIGH>;
+               };
+
+               flash: info_amber {
+                       label = "fritz4040:amber:info";
+                       gpios = <&qca8075 15 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               mux {
+                       function = "blsp_spi0";
+                       pins = "gpio55", "gpio56", "gpio57";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+
+               mux_cs {
+                       function = "gpio";
+                       pins = "gpio54";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&spi_0 { /* BLSP1 QUP1 */
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
+
+       mx25l25635f@0 {
+               compatible = "jedec,spi-nor";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+               status = "okay";
+               m25p,fast-read;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition0@0 {
+                               label = "SBL1";
+                               reg = <0x00000000 0x00040000>;
+                               read-only;
+                       };
+                       partition1@40000 {
+                               label = "MIBIB";
+                               reg = <0x00040000 0x00020000>;
+                               read-only;
+                       };
+                       partition2@60000 {
+                               label = "QSEE";
+                               reg = <0x00060000 0x00060000>;
+                               read-only;
+                       };
+                       partition3@c0000 {
+                               label = "CDT";
+                               reg = <0x000c0000 0x00010000>;
+                               read-only;
+                       };
+                       partition4@d0000 {
+                               label = "DDRPARAMS";
+                               reg = <0x000d0000 0x00010000>;
+                               read-only;
+                       };
+                       partition5@e0000 {
+                               label = "APPSBLENV"; /* uboot env - empty */
+                               reg = <0x000e0000 0x00010000>;
+                               read-only;
+                       };
+                       partition6@f0000 {
+                               label = "urlader"; /* APPSBL */
+                               reg = <0x000f0000 0x0002dc000>;
+                               read-only;
+                       };
+                       partition7@11dc00 {
+                               /* make a backup of this partition! */
+                               label = "urlader_config";
+                               reg = <0x0011dc00 0x00002400>;
+                               read-only;
+                       };
+                       partition8@120000 {
+                               label = "tffs1";
+                               reg = <0x00120000 0x00080000>;
+                               read-only;
+                       };
+                       partition9@1a0000 {
+                               label = "tffs2";
+                               reg = <0x001a0000 0x00080000>;
+                               read-only;
+                       };
+                       partition10@220000 {
+                               label = "uboot";
+                               reg = <0x00220000 0x00080000>;
+                               read-only;
+                       };
+                       partition11@2A0000 {
+                               label = "firmware";
+                               reg = <0x002a0000 0x01c60000>;
+                       };
+                       partition12@1f00000 {
+                               label = "jffs2";
+                               reg = <0x01f00000 0x00100000>;
+                       };
+               };
+       };
+};
+
+&usb3_ss_phy {
+       status = "okay";
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&usb2_hs_phy {
+       status = "okay";
+};
diff --git a/target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4019-fritz4040.dts b/target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4019-fritz4040.dts
deleted file mode 100644 (file)
index 4b5cbca..0000000
+++ /dev/null
@@ -1,322 +0,0 @@
-/* Copyright (c) 2015, The Linux Foundation. All rights reserved.
- *
- * Permission to use, copy, modify, and/or distribute this software for any
- * purpose with or without fee is hereby granted, provided that the above
- * copyright notice and this permission notice appear in all copies.
- *
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
- * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
- * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
- * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- *
- */
-
-#include "qcom-ipq4019.dtsi"
-#include "qcom-ipq4019-bus.dtsi"
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/soc/qcom,tcsr.h>
-
-/ {
-       model = "AVM FRITZ!Box 4040";
-       compatible = "avm,fritzbox-4040", "qcom,ipq4019";
-
-       aliases {
-               led-boot = &power;
-               led-failsafe = &flash;
-               led-running = &power;
-               led-upgrade = &flash;
-       };
-
-       reserved-memory {
-               #address-cells = <0x1>;
-               #size-cells = <0x1>;
-               ranges;
-
-               tz_apps@87b80000 {
-                       reg = <0x87b80000 0x280000>;
-                       reusable;
-               };
-
-               smem@87e00000 {
-                       reg = <0x87e00000 0x080000>;
-                       no-map;
-               };
-
-               tz@87e80000 {
-                       reg = <0x87e80000 0x180000>;
-                       no-map;
-               };
-       };
-
-       soc {
-               mdio@90000 {
-                       status = "okay";
-               };
-
-               ess-psgmii@98000 {
-                       status = "okay";
-               };
-
-               tcsr@1949000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1949000 0x100>;
-                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
-               };
-
-               tcsr@194b000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x194b000 0x100>;
-                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
-               };
-
-               ess_tcsr@1953000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1953000 0x1000>;
-                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
-               };
-
-               tcsr@1957000 {
-                       compatible = "qcom,tcsr";
-                       reg = <0x1957000 0x100>;
-                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
-               };
-
-               usb2@60f8800 {
-                       status = "okay";
-               };
-
-               serial@78af000 {
-                       pinctrl-0 = <&serial_pins>;
-                       pinctrl-names = "default";
-                       status = "okay";
-               };
-
-               usb3@8af8800 {
-                       status = "okay";
-               };
-
-               crypto@8e3a000 {
-                       status = "okay";
-               };
-
-               wifi@a000000 {
-                       status = "okay";
-               };
-
-               wifi@a800000 {
-                       status = "okay";
-               };
-
-               watchdog@b017000 {
-                       status = "okay";
-               };
-
-               qca8075: ess-switch@c000000 {
-                       status = "okay";
-
-                       #gpio-cells = <2>;
-                       gpio-controller;
-
-                       enable-usb-power {
-                               gpio-hog;
-                               line-name = "enable USB3 power";
-                               gpios = <7 GPIO_ACTIVE_HIGH>;
-                               output-high;
-                       };
-               };
-
-               edma@c080000 {
-                       status = "okay";
-               };
-       };
-
-       gpio-keys {
-               compatible = "gpio-keys";
-
-               wlan {
-                       label = "wlan";
-                       gpios = <&tlmm 58 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RFKILL>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               wlan {
-                       label = "fritz4040:green:wlan";
-                       gpios = <&qca8075 1 GPIO_ACTIVE_HIGH>;
-               };
-
-               panic: info_red {
-                       label = "fritz4040:red:info";
-                       gpios = <&qca8075 3 GPIO_ACTIVE_HIGH>;
-                       panic-indicator;
-               };
-
-               wan {
-                       label = "fritz4040:green:wan";
-                       gpios = <&qca8075 5 GPIO_ACTIVE_HIGH>;
-               };
-
-               power: power {
-                       label = "fritz4040:green:power";
-                       gpios = <&qca8075 11 GPIO_ACTIVE_HIGH>;
-               };
-
-               lan {
-                       label = "fritz4040:green:lan";
-                       gpios = <&qca8075 13 GPIO_ACTIVE_HIGH>;
-               };
-
-               flash: info_amber {
-                       label = "fritz4040:amber:info";
-                       gpios = <&qca8075 15 GPIO_ACTIVE_HIGH>;
-               };
-       };
-};
-
-&tlmm {
-       serial_pins: serial_pinmux {
-               mux {
-                       pins = "gpio60", "gpio61";
-                       function = "blsp_uart0";
-                       bias-disable;
-               };
-       };
-
-       spi_0_pins: spi_0_pinmux {
-               mux {
-                       function = "blsp_spi0";
-                       pins = "gpio55", "gpio56", "gpio57";
-                       drive-strength = <12>;
-                       bias-disable;
-               };
-
-               mux_cs {
-                       function = "gpio";
-                       pins = "gpio54";
-                       drive-strength = <2>;
-                       bias-disable;
-                       output-high;
-               };
-       };
-};
-
-&cryptobam {
-       status = "okay";
-};
-
-&blsp_dma {
-       status = "okay";
-};
-
-&spi_0 { /* BLSP1 QUP1 */
-       pinctrl-0 = <&spi_0_pins>;
-       pinctrl-names = "default";
-       status = "okay";
-       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
-
-       mx25l25635f@0 {
-               compatible = "jedec,spi-nor";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               reg = <0>;
-               spi-max-frequency = <24000000>;
-               status = "okay";
-               m25p,fast-read;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition0@0 {
-                               label = "SBL1";
-                               reg = <0x00000000 0x00040000>;
-                               read-only;
-                       };
-                       partition1@40000 {
-                               label = "MIBIB";
-                               reg = <0x00040000 0x00020000>;
-                               read-only;
-                       };
-                       partition2@60000 {
-                               label = "QSEE";
-                               reg = <0x00060000 0x00060000>;
-                               read-only;
-                       };
-                       partition3@c0000 {
-                               label = "CDT";
-                               reg = <0x000c0000 0x00010000>;
-                               read-only;
-                       };
-                       partition4@d0000 {
-                               label = "DDRPARAMS";
-                               reg = <0x000d0000 0x00010000>;
-                               read-only;
-                       };
-                       partition5@e0000 {
-                               label = "APPSBLENV"; /* uboot env - empty */
-                               reg = <0x000e0000 0x00010000>;
-                               read-only;
-                       };
-                       partition6@f0000 {
-                               label = "urlader"; /* APPSBL */
-                               reg = <0x000f0000 0x0002dc000>;
-                               read-only;
-                       };
-                       partition7@11dc00 {
-                               /* make a backup of this partition! */
-                               label = "urlader_config";
-                               reg = <0x0011dc00 0x00002400>;
-                               read-only;
-                       };
-                       partition8@120000 {
-                               label = "tffs1";
-                               reg = <0x00120000 0x00080000>;
-                               read-only;
-                       };
-                       partition9@1a0000 {
-                               label = "tffs2";
-                               reg = <0x001a0000 0x00080000>;
-                               read-only;
-                       };
-                       partition10@220000 {
-                               label = "uboot";
-                               reg = <0x00220000 0x00080000>;
-                               read-only;
-                       };
-                       partition11@2A0000 {
-                               label = "firmware";
-                               reg = <0x002a0000 0x01c60000>;
-                       };
-                       partition12@1f00000 {
-                               label = "jffs2";
-                               reg = <0x01f00000 0x00100000>;
-                       };
-               };
-       };
-};
-
-&usb3_ss_phy {
-       status = "okay";
-};
-
-&usb3_hs_phy {
-       status = "okay";
-};
-
-&usb2_hs_phy {
-       status = "okay";
-};
index 5c1ae7fe1f1dc53aa8c0383cb14b15eb11f3efe1..125b3bf8e2c68492eb849341b9fa2a986a9c78f6 100644 (file)
@@ -54,7 +54,7 @@ TARGET_DEVICES += asus_rt-ac58u
 
 define Device/avm_fritzbox-4040
        $(call Device/FitImageLzma)
 
 define Device/avm_fritzbox-4040
        $(call Device/FitImageLzma)
-       DEVICE_DTS := qcom-ipq4019-fritz4040
+       DEVICE_DTS := qcom-ipq4018-fritz4040
        BOARD_NAME := fritz4040
        DEVICE_TITLE := AVM Fritz!Box 4040
        IMAGE_SIZE := 29753344
        BOARD_NAME := fritz4040
        DEVICE_TITLE := AVM Fritz!Box 4040
        IMAGE_SIZE := 29753344
index d7cab052956c2e25ee285ef1cbc48e8bef5ed638..c0bdd87fcce2c1622eb16e1c62065a472200aed5 100644 (file)
@@ -15,10 +15,10 @@ Signed-off-by: John Crispin <john@phrozen.org>
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
 +      qcom-ipq4018-a42.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
 +      qcom-ipq4018-a42.dtb \
++      qcom-ipq4018-fritz4040.dtb \
 +      qcom-ipq4018-rt-ac58u.dtb \
        qcom-ipq4019-ap.dk01.1-c1.dtb \
 +      qcom-ipq4019-ap.dk04.1-c1.dtb \
 +      qcom-ipq4018-rt-ac58u.dtb \
        qcom-ipq4019-ap.dk01.1-c1.dtb \
 +      qcom-ipq4019-ap.dk04.1-c1.dtb \
-+      qcom-ipq4019-fritz4040.dtb \
 +      qcom-ipq4028-wpj428.dtb \
 +      qcom-ipq4029-gl-b1300.dtb \
 +      qcom-ipq4029-mr33.dtb \
 +      qcom-ipq4028-wpj428.dtb \
 +      qcom-ipq4029-gl-b1300.dtb \
 +      qcom-ipq4029-mr33.dtb \