kernel: mark compression modules as hiddden to obsolete the compressor kconfig hack
authorFelix Fietkau <nbd@nbd.name>
Thu, 4 Aug 2016 17:23:47 +0000 (19:23 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 4 Aug 2016 18:53:02 +0000 (20:53 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/lib.mk
target/linux/generic/patches-3.18/262-compressor_kconfig_hack.patch [deleted file]
target/linux/generic/patches-4.1/262-compressor_kconfig_hack.patch [deleted file]
target/linux/generic/patches-4.4/262-compressor_kconfig_hack.patch [deleted file]

index 9d35e42e24dd721efa7577c27322489492852edf..c5148ce4870efd30db88d3d12c1ad16c98a4a5e4 100644 (file)
@@ -104,6 +104,7 @@ define KernelPackage/lib-lzo
   KCONFIG:= \
        CONFIG_LZO_COMPRESS \
        CONFIG_LZO_DECOMPRESS
   KCONFIG:= \
        CONFIG_LZO_COMPRESS \
        CONFIG_LZO_DECOMPRESS
+  HIDDEN:=1
   FILES:= \
        $(LINUX_DIR)/lib/lzo/lzo_compress.ko \
        $(LINUX_DIR)/lib/lzo/lzo_decompress.ko
   FILES:= \
        $(LINUX_DIR)/lib/lzo/lzo_compress.ko \
        $(LINUX_DIR)/lib/lzo/lzo_decompress.ko
@@ -120,6 +121,7 @@ $(eval $(call KernelPackage,lib-lzo))
 define KernelPackage/lib-lz4
   SUBMENU:=$(LIB_MENU)
   TITLE:=LZ4 support
 define KernelPackage/lib-lz4
   SUBMENU:=$(LIB_MENU)
   TITLE:=LZ4 support
+  HIDDEN:=1
   KCONFIG:= \
        CONFIG_LZ4_COMPRESS \
        CONFIG_LZ4_DECOMPRESS
   KCONFIG:= \
        CONFIG_LZ4_COMPRESS \
        CONFIG_LZ4_DECOMPRESS
@@ -196,6 +198,7 @@ $(eval $(call KernelPackage,lib-textsearch))
 define KernelPackage/lib-zlib
   SUBMENU:=$(LIB_MENU)
   TITLE:=Zlib support
 define KernelPackage/lib-zlib
   SUBMENU:=$(LIB_MENU)
   TITLE:=Zlib support
+  HIDDEN:=1
   KCONFIG:= \
     CONFIG_ZLIB_DEFLATE \
     CONFIG_ZLIB_INFLATE
   KCONFIG:= \
     CONFIG_ZLIB_DEFLATE \
     CONFIG_ZLIB_INFLATE
diff --git a/target/linux/generic/patches-3.18/262-compressor_kconfig_hack.patch b/target/linux/generic/patches-3.18/262-compressor_kconfig_hack.patch
deleted file mode 100644 (file)
index 51b4fc8..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -205,25 +205,25 @@ config RANDOM32_SELFTEST
- # compression support is select'ed if needed
- #
- config ZLIB_INFLATE
--      tristate
-+      tristate "ZLIB inflate support"
- config ZLIB_DEFLATE
--      tristate
-+      tristate "ZLIB deflate support"
- config LZO_COMPRESS
--      tristate
-+      tristate "LZO compress support"
- config LZO_DECOMPRESS
--      tristate
-+      tristate "LZO decompress support"
- config LZ4_COMPRESS
--      tristate
-+      tristate "LZ4 compress support"
- config LZ4HC_COMPRESS
--      tristate
-+      tristate "LZ4HC compress support"
- config LZ4_DECOMPRESS
--      tristate
-+      tristate "LZ4 decompress support"
- source "lib/xz/Kconfig"
diff --git a/target/linux/generic/patches-4.1/262-compressor_kconfig_hack.patch b/target/linux/generic/patches-4.1/262-compressor_kconfig_hack.patch
deleted file mode 100644 (file)
index 771c167..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -213,25 +213,25 @@ config RANDOM32_SELFTEST
- # compression support is select'ed if needed
- #
- config ZLIB_INFLATE
--      tristate
-+      tristate "ZLIB inflate support"
- config ZLIB_DEFLATE
--      tristate
-+      tristate "ZLIB deflate support"
- config LZO_COMPRESS
--      tristate
-+      tristate "LZO compress support"
- config LZO_DECOMPRESS
--      tristate
-+      tristate "LZO decompress support"
- config LZ4_COMPRESS
--      tristate
-+      tristate "LZ4 compress support"
- config LZ4HC_COMPRESS
--      tristate
-+      tristate "LZ4HC compress support"
- config LZ4_DECOMPRESS
--      tristate
-+      tristate "LZ4 decompress support"
- source "lib/xz/Kconfig"
diff --git a/target/linux/generic/patches-4.4/262-compressor_kconfig_hack.patch b/target/linux/generic/patches-4.4/262-compressor_kconfig_hack.patch
deleted file mode 100644 (file)
index edb9ff7..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -218,26 +218,26 @@ config 842_DECOMPRESS
-       tristate
- config ZLIB_INFLATE
--      tristate
-+      tristate "ZLIB inflate support"
- config ZLIB_DEFLATE
--      tristate
-+      tristate "ZLIB deflate support"
-       select BITREVERSE
- config LZO_COMPRESS
--      tristate
-+      tristate "LZO compress support"
- config LZO_DECOMPRESS
--      tristate
-+      tristate "LZO decompress support"
- config LZ4_COMPRESS
--      tristate
-+      tristate "LZ4 compress support"
- config LZ4HC_COMPRESS
--      tristate
-+      tristate "LZ4HC compress support"
- config LZ4_DECOMPRESS
--      tristate
-+      tristate "LZ4 decompress support"
- source "lib/xz/Kconfig"