ramips: correct vendor name for COMFAST/Joowin
authorRodrigo Araujo <araujo.rm@gmail.com>
Tue, 18 Jan 2022 14:43:28 +0000 (14:43 +0000)
committerDavid Bauer <mail@david-bauer.net>
Sat, 22 Jan 2022 00:17:04 +0000 (01:17 +0100)
When Joowin WR758AC V1 and V2 devices were added, they should have been
added with the primary manufacturer name which is COMFAST, since Joowin
is just an alternate vendor name on some coutries or stores.

Fix this by changing the the vendor name on the respective files and set
Joowin as ALT0 variants while ensuring compatibility for early users.
Also adjust the model names to better follow the naming rules.

As a side effect, fix mt76x8 network script which was left incorrectly
unsorted on the case block conditions.

Fixes: 766733e172 ("ramips: add support for Joowin WR758AC V1 and V2")
Signed-off-by: Rodrigo Araujo <araujo.rm@gmail.com>
target/linux/ramips/dts/mt7628an_comfast_cf-wr758ac-v1.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7628an_comfast_cf-wr758ac-v2.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7628an_comfast_cf-wr758ac.dtsi [new file with mode: 0644]
target/linux/ramips/dts/mt7628an_joowin_jw-wr758ac-v1.dts [deleted file]
target/linux/ramips/dts/mt7628an_joowin_jw-wr758ac-v2.dts [deleted file]
target/linux/ramips/dts/mt7628an_joowin_jw-wr758ac.dtsi [deleted file]
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/mt76x8/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7628an_comfast_cf-wr758ac-v1.dts b/target/linux/ramips/dts/mt7628an_comfast_cf-wr758ac-v1.dts
new file mode 100644 (file)
index 0000000..b474035
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_comfast_cf-wr758ac.dtsi"
+
+/ {
+       compatible = "comfast,cf-wr758ac-v1", "mediatek,mt7628an-soc";
+       model = "COMFAST CF-WR758AC V1";
+};
diff --git a/target/linux/ramips/dts/mt7628an_comfast_cf-wr758ac-v2.dts b/target/linux/ramips/dts/mt7628an_comfast_cf-wr758ac-v2.dts
new file mode 100644 (file)
index 0000000..bc476f2
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_comfast_cf-wr758ac.dtsi"
+
+/ {
+       compatible = "comfast,cf-wr758ac-v2", "mediatek,mt7628an-soc";
+       model = "COMFAST CF-WR758AC V2";
+};
diff --git a/target/linux/ramips/dts/mt7628an_comfast_cf-wr758ac.dtsi b/target/linux/ramips/dts/mt7628an_comfast_cf-wr758ac.dtsi
new file mode 100644 (file)
index 0000000..6ac53ad
--- /dev/null
@@ -0,0 +1,124 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       compatible = "comfast,cf-wr758ac", "mediatek,mt7628an-soc";
+
+       keys {
+               compatible = "gpio-keys";
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               wifi-high {
+                       label = "blue:wifi-high";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi-med {
+                       label = "blue:wifi-med";
+                       gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi-low {
+                       label = "blue:wifi-low";
+                       gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "refclk", "wdt", "wled_an";
+               function = "gpio";
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <50000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0x7b0000>;
+                       };
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mediatek,mtd-eeprom = <&factory 0x0>;
+};
+
+&ethernet {
+       nvmem-cells = <&macaddr_factory_e000>;
+       nvmem-cell-names = "mac-address";
+};
+
+&esw {
+       mediatek,portdisable = <0x2f>;
+};
+
+&factory {
+       compatible = "nvmem-cells";
+       #address-cells = <1>;
+       #size-cells = <1>;
+
+       macaddr_factory_e000: macaddr@e000 {
+               reg = <0xe000 0x6>;
+       };
+};
diff --git a/target/linux/ramips/dts/mt7628an_joowin_jw-wr758ac-v1.dts b/target/linux/ramips/dts/mt7628an_joowin_jw-wr758ac-v1.dts
deleted file mode 100644 (file)
index c3b52c8..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7628an_joowin_jw-wr758ac.dtsi"
-
-/ {
-       compatible = "joowin,jw-wr758ac-v1", "mediatek,mt7628an-soc";
-       model = "Joowin WR758AC V1";
-};
diff --git a/target/linux/ramips/dts/mt7628an_joowin_jw-wr758ac-v2.dts b/target/linux/ramips/dts/mt7628an_joowin_jw-wr758ac-v2.dts
deleted file mode 100644 (file)
index 1cc0d5d..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7628an_joowin_jw-wr758ac.dtsi"
-
-/ {
-       compatible = "joowin,jw-wr758ac-v2", "mediatek,mt7628an-soc";
-       model = "Joowin WR758AC V2";
-};
diff --git a/target/linux/ramips/dts/mt7628an_joowin_jw-wr758ac.dtsi b/target/linux/ramips/dts/mt7628an_joowin_jw-wr758ac.dtsi
deleted file mode 100644 (file)
index 97845cf..0000000
+++ /dev/null
@@ -1,124 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7628an.dtsi"
-
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/gpio/gpio.h>
-
-/ {
-       compatible = "joowin,jw-wr758ac", "mediatek,mt7628an-soc";
-
-       keys {
-               compatible = "gpio-keys";
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               wifi-high {
-                       label = "blue:wifi-high";
-                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
-               };
-
-               wifi-med {
-                       label = "blue:wifi-med";
-                       gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
-               };
-
-               wifi-low {
-                       label = "blue:wifi-low";
-                       gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
-               };
-       };
-};
-
-&state_default {
-       gpio {
-               groups = "refclk", "wdt", "wled_an";
-               function = "gpio";
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x8000>;
-               ieee80211-freq-limit = <5000000 6000000>;
-       };
-};
-
-&spi0 {
-       status = "okay";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <50000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x0 0x30000>;
-                               read-only;
-                       };
-
-                       partition@30000 {
-                               label = "u-boot-env";
-                               reg = <0x30000 0x10000>;
-                               read-only;
-                       };
-
-                       factory: partition@40000 {
-                               label = "factory";
-                               reg = <0x40000 0x10000>;
-                               read-only;
-                       };
-
-                       partition@50000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x50000 0x7b0000>;
-                       };
-               };
-       };
-};
-
-&wmac {
-       status = "okay";
-
-       mediatek,mtd-eeprom = <&factory 0x0>;
-};
-
-&ethernet {
-       nvmem-cells = <&macaddr_factory_e000>;
-       nvmem-cell-names = "mac-address";
-};
-
-&esw {
-       mediatek,portdisable = <0x2f>;
-};
-
-&factory {
-       compatible = "nvmem-cells";
-       #address-cells = <1>;
-       #size-cells = <1>;
-
-       macaddr_factory_e000: macaddr@e000 {
-               reg = <0xe000 0x6>;
-       };
-};
index 29c261368507632a9dfa03f02ea1d2e0c89b2f36..59559c4164ecbac856859ce1b3ecfb1046a50412 100644 (file)
@@ -79,6 +79,32 @@ define Device/buffalo_wcr-1166ds
 endef
 TARGET_DEVICES += buffalo_wcr-1166ds
 
+define Device/comfast_cf-wr758ac
+  IMAGE_SIZE := 7872k
+  DEVICE_VENDOR := COMFAST
+  DEVICE_MODEL := CF-WR758AC
+  DEVICE_ALT0_VENDOR := Joowin
+  DEVICE_ALT0_MODEL := JW-WR758AC
+endef
+
+define Device/comfast_cf-wr758ac-v1
+  $(Device/comfast_cf-wr758ac)
+  DEVICE_PACKAGES := kmod-mt76x2
+  DEVICE_VARIANT := V1
+  DEVICE_ALT0_VARIANT := V1
+  SUPPORTED_DEVICES += joowin,jw-wr758ac-v1
+endef
+TARGET_DEVICES += comfast_cf-wr758ac-v1
+
+define Device/comfast_cf-wr758ac-v2
+  $(Device/comfast_cf-wr758ac)
+  DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
+  DEVICE_VARIANT := V2
+  DEVICE_ALT0_VARIANT := V2
+  SUPPORTED_DEVICES += joowin,jw-wr758ac-v2
+endef
+TARGET_DEVICES += comfast_cf-wr758ac-v2
+
 define Device/cudy_wr1000
   IMAGE_SIZE := 7872k
   IMAGES += factory.bin
@@ -220,26 +246,6 @@ define Device/iptime_a604m
 endef
 TARGET_DEVICES += iptime_a604m
 
-define Device/joowin_jw-wr758ac
-  IMAGE_SIZE := 7872k
-  DEVICE_VENDOR := Joowin
-  DEVICE_MODEL := WR758AC
-endef
-
-define Device/joowin_jw-wr758ac-v1
-  $(Device/joowin_jw-wr758ac)
-  DEVICE_PACKAGES := kmod-mt76x2
-  DEVICE_VARIANT := V1
-endef
-TARGET_DEVICES += joowin_jw-wr758ac-v1
-
-define Device/joowin_jw-wr758ac-v2
-  $(Device/joowin_jw-wr758ac)
-  DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
-  DEVICE_VARIANT := V2
-endef
-TARGET_DEVICES += joowin_jw-wr758ac-v2
-
 define Device/jotale_js76x8
   DEVICE_VENDOR := Jotale
   DEVICE_MODEL := JS76x8
index 43d2647cf030c2504928a79a3775ade420613002..ab068ce1504dff454c48d8cab4f77f2dfd7a8ecb 100644 (file)
@@ -53,6 +53,13 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "3:lan" "4:wan" "6@eth0"
                ;;
+       comfast,cf-wr758ac-v1|\
+       comfast,cf-wr758ac-v2|\
+       tplink,tl-wr902ac-v3|\
+       wavlink,wl-wn576a2)
+               ucidef_add_switch "switch0" \
+                       "4:lan" "6@eth0"
+               ;;
        cudy,wr1000)
                ucidef_add_switch "switch0" \
                        "2:lan:2" "3:lan:1" "4:wan" "6@eth0"
@@ -129,13 +136,6 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "2:lan" "3:wan" "6@eth0"
                ;;
-       joowin,jw-wr758ac-v1|\
-       joowin,jw-wr758ac-v2|\
-       tplink,tl-wr902ac-v3|\
-       wavlink,wl-wn576a2)
-               ucidef_add_switch "switch0" \
-                       "4:lan" "6@eth0"
-               ;;
        vocore,vocore2|\
        vocore,vocore2-lite)
                ucidef_add_switch "switch0" \