mac80211: Fix wpa_supplicant config removal ubus call
authorSven Eckelmann <sven@narfation.org>
Thu, 22 Oct 2020 08:52:08 +0000 (10:52 +0200)
committerDavid Bauer <mail@david-bauer.net>
Tue, 27 Oct 2020 23:11:12 +0000 (00:11 +0100)
If mac80211_setup_supplicant() is called with enabled=0 then it should just
destroy the interface and remove the configuration from wpa_supplicant. But
the ubus method call always returned

  Command failed: Method not found

because the actual name of the method is "config_remove".

Fixes: b5516603dd90 ("mac80211: more wifi reconf related fixes")
Signed-off-by: Sven Eckelmann <sven@narfation.org>
[bump PKG_RELEASE]
Signed-off-by: David Bauer <mail@david-bauer.net>
package/kernel/mac80211/Makefile
package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh

index bf88484b78aab84fdecaa5425eb168bf3a6a6531..8448350acf5ee0d17bfb64ef042d8993dee16aab 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=5.8-1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.8/
 PKG_HASH:=19b4174d89bf11ee221458e11f1e8dace26558498774b823051156f522d2036b
 
index 11ea700b98d85d2ce5ade63af7613d1a4e56bf39..6ca12084cf5041844ffa39c547d8ee422948fe94 100644 (file)
@@ -627,7 +627,7 @@ mac80211_setup_supplicant() {
        local spobj="$(ubus -S list | grep wpa_supplicant.${ifname})"
 
        [ "$enable" = 0 ] && {
-               ubus call wpa_supplicant.${phy} config_del "{\"iface\":\"$ifname\"}"
+               ubus call wpa_supplicant.${phy} config_remove "{\"iface\":\"$ifname\"}"
                ip link set dev "$ifname" down
                iw dev "$ifname" del
                return 0