lantiq: add support for ZTE H201L
authorLuka Perkov <luka@openwrt.org>
Thu, 19 Sep 2013 00:50:44 +0000 (00:50 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 19 Sep 2013 00:50:44 +0000 (00:50 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38048

target/linux/lantiq/base-files/etc/uci-defaults/01_leds [changed mode: 0755->0644]
target/linux/lantiq/base-files/etc/uci-defaults/02_network [changed mode: 0755->0644]
target/linux/lantiq/dts/H201L.dts [new file with mode: 0644]
target/linux/lantiq/image/Makefile
target/linux/lantiq/xway/profiles/zte.mk [new file with mode: 0644]

old mode 100755 (executable)
new mode 100644 (file)
index 6b0093c..a5cf212
@@ -84,6 +84,12 @@ GR7000)
        ucidef_set_interface_wan "eth0"
        uci set network.lan.ifname=''
        ;;
+
+H201L)
+       ucidef_set_interface_lan "eth0.1"
+       ucidef_add_switch "switch0" "1" "1"
+       ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4t"
+       ;;
 esac
 
 [ -z "$(ls /lib/modules/`uname -r`/ltq_atm*)" ] || set_atm_wan "$vpi" "$vci" "$encaps" "$payload"
diff --git a/target/linux/lantiq/dts/H201L.dts b/target/linux/lantiq/dts/H201L.dts
new file mode 100644 (file)
index 0000000..5cb5612
--- /dev/null
@@ -0,0 +1,139 @@
+/dts-v1/;
+
+/include/ "ar9.dtsi"
+
+/ {
+       model = "H201L - ZTE H210L";
+
+       chosen {
+               bootargs = "console=ttyLTQ0,115200 init=/etc/preinit";
+       };
+
+       memory@0 {
+               reg = <0x0 0x2000000>;
+       };
+
+       fpi@10000000 {
+               localbus@0 {
+                       nor-boot@0 {
+                               compatible = "lantiq,nor";
+                               bank-width = <2>;
+                               reg = <0 0x0 0x2000000>;
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               partition@0 {
+                                       label = "uboot";
+                                       reg = <0x00000 0x20000>;
+                                       read-only;
+                               };
+
+                               partition@20000 {
+                                       label = "uboot_env";
+                                       reg = <0x20000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "firmware";
+                                       reg = <0x30000 0x7d0000>;
+                               };
+                       };
+               };
+
+               gpio: pinmux@E100B10 {
+                       pinctrl-names = "default";
+                       pinctrl-0 = <&state_default>;
+
+                       state_default: pinmux {
+                       };
+               };
+
+               etop@E180000 {
+                       phy-mode = "rgmii";
+               };
+
+               ifxhcd@E101000 {
+                       status = "okay";
+                       gpios = <&gpio 36 0>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <100>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 53 1>;
+                       linux,code = <0x198>;
+               };
+               wps {
+                       label = "wps";
+                       gpios = <&gpio 54 1>;
+                       linux,code = <0x211>;
+               };
+               rfkill {
+                       label = "rfkill";
+                       gpios = <&gpio 55 1>;
+                       linux,code = <0xf7>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "power";
+                       gpios = <&gpio 19 1>;
+                       default-state = "on";
+               };
+               online {
+                       label = "online";
+                       gpios = <&gpio 37 1>;
+               };
+               dsl {
+                       label = "dsl";
+                       gpios = <&gpio 4 1>;
+               };
+               phone {
+                       label = "phone";
+                       gpios = <&gpio 39 1>;
+               };
+               wps {
+                       label = "wps";
+                       gpios = <&gpio 22 1>;
+               };
+               wifi {
+                       label = "wifi";
+                       gpios = <&gpio 6 1>;
+               };
+               usb {
+                       label = "usb";
+                       gpios = <&gpio 14 1>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               switch {
+                       gpio-export,name = "switch";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 38 0>;
+               };
+               usb {
+                       gpio-export,name = "usb";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 28 0>;
+               };
+               wifi {
+                       gpio-export,name = "wifi";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 7 0>;
+               };
+       };
+};
index fea32bef221abc53343dff3f2b04d2d21d7be23a..c34b6b0dfaea3d4af0494e43e8fa5bdaae77777b 100644 (file)
@@ -7,7 +7,7 @@
 
 # boards missing since devicetree update
 #EASY50712 ARV3527P GIGASX76X BTHOMEHUBV2B BTHOMEHUBV2BOPENRG
-#WBMR P2601HNFX H201L
+#WBMR P2601HNFX
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
@@ -255,6 +255,9 @@ Image/Build/Profile/FRITZ7320=$(call Image/BuildEVA/$(1),$(1),FRITZ7320)
 Image/BuildKernel/Profile/GR7000=$(call Image/BuildKernel/Template,GR7000)
 Image/Build/Profile/GR7000=$(call Image/Build/$(1),$(1),GR7000)
 
+Image/BuildKernel/Profile/H201L=$(call Image/BuildKernel/Template,H201L)
+Image/Build/Profile/H201L=$(call Image/Build/$(1),$(1),H201L)
+
 endif
 
 
diff --git a/target/linux/lantiq/xway/profiles/zte.mk b/target/linux/lantiq/xway/profiles/zte.mk
new file mode 100644 (file)
index 0000000..d6e70f2
--- /dev/null
@@ -0,0 +1,12 @@
+define Profile/H201L
+  NAME:=ZTE H201L - H201L
+  PACKAGES:=kmod-ath9k-htc wpad-mini \
+       kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
+       kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
+       ltq-adsl-app ppp-mod-pppoe \
+       kmod-ltq-deu-ar9 kmod-ltq-hcd-ar9 \
+       kmod-ltq-tapi kmod-ltq-vmmc \
+       swconfig
+endef
+
+$(eval $(call Profile,H201L))