bcm63xx: Update support for the DSL-274xB revision C
authorFlorian Fainelli <florian@openwrt.org>
Wed, 11 May 2011 13:33:50 +0000 (13:33 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 11 May 2011 13:33:50 +0000 (13:33 +0000)
Rename the DSL-274xB rev C2's board ID to "AW4139" to match the one used
for the rev C3 (same hardware) and add a fixup for C2. Also generate
images for C3.

While we are at it, rename the LEDs to conform to the Linux LED naming
conventions.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
SVN-Revision: 26876

target/linux/brcm63xx/base-files/etc/defconfig/96358GW/network [deleted file]
target/linux/brcm63xx/base-files/etc/defconfig/AW4139/network [new file with mode: 0644]
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-2.6.37/400-board_96358gw.patch [deleted file]
target/linux/brcm63xx/patches-2.6.37/400-board_dsl_274xb_rev_c.patch [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/base-files/etc/defconfig/96358GW/network b/target/linux/brcm63xx/base-files/etc/defconfig/96358GW/network
deleted file mode 100644 (file)
index a35fd2e..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright (C) 2006 OpenWrt.org
-
-config interface loopback
-       option ifname   lo
-       option proto    static
-       option ipaddr   127.0.0.1
-       option netmask  255.0.0.0
-
-config interface lan
-       option ifname   eth0
-       option type     bridge
-       option proto    static
-       option ipaddr   192.168.1.1
-       option netmask  255.255.255.0
diff --git a/target/linux/brcm63xx/base-files/etc/defconfig/AW4139/network b/target/linux/brcm63xx/base-files/etc/defconfig/AW4139/network
new file mode 100644 (file)
index 0000000..a35fd2e
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config interface loopback
+       option ifname   lo
+       option proto    static
+       option ipaddr   127.0.0.1
+       option netmask  255.0.0.0
+
+config interface lan
+       option ifname   eth0
+       option type     bridge
+       option proto    static
+       option ipaddr   192.168.1.1
+       option netmask  255.255.255.0
index 71c188022c62ad8c147286227aec167805f56810..b18386e0dd9dbd8b75952d2d006ba7dfdd6a5750 100755 (executable)
@@ -39,11 +39,16 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth0
                ;;
-       "bcm63xx/96358GW "* | "bcm63xx/SPW500V "*)
+       "bcm63xx/SPW500V "*)
                status_led="power:green"
                brcm63xx_has_reset_button="true"
                ifname=eth0
                ;;
+       "bcm63xx/AW4139 "*)
+               status_led="dsl-274xb:green:power"
+               brcm63xx_has_reset_button="true"
+               ifname=eth0
+               ;;
        "bcm63xx/CPVA642 "* )
                status_led="power:green"
                brcm63xx_has_reset_button="true"
index 22d297137cfa70b0eceadda8a6d22711fa91b60e..144f5559ea436b6e24da68508ac345c1e26faf18 100644 (file)
@@ -177,7 +177,9 @@ define Image/Build
        # D-Link DSL-2640B
        $(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B)
        # D-Link DSL-2740B/DSL-2741B, rev C2
-       $(call Image/Build/CFE,$(1),96358GW,6358,DSL274XB-C2)
+       $(call Image/Build/CFEFIXUP,$(1),96358GW,AW4139,6358,DSL274XB-C2)
+       # D-Link DSL-2740B/DSL-2741B, rev C3
+       $(call Image/Build/CFE,$(1),AW4139,6358,DSL274XB-C3)
 
        # TP-Link TD-8810A, TD-8810B, TD-8811A, TD-8811B
        $(call Image/Build/CFE,$(1),8L-2M-8M,6338,TP8810_8811)
diff --git a/target/linux/brcm63xx/patches-2.6.37/400-board_96358gw.patch b/target/linux/brcm63xx/patches-2.6.37/400-board_96358gw.patch
deleted file mode 100644 (file)
index d008e1d..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
---- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
-+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -562,6 +562,59 @@ static struct board_info __initdata boar
-  * known 6358 boards
-  */
- #ifdef CONFIG_BCM63XX_CPU_6358
-+
-+static struct board_info __initdata board_96358gw = {
-+      .name                           = "96358GW",
-+      .expected_cpu_id                = 0x6358,
-+
-+      .has_uart0                      = 1,
-+      .has_enet1                      = 1,
-+      .has_pci                        = 1,
-+
-+      .enet1 = {
-+              .force_speed_100        = 1,
-+              .force_duplex_full      = 1,
-+      },
-+
-+      .leds = {
-+              {
-+                      .name           = "power:green",
-+                      .gpio           = 5,
-+                      .active_low     = 1,
-+                      .default_trigger = "default-on",
-+              },
-+              {
-+                      .name           = "power:red",
-+                      .gpio           = 4,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "adsl",
-+                      .gpio           = 9,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "internet:green",
-+                      .gpio           = 2,
-+              },
-+              {
-+                      .name           = "internet:red",
-+                      .gpio           = 10,
-+              },
-+      },
-+
-+      .buttons = {
-+              {
-+                      .desc           = "reset",
-+                      .gpio           = 34,
-+                      .active_low     = 1,
-+                      .type           = EV_KEY,
-+                      .code           = KEY_RESTART,
-+                      .threshold      = 3,
-+              },
-+      },
-+};
-+
- static struct board_info __initdata board_96358vw = {
-       .name                           = "96358VW",
-       .expected_cpu_id                = 0x6358,
-@@ -1413,6 +1466,7 @@ static const struct board_info __initdat
- #endif
- #ifdef CONFIG_BCM63XX_CPU_6358
-+      &board_96358gw,
-       &board_96358vw,
-       &board_96358vw2,
-       &board_AGPFS0,
diff --git a/target/linux/brcm63xx/patches-2.6.37/400-board_dsl_274xb_rev_c.patch b/target/linux/brcm63xx/patches-2.6.37/400-board_dsl_274xb_rev_c.patch
new file mode 100644 (file)
index 0000000..a0a7407
--- /dev/null
@@ -0,0 +1,70 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -891,6 +891,59 @@ static struct board_info __initdata boar
+       .has_ohci0                      = 1,
+ };
++/* D-Link DSL-274xB revison C2/C3 */
++static struct board_info __initdata board_dsl_274xb_rev_c = {
++      .name                           = "AW4139",
++      .expected_cpu_id                = 0x6358,
++
++      .has_uart0                      = 1,
++      .has_enet1                      = 1,
++      .has_pci                        = 1,
++
++      .enet1 = {
++              .force_speed_100        = 1,
++              .force_duplex_full      = 1,
++      },
++
++      .leds = {
++              {
++                      .name           = "dsl-274xb:green:power",
++                      .gpio           = 5,
++                      .active_low     = 1,
++                      .default_trigger = "default-on",
++              },
++              {
++                      .name           = "dsl-274xb:red:power",
++                      .gpio           = 4,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "dsl-274xb:green:adsl",
++                      .gpio           = 9,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "dsl-274xb:green:internet",
++                      .gpio           = 2,
++              },
++              {
++                      .name           = "dsl-274xb:red:internet",
++                      .gpio           = 10,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc           = "reset",
++                      .gpio           = 34,
++                      .active_low     = 1,
++                      .type           = EV_KEY,
++                      .code           = KEY_RESTART,
++                      .threshold      = 3,
++              },
++      },
++};
++
+ struct spi_gpio_platform_data nb4_spi_gpio_data = {
+       .sck            = NB4_SPI_GPIO_CLK,
+       .mosi           = NB4_SPI_GPIO_MOSI,
+@@ -1418,6 +1471,7 @@ static const struct board_info __initdat
+       &board_AGPFS0,
+       &board_CPVA642,
+       &board_DWVS0,
++      &board_dsl_274xb_rev_c,
+       &board_nb4_ser_r0,
+       &board_nb4_ser_r1,
+       &board_nb4_ser_r2,