kernel: update 3.18 to 3.18.21
authorJonas Gorski <jogo@openwrt.org>
Wed, 2 Sep 2015 10:18:15 +0000 (10:18 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 2 Sep 2015 10:18:15 +0000 (10:18 +0000)
Changelog:
 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.21

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46768

20 files changed:
include/kernel-version.mk
target/linux/brcm2708/patches-3.18/0019-Add-Chris-Boot-s-i2c-and-spi-drivers.patch
target/linux/brcm2708/patches-3.18/0053-i2c-bcm2708-add-device-tree-support.patch
target/linux/brcm2708/patches-3.18/0089-Add-2709-platform-for-Raspberry-Pi-2.patch
target/linux/brcm47xx/patches-3.18/159-cpu_fixes.patch
target/linux/brcm63xx/patches-3.18/572-board_VR-3026e.patch
target/linux/cns3xxx/patches-3.18/070-i2c_support.patch
target/linux/generic/patches-3.18/130-MIPS-kernel-fix-sched_getaffinity-with-MT-FPAFF-enab.patch [deleted file]
target/linux/generic/patches-3.18/834-ledtrig-libata.patch
target/linux/generic/patches-3.18/921-use_preinit_as_init.patch
target/linux/lantiq/patches-3.18/0031-I2C-MIPS-lantiq-add-FALC-ON-i2c-bus-master.patch
target/linux/lantiq/patches-3.18/0101-mtd-split.patch
target/linux/ramips/patches-3.18/0037-USB-phy-add-ralink-SoC-driver.patch
target/linux/ramips/patches-3.18/0052-i2c-MIPS-adds-ralink-I2C-driver.patch
target/linux/ramips/patches-3.18/0060-soc_type.patch
target/linux/ramips/patches-3.18/0062-mt7621-add-ECHI-OCHI-XCHI-support.patch
target/linux/ramips/patches-3.18/0065-fix_dts_cache_issues.patch
target/linux/ramips/patches-3.18/0074-i2c-MIPS-add-mt7621-I2C-driver.patch
target/linux/ramips/patches-3.18/0100-mtd-split-remove-padding.patch
target/linux/ramips/patches-3.18/0101-mtd-add-rtn56u-support.patch

index 2d4782ae174d26876fd506f8dfd6290ac64af575..afc0e651e2cb6bae09c8d7f5d10d2337e8867607 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .20
+LINUX_VERSION-3.18 = .21
 LINUX_VERSION-4.0 = .9
 LINUX_VERSION-4.1 = .6
 
-LINUX_KERNEL_MD5SUM-3.18.20 = 952c9159acdf4efbc96e08a27109d994
+LINUX_KERNEL_MD5SUM-3.18.21 = e4248caaa4cef318c04657e971b37298
 LINUX_KERNEL_MD5SUM-4.0.9 = 40fc5f6e2d718e539b45e6601c71985b
 LINUX_KERNEL_MD5SUM-4.1.6 = 1dae0c808e34164cab3dfd57be88bd53
 
index 95e4a6d2448d5273fe1419ec7d1f1ec019a4a25c..779559745100057da3246c9b6308ae9bd3ee917b 100644 (file)
@@ -212,7 +212,7 @@ The correct baudrate is shown in the log after the cdiv > 0xffff correction.
  static void timer_set_mode(enum clock_event_mode mode,
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -371,6 +371,25 @@ config I2C_BCM2835
+@@ -372,6 +372,25 @@ config I2C_BCM2835
          This support is also available as a module.  If so, the module
          will be called i2c-bcm2835.
  
index acf920359b8a7f90596cb8364c3ce6f7e600cd30..0269052ae349ea1e0380243db7ed94b4f758a171 100644 (file)
@@ -147,7 +147,7 @@ Signed-off-by: Noralf Tronnes <notro@tronnes.org>
        bcm_register_device(&bcm2835_thermal_device);
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -361,7 +361,7 @@ config I2C_AXXIA
+@@ -362,7 +362,7 @@ config I2C_AXXIA
  
  config I2C_BCM2835
        tristate "Broadcom BCM2835 I2C controller"
index 68788385902da39dde24f25bbdbefe8c3db49096..c1e938bb33a814f9405946814a679a5bf1691b1e 100644 (file)
@@ -9352,7 +9352,7 @@ Subject: [PATCH 089/114] Add 2709 platform for Raspberry Pi 2
  
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -361,7 +361,7 @@ config I2C_AXXIA
+@@ -362,7 +362,7 @@ config I2C_AXXIA
  
  config I2C_BCM2835
        tristate "Broadcom BCM2835 I2C controller"
@@ -9361,7 +9361,7 @@ Subject: [PATCH 089/114] Add 2709 platform for Raspberry Pi 2
        help
          If you say yes to this option, support will be included for the
          BCM2835 I2C controller.
-@@ -373,7 +373,7 @@ config I2C_BCM2835
+@@ -374,7 +374,7 @@ config I2C_BCM2835
  
  config I2C_BCM2708
        tristate "BCM2708 BSC"
index dd430f52dd7b8ab213ef3c08dba583bbba68281f..48cf095d0e1ae1ee1c33a1f1bbd5282445b99952 100644 (file)
  #endif /* _ASM_R4KCACHE_H */
 --- a/arch/mips/include/asm/stackframe.h
 +++ b/arch/mips/include/asm/stackframe.h
-@@ -333,6 +333,10 @@
+@@ -358,6 +358,10 @@
                .macro  RESTORE_SP_AND_RET
                LONG_L  sp, PT_R29(sp)
                .set    arch=r4000
index 260602adca5125aad6ada2cd7106b8a16cf0029b..4358afda59057ff33fcbdb614e18d54c4dbd1d02 100644 (file)
@@ -1,9 +1,9 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
 @@ -2168,6 +2168,60 @@ static struct board_info __initdata boar
-       },
+       },
  };
-
 +static struct sprom_fixup __initdata vr3026e_fixups[] = {
 +      { .offset = 97, .value = 0xfeb3 },
 +      { .offset = 98, .value = 0x1618 },
 +};
 +
  static struct b53_platform_data WAP5813n_b53_pdata = {
-       .alias = "eth0",
+       .alias = "eth0",
  };
 @@ -2472,6 +2526,7 @@ static const struct board_info __initcon
-       &board_P870HW51A_V2,
-       &board_VR3025u,
-       &board_VR3025un,
+       &board_P870HW51A_V2,
+       &board_VR3025u,
+       &board_VR3025un,
 +      &board_VR3026e,
-       &board_WAP5813n,
+       &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
 @@ -2572,6 +2627,7 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
-       { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
-       { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
+       { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
+       { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
+       { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
 +      { .compatible = "comtrend,vr-3026e", .data = &board_VR3026e, },
-       { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
-       { .compatible = "huawei,hg655b", .data = &board_HG655b, },
-       { .compatible = "netgear,dgnd3700v1", .data = &board_DGND3700v1_3800B, },
+       { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
+       { .compatible = "huawei,hg655b", .data = &board_HG655b, },
+       { .compatible = "netgear,dgnd3700v1", .data = &board_DGND3700v1_3800B, },
index 0114d7e781c644b0a752d26870040993d5f00316..ff6be6a1ba2f25f1dc45701d8755e7b7646ff767 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -416,6 +416,18 @@ config I2C_CBUS_GPIO
+@@ -417,6 +417,18 @@ config I2C_CBUS_GPIO
          This driver can also be built as a module.  If so, the module
          will be called i2c-cbus-gpio.
  
diff --git a/target/linux/generic/patches-3.18/130-MIPS-kernel-fix-sched_getaffinity-with-MT-FPAFF-enab.patch b/target/linux/generic/patches-3.18/130-MIPS-kernel-fix-sched_getaffinity-with-MT-FPAFF-enab.patch
deleted file mode 100644 (file)
index a7bfef3..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Felix Fietkau <nbd@openwrt.org>
-Date: Sun, 19 Jul 2015 00:21:57 +0200
-Subject: [PATCH] MIPS: kernel: fix sched_getaffinity with MT FPAFF enabled
-
-p->thread.user_cpus_allowed is zero-initialized and is only filled on
-the first sched_setaffinity call.
-
-To avoid adding overhead in the task initialization codepath, simply OR
-the returned mask in sched_getaffinity with p->cpus_allowed.
-
-Cc: stable@vger.kernel.org
-Signed-off-by: Felix Fietkau <nbd@openwrt.org>
----
-
---- a/arch/mips/kernel/mips-mt-fpaff.c
-+++ b/arch/mips/kernel/mips-mt-fpaff.c
-@@ -154,7 +154,7 @@ asmlinkage long mipsmt_sys_sched_getaffi
-                                     unsigned long __user *user_mask_ptr)
- {
-       unsigned int real_len;
--      cpumask_t mask;
-+      cpumask_t allowed, mask;
-       int retval;
-       struct task_struct *p;
-@@ -173,7 +173,8 @@ asmlinkage long mipsmt_sys_sched_getaffi
-       if (retval)
-               goto out_unlock;
--      cpumask_and(&mask, &p->thread.user_cpus_allowed, cpu_possible_mask);
-+      cpumask_or(&allowed, &p->thread.user_cpus_allowed, &p->cpus_allowed);
-+      cpumask_and(&mask, &allowed, cpu_active_mask);
- out_unlock:
-       read_unlock(&tasklist_lock);
index 1360ce9fb8079082efeffaac84707d64c2c6124b..4c0ffcac91b6eb9605629e12eef41ec4014c61cc 100644 (file)
@@ -69,7 +69,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4761,6 +4774,9 @@ static struct ata_queued_cmd *ata_qc_new
+@@ -4798,6 +4811,9 @@ static struct ata_queued_cmd *ata_qc_new
                        break;
                }
        }
@@ -79,7 +79,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        return qc;
  }
-@@ -5671,6 +5687,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5708,6 +5724,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -89,7 +89,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5692,6 +5711,12 @@ static void ata_host_release(struct devi
+@@ -5729,6 +5748,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -102,7 +102,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6138,7 +6163,23 @@ int ata_host_register(struct ata_host *h
+@@ -6175,7 +6200,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
@@ -138,7 +138,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -872,6 +875,12 @@ struct ata_port {
+@@ -874,6 +877,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index d297e3bc3059170d0fcf54196b17395700dbaa58..57c2fe27be8017c7c88f968d6a833d19ecbcd6a2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -962,7 +962,8 @@ static int __ref kernel_init(void *unuse
+@@ -963,7 +963,8 @@ static int __ref kernel_init(void *unuse
                pr_err("Failed to execute %s (error %d).  Attempting defaults...\n",
                        execute_command, ret);
        }
index 819eb322cb680ab1c7f67c15e9d343be5d3f3b36..4f655db49963f114ff9773b340eddd28ac4d3429 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -553,6 +553,16 @@ config I2C_KEMPLD
+@@ -554,6 +554,16 @@ config I2C_KEMPLD
          This driver can also be built as a module. If so, the module
          will be called i2c-kempld.
  
index 6753a2156c462ce9b3908864d37d5f02d158eccb..6152e0e211a89ac2168ae15a60daa2b6f3594ffe 100644 (file)
                                 enum mtd_parser_type type,
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -627,7 +627,7 @@ out_register:
+@@ -628,7 +628,7 @@ out_register:
  }
  
  
  __mtd_add_partition(struct mtd_info *master, const char *name,
                    long long offset, long long length, bool dup_check)
  {
-@@ -748,7 +748,7 @@ run_parsers_by_type(struct mtd_part *sla
+@@ -749,7 +749,7 @@ run_parsers_by_type(struct mtd_part *sla
        return nr_parts;
  }
  
  mtd_pad_erasesize(struct mtd_info *mtd, int offset, int len)
  {
        unsigned long mask = mtd->erasesize - 1;
-@@ -818,7 +818,6 @@ static void split_uimage(struct mtd_info
+@@ -819,7 +819,6 @@ static void split_uimage(struct mtd_info
                return;
  
        len = be32_to_cpu(hdr.size) + 0x40;
index 5a7d416726ab64013c47d8f8b9793ded5588d7a1..2448d0ab3130b4e05f5f4917a124cf7ed13cc2bd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/phy/Kconfig
 +++ b/drivers/phy/Kconfig
-@@ -239,6 +239,11 @@
+@@ -239,6 +239,11 @@ config PHY_XGENE
        help
          This option enables support for APM X-Gene SoC multi-purpose PHY.
  
@@ -14,7 +14,7 @@
        depends on RESET_CONTROLLER
 --- a/drivers/phy/Makefile
 +++ b/drivers/phy/Makefile
-@@ -31,3 +31,4 @@
+@@ -31,3 +31,4 @@ obj-$(CONFIG_PHY_ST_SPEAR1340_MIPHY) +=
  obj-$(CONFIG_PHY_XGENE)                       += phy-xgene.o
  obj-$(CONFIG_PHY_STIH407_USB)         += phy-stih407-usb.o
  obj-$(CONFIG_PHY_STIH41X_USB)         += phy-stih41x-usb.o
index 8ed061070a8a4d49c4fda332c2707cb1b0bed9c9..0cf554265e1ae0b87333543871c532a42b57a0c8 100644 (file)
@@ -45,7 +45,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +};
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -710,6 +710,10 @@ config I2C_RK3X
+@@ -711,6 +711,10 @@ config I2C_RK3X
          This driver can also be built as a module. If so, the module will
          be called i2c-rk3x.
  
index 292a4ad456bda5e94c39eed15ed6b1799e922051..41cc1208c3f60373b97821c60f2e4838c88cd1ef 100644 (file)
  {
 --- a/arch/mips/ralink/mt7621.c
 +++ b/arch/mips/ralink/mt7621.c
-@@ -176,6 +176,7 @@ void prom_soc_init(struct ralink_soc_inf
+@@ -193,6 +193,7 @@ void prom_soc_init(struct ralink_soc_inf
        soc_info->mem_size_min = MT7621_DDR2_SIZE_MIN;
        soc_info->mem_size_max = MT7621_DDR2_SIZE_MAX;
        soc_info->mem_base = MT7621_DRAM_BASE;
index 15f5ee83780691cf9985b757fa58dc20f067b947..98e8ca5a499cae3b2815423569ca87f2eb0fa6ed 100644 (file)
        ctrl_ctx->add_flags |= cpu_to_le32(added_ctxs);
        new_add_flags = le32_to_cpu(ctrl_ctx->add_flags);
  
-@@ -4451,8 +4597,14 @@ static u16 xhci_call_host_update_timeout
+@@ -4454,8 +4600,14 @@ static u16 xhci_call_host_update_timeout
                u16 *timeout)
  {
        if (state == USB3_LPM_U1)
                return xhci_calculate_u2_timeout(xhci, udev, desc);
  
        return USB3_LPM_DISABLED;
-@@ -4837,7 +4989,9 @@ int xhci_gen_setup(struct usb_hcd *hcd,
+@@ -4840,7 +4992,9 @@ int xhci_gen_setup(struct usb_hcd *hcd,
        hcd->self.no_sg_constraint = 1;
  
        /* XHCI controllers don't stop the ep queue on short packets :| */
  
        if (usb_hcd_is_primary_hcd(hcd)) {
                xhci = kzalloc(sizeof(struct xhci_hcd), GFP_KERNEL);
-@@ -4900,6 +5054,10 @@ int xhci_gen_setup(struct usb_hcd *hcd,
+@@ -4903,6 +5057,10 @@ int xhci_gen_setup(struct usb_hcd *hcd,
                goto error;
        xhci_dbg(xhci, "Reset complete\n");
  
        /* Set dma_mask and coherent_dma_mask to 64-bits,
         * if xHC supports 64-bit addressing */
        if (HCC_64BIT_ADDR(xhci->hcc_params) &&
-@@ -4994,8 +5152,57 @@ MODULE_DESCRIPTION(DRIVER_DESC);
+@@ -4997,8 +5155,57 @@ MODULE_DESCRIPTION(DRIVER_DESC);
  MODULE_AUTHOR(DRIVER_AUTHOR);
  MODULE_LICENSE("GPL");
  
index 42c04aef9623c070cb38d9725f78a79ccc17921a..520c570ee27ddfdeaddd96660438afbf48670b52 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/kernel/setup.c
 +++ b/arch/mips/kernel/setup.c
-@@ -675,7 +675,6 @@
+@@ -675,7 +675,6 @@ static void __init arch_mem_init(char **
                                crashk_res.end - crashk_res.start + 1,
                                BOOTMEM_DEFAULT);
  #endif
@@ -8,7 +8,7 @@
        sparse_init();
        plat_swiotlb_setup();
        paging_init();
-@@ -784,6 +783,7 @@
+@@ -784,6 +783,7 @@ void __init setup_arch(char **cmdline_p)
        prefill_possible_map();
  
        cpu_cache_init();
index b34581ed631fa820a6935ff8a86e0daecff58cdc..9b9a72bc7b493fca3c5711b542b8e208a1585444 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -714,6 +714,10 @@ config I2C_RALINK
+@@ -715,6 +715,10 @@ config I2C_RALINK
        tristate "Ralink I2C Controller"
        select OF_I2C
  
index 32cea7ded9404534d63c48bb82888aec9a38341c..81702c28e80bafc20f64748f69a2c62d52f0c197 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -818,9 +818,6 @@ static void split_uimage(struct mtd_info
+@@ -819,9 +819,6 @@ static void split_uimage(struct mtd_info
                return;
  
        len = be32_to_cpu(hdr.size) + 0x40;
index 6f6458fc1c25b778d0d4f807892765a89abd0412..50b88dbcd3efdea40690d9552712d200a33b8e34 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -806,8 +806,11 @@ static void split_uimage(struct mtd_info
+@@ -807,8 +807,11 @@ static void split_uimage(struct mtd_info
  {
        struct {
                __be32 magic;
@@ -13,7 +13,7 @@
        } hdr;
        size_t len;
  
-@@ -817,7 +820,10 @@ static void split_uimage(struct mtd_info
+@@ -818,7 +821,10 @@ static void split_uimage(struct mtd_info
        if (len != sizeof(hdr) || hdr.magic != cpu_to_be32(UBOOT_MAGIC))
                return;