build: add optional dependency on libssp to all non-kernel packages
authorFelix Fietkau <nbd@openwrt.org>
Fri, 20 Mar 2015 16:50:50 +0000 (16:50 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 20 Mar 2015 16:50:50 +0000 (16:50 +0000)
When enabling SSP_SUPPORT, a lot of packages fail during compile phase
with the following error:

Package X is missing dependencies for the following libraries:
libssp.so.0

This can be solved by adding an optional dependency on libssp to all
those packages, but as there are quite a few packages both in OpenWrt
core and in the package repository, it might make sense to add this
optional dependency to all non-kernel packages, instead of polluting
lots of package dependency lines with it.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
SVN-Revision: 44911

include/package-defaults.mk

index a94f2a4..9567e04 100644 (file)
@@ -5,7 +5,7 @@
 # See /LICENSE for more information.
 #
 
-PKG_DEFAULT_DEPENDS = +libc +USE_GLIBC:librt +USE_GLIBC:libpthread
+PKG_DEFAULT_DEPENDS = +libc +SSP_SUPPORT:libssp +USE_GLIBC:librt +USE_GLIBC:libpthread
 
 ifneq ($(PKG_NAME),toolchain)
   PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),$(PKG_DEFAULT_DEPENDS) $(filter-out $(PKG_DEFAULT_DEPENDS),$(2)))