cleanup magicbox patches
authorGabor Juhos <juhosg@openwrt.org>
Sun, 19 Jul 2009 04:50:37 +0000 (04:50 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 19 Jul 2009 04:50:37 +0000 (04:50 +0000)
SVN-Revision: 16905

target/linux/ppc40x/patches-2.6.30/005-magicboxv1.patch
target/linux/ppc40x/patches-2.6.30/006-magicboxv2.patch

index 4993e799d2bf1f0b70faeb0aa54e701648d65462..ef29e0bf29db036e8d1b99528cde32d78e55bce1 100644 (file)
@@ -1,6 +1,6 @@
 --- /dev/null
 +++ b/arch/powerpc/boot/cuboot-magicboxv1.c
-@@ -0,0 +1,40 @@
+@@ -0,0 +1,41 @@
 +/*
 + * Old U-boot compatibility for Magicbox v1
 + *
@@ -31,7 +31,7 @@
 +      ibm4xx_sdram_fixup_memsize();
 +      dt_fixup_mac_addresses(&bd.bi_enetaddr);
 +}
-+      
++
 +void platform_init(unsigned long r3, unsigned long r4, unsigned long r5,
 +              unsigned long r6, unsigned long r7)
 +{
@@ -41,6 +41,7 @@
 +      fdt_init(_dtb_start);
 +      serial_console_init();
 +}
++
 --- /dev/null
 +++ b/arch/powerpc/boot/dts/magicboxv1.dts
 @@ -0,0 +1,217 @@
 +};
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -75,7 +75,7 @@ src-plat := of.c cuboot-52xx.c cuboot-82
+@@ -75,7 +75,7 @@
                cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
                cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
                virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
  src-boot := $(src-wlib) $(src-plat) empty.c
  
  src-boot := $(addprefix $(obj)/, $(src-boot))
-@@ -192,6 +192,7 @@ image-$(CONFIG_DEFAULT_UIMAGE)             += uImag
+@@ -192,6 +192,7 @@
  image-$(CONFIG_EP405)                 += dtbImage.ep405
  image-$(CONFIG_WALNUT)                        += treeImage.walnut
  image-$(CONFIG_ACADIA)                        += cuImage.acadia
  image-$(CONFIG_EBONY)                 += treeImage.ebony cuImage.ebony
 --- a/arch/powerpc/platforms/40x/Kconfig
 +++ b/arch/powerpc/platforms/40x/Kconfig
-@@ -49,6 +49,16 @@ config KILAUEA
+@@ -49,6 +49,16 @@
        help
          This option enables support for the AMCC PPC405EX evaluation board.
  
        depends on 40x
 --- a/arch/powerpc/platforms/40x/ppc40x_simple.c
 +++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
-@@ -51,7 +51,8 @@ machine_device_initcall(ppc40x_simple, p
+@@ -51,7 +51,8 @@
   * board.c file for it rather than adding it to this list.
   */
  static char *board[] __initdata = {
 -      "amcc,acadia"
 +      "amcc,acadia",
-+      "magicboxv1"
++      "magicboxv1",
  };
  
  static int __init ppc40x_probe(void)
index e658895c4229508d926b69588447cedbffb2d603..8a7dbb6aef30d23e53e57b03a78c715ee4e5bb08 100644 (file)
@@ -1,6 +1,6 @@
 --- /dev/null
 +++ b/arch/powerpc/boot/cuboot-magicboxv2.c
-@@ -0,0 +1,40 @@
+@@ -0,0 +1,41 @@
 +/*
 + * Old U-boot compatibility for Magicbox v2
 + *
@@ -31,7 +31,7 @@
 +      ibm4xx_sdram_fixup_memsize();
 +      dt_fixup_mac_addresses(&bd.bi_enetaddr, &bd.bi_enet1addr);
 +}
-+      
++
 +void platform_init(unsigned long r3, unsigned long r4, unsigned long r5,
 +              unsigned long r6, unsigned long r7)
 +{
@@ -41,6 +41,7 @@
 +      fdt_init(_dtb_start);
 +      serial_console_init();
 +}
++
 --- /dev/null
 +++ b/arch/powerpc/boot/dts/magicboxv2.dts
 @@ -0,0 +1,250 @@
 +};
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -75,7 +75,8 @@ src-plat := of.c cuboot-52xx.c cuboot-82
+@@ -75,7 +75,8 @@
                cuboot-katmai.c cuboot-rainier.c redboot-8xx.c ep8248e.c \
                cuboot-warp.c cuboot-85xx-cpm2.c cuboot-yosemite.c simpleboot.c \
                virtex405-head.S virtex.c redboot-83xx.c cuboot-sam440ep.c \
  src-boot := $(src-wlib) $(src-plat) empty.c
  
  src-boot := $(addprefix $(obj)/, $(src-boot))
-@@ -193,6 +194,7 @@ image-$(CONFIG_EP405)                      += dtbImage.ep40
+@@ -193,6 +194,7 @@
  image-$(CONFIG_WALNUT)                        += treeImage.walnut
  image-$(CONFIG_ACADIA)                        += cuImage.acadia
  image-$(CONFIG_MAGICBOXV1)            += cuImage.magicboxv1
  image-$(CONFIG_EBONY)                 += treeImage.ebony cuImage.ebony
 --- a/arch/powerpc/platforms/40x/Kconfig
 +++ b/arch/powerpc/platforms/40x/Kconfig
-@@ -59,6 +59,16 @@ config MAGICBOXV1
+@@ -59,6 +59,16 @@
        help
          This option enables support for the Magicbox v1 board.
  
        depends on 40x
 --- a/arch/powerpc/platforms/40x/ppc40x_simple.c
 +++ b/arch/powerpc/platforms/40x/ppc40x_simple.c
-@@ -52,7 +52,8 @@ machine_device_initcall(ppc40x_simple, p
-  */
+@@ -53,6 +53,7 @@
  static char *board[] __initdata = {
        "amcc,acadia",
--      "magicboxv1"
-+      "magicboxv1",
+       "magicboxv1",
 +      "magicboxv2",
  };