ath79: Add support for OpenMesh OM5P
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 30 Dec 2020 22:32:07 +0000 (23:32 +0100)
Device specifications:
======================

* Qualcomm/Atheros AR9344 rev 2
* 560/450/225 MHz (CPU/DDR/AHB)
* 64 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 2x 10/100 Mbps Ethernet
* 2T2R 5 GHz Wi-Fi
* 6x GPIO-LEDs (3x wifi, 2x ethernet, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default)
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 2x fast ethernet
  - eth0
    + builtin switch port 1
    + used as LAN interface
  - eth1
    + 18-24V passive POE (mode B)
    + used as WAN interface
* 12-24V 1A DC
* internal antennas

WAN/LAN LEDs appear to be wrong in ar71xx and have been swapped here.

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to the
device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
[add LED swap comment]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/ar9344_openmesh_om5p.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 92caed4be721aa92b2beadc63b286651cc9fa516..8bc2c00ba5c257856c4b644c4a3a93a63db1304c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
-PKG_RELEASE:=16
+PKG_RELEASE:=17
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index 55c1ce8f638f35f62f3dffde4ceaf8c5da02b518..dedf7160f02f7f402a872e472ac22020916edb85 100644 (file)
@@ -48,6 +48,7 @@ netgear,wnr2200-16m|\
 netgear,wnr612-v2|\
 ocedo,koala|\
 ocedo,raccoon|\
+openmesh,om5p|\
 openmesh,om5p-ac-v2|\
 samsung,wam250|\
 ubnt,nanostation-m|\
diff --git a/target/linux/ath79/dts/ar9344_openmesh_om5p.dts b/target/linux/ath79/dts/ar9344_openmesh_om5p.dts
new file mode 100644 (file)
index 0000000..a733a92
--- /dev/null
@@ -0,0 +1,166 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9344.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "openmesh,om5p", "qca,ar9344";
+       model = "OpenMesh OM5P";
+
+       chosen {
+               /delete-property/ bootargs;
+       };
+
+       aliases {
+               serial0 = &uart;
+               led-boot = &led_power_blue;
+               led-failsafe = &led_power_blue;
+               led-running = &led_power_blue;
+               led-upgrade = &led_power_blue;
+               label-mac-device = &eth1;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               pinctrl-names = "default";
+               pinctrl-0 = <&led_lan_wan_blue_pin>;
+
+               led_power_blue: power_blue {
+                       label = "blue:power";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wan_blue {
+                       label = "blue:wan";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               lan_blue {
+                       label = "blue:lan";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi_green {
+                       label = "green:wifi";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wifi_yellow {
+                       label = "yellow:wifi";
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi_red {
+                       label = "red:wifi";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       watchdog {
+               compatible = "linux,wdt-gpio";
+               gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+               hw_algo = "toggle";
+               /* hw_margin_ms is actually 300s but driver limits it to 60s */
+               hw_margin_ms = <60000>;
+               always-running;
+       };
+};
+
+&ref {
+       clock-frequency = <40000000>;
+};
+
+&uart {
+       status = "okay";
+};
+
+&pinmux {
+       led_lan_wan_blue_pin: pinmux_lan_wan_blue_pin {
+               pinctrl-single,bits = <0xc 0x0 0xffff0000>;
+       };
+};
+
+&spi {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <40000000>;
+
+               /* partitions are passed via bootloader */
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@50000 {
+                               label = "custom";
+                               reg = <0x050000 0x060000>;
+                               read-only;
+                       };
+
+                       partition@b0000 {
+                               label = "inactive";
+                               reg = <0x0b0000 0x7a0000>;
+                       };
+
+                       partition@850000 {
+                               label = "inactive2";
+                               reg = <0x850000 0x7a0000>;
+                       };
+
+                       art: partition@ff0000 {
+                               label = "ART";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy4>;
+
+       mtd-mac-address = <&art 0x6>;
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&art 0x0>;
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+};
index 8f0e2f87a72573ed3b2261a66c7cbdb2dbcf0594..b961e7d3e8c1ff6b6fa17dacf06c68b9c834f2ef 100755 (executable)
@@ -150,6 +150,7 @@ openmesh,om2p-hs-v1|\
 openmesh,om2p-hs-v2|\
 openmesh,om2p-hs-v3|\
 openmesh,om2p-lc|\
+openmesh,om5p|\
 telco,t1)
        ucidef_set_led_switch "lan" "LAN" "blue:lan" "switch0" "0x02"
        ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth1"
index 2c907ac1010a8c1dec12478dfa096792c0242388..79e023482b2f7008030334cba0081f0f0f7b6f5a 100644 (file)
@@ -56,7 +56,8 @@ platform_do_upgrade() {
        openmesh,om2p-hs-v2|\
        openmesh,om2p-hs-v3|\
        openmesh,om2p-hs-v4|\
-       openmesh,om2p-lc)
+       openmesh,om2p-lc|\
+       openmesh,om5p)
                PART_NAME="inactive"
                platform_do_upgrade_openmesh "$1"
                ;;
index acb456ba44171bc62f3b7e05ef5d96a94ec490e2..ded8e29c2cf62e7d1400c6042b8e1cd3271bcc1f 100644 (file)
@@ -1630,6 +1630,25 @@ define Device/openmesh_om2p-lc
 endef
 TARGET_DEVICES += openmesh_om2p-lc
 
+define Device/openmesh_om5p-common
+  SOC := ar9344
+  DEVICE_VENDOR := OpenMesh
+  DEVICE_PACKAGES := uboot-envtools
+  IMAGE_SIZE := 7808k
+  BLOCKSIZE := 64k
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | \
+       pad-to $$(BLOCKSIZE)
+  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
+       openmesh-image ce_type=OM5P | append-metadata
+endef
+
+define Device/openmesh_om5p
+  $(Device/openmesh_om5p-common)
+  DEVICE_MODEL := OM5P
+  SUPPORTED_DEVICES += om5p
+endef
+TARGET_DEVICES += openmesh_om5p
+
 define Device/openmesh_om5p-ac-v2
   SOC := qca9558
   DEVICE_VENDOR := OpenMesh