mac80211: add debug compile option for rtw88 devices
authorFlorian Eckert <fe@dev.tdt.de>
Tue, 1 Feb 2022 12:37:24 +0000 (13:37 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 20 Feb 2022 13:26:40 +0000 (14:26 +0100)
This commit adds the following package compile options.

CONFIG_PACKAGE_RTW88_DEBGUG:
Compile the driver with additional debug logging output

CONFIG_PACKAGE_RTW88_DEBGUGFS:
Add the possibility to map information about the driver rtw88 into
debugfs.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
package/kernel/mac80211/realtek.mk

index 75cb94d7b60136ec46288a3bac94cf1caf987e4c..44c6c25b089df1196f1e409d4ebaf696eaa00bfc 100644 (file)
@@ -27,6 +27,8 @@ config-y += STAGING
 
 config-$(call config_package,rtw88) += RTW88 RTW88_CORE RTW88_PCI
 config-y += RTW88_8822BE RTW88_8822CE RTW88_8723DE
+config-$(CONFIG_PACKAGE_RTW88_DEBUG) += RTW88_DEBUG
+config-$(CONFIG_PACKAGE_RTW88_DEBUGFS) += RTW88_DEBUGFS
 
 define KernelPackage/rtl818x/Default
   $(call KernelPackage/mac80211/Default)
@@ -175,6 +177,22 @@ define KernelPackage/rtl8xxxu/description
   Please report your results!
 endef
 
+define KernelPackage/rtw88/config
+       config PACKAGE_RTW88_DEBUG
+               bool "Realtek wireless debugging (rtw88)"
+               depends on PACKAGE_kmod-rtw88
+               help
+                 Enable debugging output for rtw88 devices
+
+       config PACKAGE_RTW88_DEBUGFS
+               bool "Enable rtw88 debugfS support"
+               select KERNEL_DEBUG_FS
+               depends on PACKAGE_kmod-rtw88
+               help
+                 Select this to see extensive information about
+                 the internal state of rtw88 in debugfs.
+endef
+
 define KernelPackage/rtw88
   $(call KernelPackage/mac80211/Default)
   TITLE:=Realtek RTL8822BE/RTL8822CE/RTL8723DE