mvebu: udpu: fix initramfs booting
authorRobert Marko <robert.marko@sartura.hr>
Mon, 21 Mar 2022 10:47:27 +0000 (11:47 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 21 Mar 2022 13:00:34 +0000 (14:00 +0100)
uDPU provides a FIT based initramfs, but currently gets stuck after U-boot
starts the kernel at "Starting kernel..".

It is due to the load address being too low, so increase it in order to get
the initramfs booting again.

Signed-off-by: Robert Marko <robert.marko@sartura.hr>
target/linux/mvebu/image/cortexa53.mk

index ca3a53f992c052e265799a4e75b097b90da96ffd..46f04fe7cc111817edfd5152f69bf2d43821f1e7 100644 (file)
@@ -82,7 +82,7 @@ define Device/methode_udpu
   DEVICE_VENDOR := Methode
   DEVICE_MODEL := micro-DPU (uDPU)
   DEVICE_DTS := armada-3720-uDPU
-  KERNEL_LOADADDR := 0x00080000
+  KERNEL_LOADADDR := 0x00800000
   KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
   KERNEL_INITRAMFS_SUFFIX := .itb
   DEVICE_PACKAGES += f2fs-tools fdisk kmod-i2c-pxa