brcm2708: fix build failure
authorDavid Bauer <mail@david-bauer.net>
Thu, 26 Mar 2020 00:10:02 +0000 (01:10 +0100)
committerDavid Bauer <mail@david-bauer.net>
Thu, 26 Mar 2020 00:34:30 +0000 (01:34 +0100)
Build of the brcm2708 subtarget currently fails with the following error
message:

 arch/arm/lib/memset_rpi.S: Assembler messages:
 arch/arm/lib/memset_rpi.S:65: Error: garbage following instruction
  -- `orr DAT0,DAT0,lsl#8'
 arch/arm/lib/memset_rpi.S:67: Error: garbage following instruction
  -- `orr DAT0,DAT0,lsl#16'
 scripts/Makefile.build:427: recipe for target 'arch/arm/lib/memset_rpi.o'
 failed

Using the assembly notation from master fixes this error.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/brcm2708/patches-4.14/950-0061-Improve-__copy_to_user-and-__copy_from_user-performa.patch

index d7b04c9efd5680a3dcfceb14cd2d847e257cdcb1..b8f7de202d85c0ba6ab871ed20e98b76f85d5282 100644 (file)
@@ -1313,9 +1313,9 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 +        DAT2    .req    ip
 +        DAT3    .req    lr
 +
 +        DAT2    .req    ip
 +        DAT3    .req    lr
 +
-+        orr     DAT0, DAT0, lsl #8
++        orr     DAT0, DAT0, DAT0, lsl #8
 +        push    {S, lr}
 +        push    {S, lr}
-+        orr     DAT0, DAT0, lsl #16
++        orr     DAT0, DAT0, DAT0, lsl #16
 +        mov     DAT1, DAT0
 +
 +        /* See if we're guaranteed to have at least one 16-byte aligned 16-byte write */
 +        mov     DAT1, DAT0
 +
 +        /* See if we're guaranteed to have at least one 16-byte aligned 16-byte write */