mediatek: fix parallel build issues in image build code
authorJo-Philipp Wich <jo@mein.io>
Tue, 17 Jul 2018 12:40:04 +0000 (14:40 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 17 Jul 2018 12:40:04 +0000 (14:40 +0200)
Drop the parallel-unsafe custom Build/dtb macro and use the .dtb artifacts
produced by the generic image build code.

Also remove unused .dtb references in the mt7623 subtarget.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/mediatek/image/Makefile

index 5e2b2c6d0aab18cb9374f07f65113869afbc0e33..d14c12ee7c557ee4abc4fc579ebcd884c6110d4b 100644 (file)
@@ -16,12 +16,6 @@ ifeq ($(SUBTARGET),mt7622)
 KERNEL_LOADADDR = 0x41080000
 endif
 
-# build dtb
-define Build/dtb
-        $(call Image/BuildDTB,$(DEVICE_DTS_DIR)/$(DEVICE_DTS).dts,$(DEVICE_DTS_DIR)/$(DEVICE_DTS).dtb)
-       $(CP) $(DEVICE_DTS_DIR)/$(DEVICE_DTS).dtb $(BIN_DIR)/
-endef
-
 define Build/sysupgrade-emmc
        rm -f $@.recovery
        mkfs.fat -C $@.recovery 3070
@@ -42,13 +36,13 @@ define Device/Default
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata 
 ifeq ($(SUBTARGET),mt7623)
   KERNEL_NAME := zImage
-  KERNEL := dtb | kernel-bin | append-dtb | uImage none
-  KERNEL_INITRAMFS := dtb | kernel-bin | append-dtb | uImage none
+  KERNEL := kernel-bin | append-dtb | uImage none
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
 endif
 ifeq ($(SUBTARGET),mt7622)
   KERNEL_NAME := Image
-  KERNEL = dtb | kernel-bin | lzma | fit lzma $$(DEVICE_DTS_DIR)/$$(DEVICE_DTS).dtb
-  KERNEL_INITRAMFS = dtb | kernel-bin | lzma | fit lzma $$(DEVICE_DTS_DIR)/$$(DEVICE_DTS).dtb
+  KERNEL = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+  KERNEL_INITRAMFS = kernel-bin | lzma | fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
 endif
 endef