target/toolchain: Fix toolchain packaging without package build
authorMicha Lenk <micha@lenk.info>
Tue, 9 Aug 2016 10:59:06 +0000 (12:59 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 6 Sep 2016 09:40:12 +0000 (11:40 +0200)
If the toolchain is packaged for later use as external toolchain, the resulting
tarball is created in $BIN_DIR. But without building all packages first that
directory isn't created, hence 'make target/toolchain/compile' fails when
trying to create the toolchain tarball with error "Cannot open: No such file or
directory".

To fix that the $BIN_DIR is created before using it.

Signed-off-by: Micha Lenk <micha@lenk.info>
target/toolchain/Makefile

index 2f5186c152a803cfac314343ee08da959abebc89..2fcda3e25ff6a457c4a6cc15ba55eb295504494f 100644 (file)
@@ -58,6 +58,7 @@ $(BIN_DIR)/$(TOOLCHAIN_NAME).tar.bz2: clean
        find $(TOOLCHAIN_BUILD_DIR) -name .git | $(XARGS) rm -rf
        find $(TOOLCHAIN_BUILD_DIR) -name .svn | $(XARGS) rm -rf
        find $(TOOLCHAIN_BUILD_DIR) -name CVS | $(XARGS) rm -rf
+       mkdir -p $(BIN_DIR)
        (cd $(BUILD_DIR); \
                tar cfj $@ $(TOOLCHAIN_NAME); \
        )