kernel: add module for Emulex OneConnect 10Gbit
authorAlberto Bursi <alberto.bursi@outlook.it>
Sun, 15 Sep 2019 22:54:20 +0000 (00:54 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 19 Sep 2019 21:43:27 +0000 (23:43 +0200)
add module to support Emulex OneConnect
common in 10Gbit SFP+ cards by Dell/HP/IBM
supports OneConnect OCe10xxx OCe11xxx OCe14xxx,
LightPulse LPe12xxx

Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it>
package/kernel/linux/modules/netdevices.mk

index 4ed5736bb2dc77b4263a638ee9ceb764f9b388eb..5f8d767679a0d3831233820d1adcd386132eb839 100644 (file)
@@ -1021,3 +1021,24 @@ define KernelPackage/bnx2x/description
 endef
 
 $(eval $(call KernelPackage,bnx2x))
 endef
 
 $(eval $(call KernelPackage,bnx2x))
+
+define KernelPackage/be2net
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Broadcom Emulex OneConnect 10Gbps NIC
+  DEPENDS:=@PCI_SUPPORT +kmod-hwmon-core
+  FILES:=$(LINUX_DIR)/drivers/net/ethernet/emulex/benet/be2net.ko
+  KCONFIG:= \
+       CONFIG_BE2NET \
+       CONFIG_BE2NET_BE2=y \
+       CONFIG_BE2NET_BE3=y \
+       CONFIG_BE2NET_LANCER=y \
+       CONFIG_BE2NET_SKYHAWK=y \
+       CONFIG_BE2NET_HWMON=y
+  AUTOLOAD:=$(call AutoProbe,be2net)
+endef
+
+define KernelPackage/be2net/description
+  Broadcom Emulex OneConnect 10Gbit SFP+ support, OneConnect OCe10xxx OCe11xxx OCe14xxx, LightPulse LPe12xxx
+endef
+
+$(eval $(call KernelPackage,be2net))