brcm63xx: Add DT support for WAP-5813n
authorJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:37 +0000 (11:28 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 21 Aug 2014 11:28:37 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
[jogo: make linux partition writable]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 42243

target/linux/brcm63xx/dts/wap-5813n.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/comtrend.mk

diff --git a/target/linux/brcm63xx/dts/wap-5813n.dts b/target/linux/brcm63xx/dts/wap-5813n.dts
new file mode 100644 (file)
index 0000000..29b85a2
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6368.dtsi"
+
+/ {
+       model = "Comtrend WAP-5813n";
+       compatible = "comtrend,wap-5813n", "brcm,bcm6368";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x7e0000>;
+       };
+
+       nvram@7f0000 {
+               label = "nvram";
+               reg = <0x7f0000 0x010000>;
+       };
+};
index 9c8deb61f62590f13f3a62e9c77201a416975ef3..137cc73250b5e1216eee074c8cda7681275f8293 100755 (executable)
@@ -271,8 +271,6 @@ define Image/Build
        # Sagem F@ST2504n
        $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
 
-       # Comtrend WAP-5813n
-       $(call Image/Build/CFE,$(1),96369R-1231N,6368,WAP-5813n,,--pad 4)
        # Davolink DV201AMR
        $(call Image/Build/CFEOLD,$(1),DV201AMR,6348)
        # USR 9108
@@ -363,6 +361,8 @@ $(eval $(call CfeImageDTB,CT6373,ct-6373,CT6373-1,6358,CT-6373))
 $(eval $(call CfeImageDTB,VR3025u,vr-3025u,96368M-1541N,6368,VR-3025u,,--pad 16 --image-offset 0x20000 --block-size 0x20000))
 # Comtrend VR-3025un
 $(eval $(call CfeImageDTB,VR3025un,vr-3025un,96368M-1341N,6368,VR-3025un,,--pad 4))
+# Comtrend WAP-5813n
+$(eval $(call CfeImageDTB,WAP5813n,wap-5813n,96369R-1231N,6368,WAP-5813n,,--pad 4))
 # D-Link DSL-2740B/DSL-2741B, rev C2
 $(eval $(call CfeImageDTB,DSL274XB_C,dsl-274xb-c,96358GW,6358,DSL274XB-C2))
 # D-Link DSL-2740B/DSL-2741B, rev C3
index c8337cb163b175744cda9c1e00a5037b1e0f764f..4a251db0a83794cc6704a3a7026320723bce597f 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4167,6 +4168,117 @@ static struct board_info __initdata boar
+@@ -4167,6 +4168,118 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
@@ -38,6 +38,7 @@
 +
 +static struct board_info __initdata board_WAP5813n = {
 +      .name                           = "96369R-1231N",
++      .of_board_id                    = "comtrend,wap-5813n",
 +      .expected_cpu_id                = 0x6368,
 +
 +      .has_uart0                      = 1,
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4546,6 +4658,7 @@ static const struct board_info __initcon
+@@ -4546,6 +4659,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 25b7123c72e40c7e0257c015fec9df1f20cb6a72..7aa4e5ed269877e56df756e5f5303ac0e22d4112 100644 (file)
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4658,6 +4769,7 @@ static const struct board_info __initcon
+@@ -4659,6 +4770,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 8e25172f2059262b7960f96136334e1ae986bd4b..49c86773193a7c86121cb56b06913e29c6d8af78 100644 (file)
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4770,6 +4881,7 @@ static const struct board_info __initcon
+@@ -4771,6 +4882,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 35ee212502b9a597c9e7e5db95b9f0b82f99373c..e00bf34973385f4f957039a6e4a28819edf5a2ea 100644 (file)
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .of_board_id                    = "comtrend,vr-3025u",
-@@ -4880,6 +4970,7 @@ static const struct board_info __initcon
+@@ -4881,6 +4971,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 5f5d77118f0eb52c786a2b2ce6001f139cd8cd3e..8e76a16828abd61bdd87d96daf0a4e911eb25e06 100644 (file)
@@ -57,7 +57,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -4954,6 +5004,7 @@ static const struct board_info __initcon
+@@ -4955,6 +5005,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 1f2214f035336e23c07904c33d923919bc373506..c1f505baba95b192af432624bfe77ad291e30375 100644 (file)
@@ -96,7 +96,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -4955,6 +5044,7 @@ static const struct board_info __initcon
+@@ -4956,6 +5045,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 9e524433e1f255b5015a2190c8c1a12349b34e8e..e2dbcac1e863a3491e1481867730671030fe7abb 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5038,6 +5173,7 @@ static const struct board_info __initcon
+@@ -5039,6 +5174,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index b3495b13be404745d85b9030d0c98ab3f43912ba..8c1b8628a6e3d3a5ca7be09064dfe4a8b987b44b 100644 (file)
@@ -72,3 +72,13 @@ define Profile/VR3025un/Description
   Package set optimized for VR-3025un.
 endef
 $(eval $(call Profile,VR3025un))
+
+define Profile/WAP5813n
+  NAME:=Comtrend WAP-5813n
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/WAP5813n/Description
+  Package set optimized for WAP-5813n.
+endef
+$(eval $(call Profile,WAP5813n))