kernel: package TI's USB 3410/505 usb driver
authorJohn Crispin <john@openwrt.org>
Wed, 30 Nov 2011 14:16:58 +0000 (14:16 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 30 Nov 2011 14:16:58 +0000 (14:16 +0000)
This is a patch that adds kernel drivers for TI's USB 3410/5052
devices to the `make menuconfig` GUI during setup.

Signed-off-by: Nemanja Stefanovic <nemik@nemik.net>
SVN-Revision: 29366

package/kernel/modules/usb.mk

index ef05e51cc1b80e7998a4b8dc78d7e49d77ed318b..834baa984f17ff4696d65982b475703976ff7f63 100644 (file)
@@ -354,6 +354,21 @@ endef
 $(eval $(call KernelPackage,usb-serial-ftdi))
 
 
+define KernelPackage/usb-serial-ti-usb
+  TITLE:=Support for TI USB 3410/5052
+  KCONFIG:=CONFIG_USB_SERIAL_TI
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/ti_usb_3410_5052.ko
+  AUTOLOAD:=$(call AutoLoad,65,ti_usb_3410_5052)
+  $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-ti-usb/description
+ Kernel support for TI USB 3410/5052 devices
+endef
+
+$(eval $(call KernelPackage,usb-serial-ti-usb))
+
+
 define KernelPackage/usb-serial-ipw
   TITLE:=Support for IPWireless 3G devices
   KCONFIG:=CONFIG_USB_SERIAL_IPW