ramips/rt288x,rt3883: Synchronize Makefiles with DTS compatible
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 3 Jul 2019 21:22:16 +0000 (23:22 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 10 Jul 2019 15:36:29 +0000 (17:36 +0200)
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/preinit/04_handle_checksumming
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/image/rt288x.mk
target/linux/ramips/image/rt3883.mk

index d044ec7bcca5436b1f3ce8ff5a64d5448fb35c0c..ec8abae5822bd0021cac9096679716323e7b3622 100755 (executable)
@@ -18,7 +18,7 @@ led_wlan="$(get_dt_led wlan)"
 
 case $board in
 3g-6200n|\
-br-6475nd|\
+edimax,br-6475nd|\
 mzk-w300nh2)
        set_wifi_led "$boardname:amber:wlan"
        ;;
@@ -59,8 +59,8 @@ all0256n-8M)
        ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "all0256n:green:rssihigh" "wlan0" "70" "100" "-69" "8"
        set_wifi_led "rt2800pci-phy0::radio"
        ;;
-ar670w|\
-ar725w|\
+airlink101,ar670w|\
+airlink101,ar725w|\
 awapn2403)
        set_wifi_led "rt2800soc-phy0::radio"
        ;;
@@ -127,7 +127,7 @@ hlk-rm04|\
 kn|\
 nbg-419n2|\
 sl-r7205|\
-v11st-fe|\
+ralink,v11st-fe|\
 w306r-v20|\
 w502u|\
 wt1520-4M|\
@@ -175,7 +175,7 @@ netgear,ex3700)
        ucidef_set_led_netdev "wlan5g" "ROUTER (green)" "$boardname:green:router" "wlan0"
        ucidef_set_led_netdev "wlan2g" "DEVICE (green)" "$boardname:green:device" "wlan1"
        ;;
-f5d8235-v1)
+belkin,f5d8235-v1)
        set_wifi_led "$boardname:blue:wireless"
        ;;
 fonera20n|\
@@ -211,7 +211,7 @@ hg255d)
        set_wifi_led "$boardname:green:wlan"
        ucidef_set_led_netdev "internet" "internet" "$boardname:green:internet" "eth0.2"
        ;;
-hpm)
+omnima,hpm)
        ucidef_set_led_netdev "eth" "ETH" "$boardname:green:eth" "eth0"
        set_wifi_led "$boardname:green:wifi"
        ;;
index 94cc9e0ccdba15d5d8698d1329ca7c693a40f54a..8bbd362589f483347c9a9a59a15de587d381b739 100755 (executable)
@@ -164,7 +164,7 @@ ramips_setup_interfaces()
        dlink,dch-m225|\
        netgear,ex2700|\
        netgear,ex3700|\
-       hpm|\
+       omnima,hpm|\
        planex,mzk-ex300np|\
        planex,mzk-ex750np|\
        sercomm,na930|\
@@ -174,8 +174,8 @@ ramips_setup_interfaces()
        tplink,tl-mr3020-v3|\
        tplink,tl-wr802n-v4|\
        kimax,u25awf-h1|\
-       wli-tx4-ag300n|\
-       wmdr-143n|\
+       buffalo,wli-tx4-ag300n|\
+       loewe,wmdr-143n|\
        buffalo,wmr-300|\
        netgear,wn3000rp-v3|\
        elecom,wrh-300cr)
@@ -200,15 +200,15 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:lan:1" "1:lan:2" "2:lan:3" "3:lan:4" "4:wan:5" "6@eth0"
                ;;
-       ar670w|\
-       ar725w|\
+       airlink101,ar670w|\
+       airlink101,ar725w|\
        rakwireless,rak633|\
        asus,rt-ac51u)
                ucidef_add_switch "switch0" \
                        "0:wan" "1:lan" "2:lan" "3:lan" "4:lan" "6t@eth0"
                ;;
        belkin,f9k1109v1|\
-       rt-n15|\
+       asus,rt-n15|\
        wl-351)
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "5@eth0"
@@ -224,7 +224,7 @@ ramips_setup_interfaces()
        awm002-evb-8M|\
        bdcom,wap2100-sk|\
        tplink,archer-c20i|\
-       dir-645|\
+       dlink,dir-645|\
        glinet,gl-mt300a|\
        glinet,gl-mt300n|\
        glinet,gl-mt750|\
@@ -297,7 +297,7 @@ ramips_setup_interfaces()
        wr6202)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ;;
-       br-6475nd)
+       edimax,br-6475nd)
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "9@eth0"
                ;;
@@ -310,7 +310,7 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "2:lan:2" "3:lan:1" "4:wan" "6@eth0"
                ;;
-       cy-swr1100)
+       samsung,cy-swr1100)
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "9@eth0"
                ;;
@@ -394,7 +394,7 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:lan:1" "1:lan:2" "2:lan:3" "3:lan:4" "6@eth0"
                ;;
-       rt-n56u)
+       asus,rt-n56u)
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "8@eth0"
                ;;
@@ -403,9 +403,9 @@ ramips_setup_interfaces()
                        "4:lan" "6@eth0"
                ;;
        lava,lr-25g001|\
-       tew-691gr|\
-       tew-692gr|\
-       wlr-6000)
+       trendnet,tew-691gr|\
+       trendnet,tew-692gr|\
+       sitecom,wlr-6000)
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "5:wan" "0@eth0"
                ;;
@@ -424,11 +424,11 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:lan" "2:lan" "6t@eth0"
                ;;
-       f5d8235-v1|\
+       belkin,f5d8235-v1|\
        f5d8235-v2|\
        tew-714tru|\
-       v11st-fe|\
-       wzr-agl300nh)
+       ralink,v11st-fe|\
+       buffalo,wzr-agl300nh)
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "5@eth0"
                ;;
@@ -499,7 +499,7 @@ ramips_setup_macs()
        case $board in
        a5-v11|\
        ht-tm02|\
-       wmdr-143n)
+       loewe,wmdr-143n)
                lan_mac=$(cat /sys/class/net/eth0/address)
                ;;
        carambola|\
@@ -531,15 +531,15 @@ ramips_setup_macs()
                wan_mac=$(mtd_get_mac_ascii uboot-env HW_WAN_MAC)
                lan_mac=$(mtd_get_mac_ascii uboot-env HW_LAN_MAC)
                ;;
-       br-6475nd)
+       edimax,br-6475nd)
                lan_mac=$(cat /sys/class/net/eth0/address)
                wan_mac=$(mtd_get_mac_binary devdata 7)
                ;;
-       cy-swr1100|\
+       samsung,cy-swr1100|\
        dlink,dch-m225)
                lan_mac=$(mtd_get_mac_ascii factory lanmac)
                ;;
-       dir-645)
+       dlink,dir-645)
                lan_mac=$(mtd_get_mac_ascii nvram lanmac)
                wan_mac=$(mtd_get_mac_ascii nvram wanmac)
                ;;
@@ -637,7 +637,7 @@ ramips_setup_macs()
                wan_mac=$(mtd_get_mac_binary factory 4)
                lan_mac=$(macaddr_add "$wan_mac" 1)
                ;;
-       rt-n56u)
+       asus,rt-n56u)
                lan_mac=$(cat /sys/class/net/eth0/address)
                lan_mac=$(macaddr_setbit_la "$lan_mac")
                wan_mac=$(mtd_get_mac_binary factory 32772)
@@ -646,10 +646,10 @@ ramips_setup_macs()
                lan_mac=$(mtd_get_mac_binary factory 40)
                wan_mac=$(mtd_get_mac_binary factory 46)
                ;;
-       tew-691gr)
+       trendnet,tew-691gr)
                wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory 4)" 3)
                ;;
-       tew-692gr)
+       trendnet,tew-692gr)
                wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory 4)" 1)
                ;;
        dovado,tiny-ac)
@@ -684,7 +684,7 @@ ramips_setup_macs()
                lan_mac=$(mtd_get_mac_binary factory 4)
                wan_mac=$(mtd_get_mac_binary factory 40)
                ;;
-       wlr-6000)
+       sitecom,wlr-6000)
                wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory 32772)" 2)
                ;;
        xiaomi,mir3g|\
index 007abf79f6d69b4bec9786e9956fef069ba79332..3be82ae4416d202b4e24beeab609de2b9ea46bb7 100644 (file)
@@ -35,7 +35,7 @@ do_checksumming_disable() {
                        echo "Checksum is already zero, nothing to do."
                fi
        ;;
-       rt-n56u)
+       asus,rt-n56u)
                echo "Board is ASUS RT-N56U, replacing uImage header..."
                local firmware_mtd=$(find_mtd_part firmware)
                local rootfs_mtd=$(find_mtd_part rootfs)
index 013412b58905726f1629dba4270fe727c1c362a9..e52402f0a2f70ff411437573ceb6a6909487b45b 100755 (executable)
@@ -40,12 +40,6 @@ ramips_board_detect() {
        *"ALL5003")
                name="all5003"
                ;;
-       *"AR670W")
-               name="ar670w"
-               ;;
-       *"AR725W")
-               name="ar725w"
-               ;;
        *"ASL26555 (8M)")
                name="asl26555-8M"
                ;;
@@ -67,18 +61,12 @@ ramips_board_detect() {
        *"BC2")
                name="bc2"
                ;;
-       *"BR-6475nD")
-               name="br-6475nd"
-               ;;
        *"Broadway")
                name="broadway"
                ;;
        *"Carambola")
                name="carambola"
                ;;
-       *"CY-SWR1100")
-               name="cy-swr1100"
-               ;;
        *"D105")
                name="d105"
                ;;
@@ -118,18 +106,12 @@ ramips_board_detect() {
        *"DIR-620 D1")
                name="dir-620-d1"
                ;;
-       *"DIR-645")
-               name="dir-645"
-               ;;
        *"DWR-512 B")
                name="dwr-512-b"
                ;;
        *"ESR-9753")
                name="esr-9753"
                ;;
-       *"F5D8235 v1")
-               name="f5d8235-v1"
-               ;;
        *"F5D8235 v2")
                name="f5d8235-v2"
                ;;
@@ -148,9 +130,6 @@ ramips_board_detect() {
        *"HLK-RM04")
                name="hlk-rm04"
                ;;
-       *"HPM")
-               name="hpm"
-               ;;
        *"HT-TM02")
                name="ht-tm02"
                ;;
@@ -259,12 +238,6 @@ ramips_board_detect() {
        *"RT-N13U")
                name="rt-n13u"
                ;;
-       *"RT-N15")
-               name="rt-n15"
-               ;;
-       *"RT-N56U")
-               name="rt-n56u"
-               ;;
        *"RUT5XX")
                name="rut5xx"
                ;;
@@ -274,12 +247,6 @@ ramips_board_detect() {
        *"TEW-638APB v2")
                name="tew-638apb-v2"
                ;;
-       *"TEW-691GR")
-               name="tew-691gr"
-               ;;
-       *"TEW-692GR")
-               name="tew-692gr"
-               ;;
        *"TEW-714TRU")
                name="tew-714tru"
                ;;
@@ -289,9 +256,6 @@ ramips_board_detect() {
        *"UR-336UN")
                name="ur-336un"
                ;;
-       *"V11ST-FE")
-               name="v11st-fe"
-               ;;
        *"V22RW-2X2")
                name="v22rw-2x2"
                ;;
@@ -331,15 +295,6 @@ ramips_board_detect() {
        *"WL-351 v1 002")
                name="wl-351"
                ;;
-       *"WLI-TX4-AG300N")
-               name="wli-tx4-ag300n"
-               ;;
-       *"WLR-6000")
-               name="wlr-6000"
-               ;;
-       *"WMDR-143N")
-               name="wmdr-143n"
-               ;;
        *"WNCE2001")
                name="wnce2001"
                ;;
@@ -358,9 +313,6 @@ ramips_board_detect() {
        *"WT1520 (8M)")
                name="wt1520-8M"
                ;;
-       *"WZR-AGL300NH")
-               name="wzr-agl300nh"
-               ;;
        *"X5")
                name="x5"
                ;;
index 22fe4a857a25a5b35751dec08a2cce9867c1ecc7..fe6764ce59a9d277c9c62ed3b0ddec2b97a705d3 100644 (file)
@@ -9,7 +9,7 @@ define Build/gemtek-header
        fi
 endef
 
-define Device/ar670w
+define Device/airlink101_ar670w
   DTS := AR670W
   BLOCKSIZE := 64k
   DEVICE_VENDOR := Airlink
@@ -19,18 +19,20 @@ define Device/ar670w
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
        wrg-header wrgn16a_airlink_ar670w
+  SUPPORTED_DEVICES += ar670w
 endef
-TARGET_DEVICES += ar670w
+TARGET_DEVICES += airlink101_ar670w
 
-define Device/ar725w
+define Device/airlink101_ar725w
   DTS := AR725W
   DEVICE_VENDOR := Airlink
   DEVICE_MODEL := AR725W
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size 3328k | \
        gemtek-header ar725w
+  SUPPORTED_DEVICES += ar725w
 endef
-TARGET_DEVICES += ar725w
+TARGET_DEVICES += airlink101_ar725w
 
 define Device/dlink_dap-1522-a1
   DTS := DAP-1522-A1
@@ -50,7 +52,7 @@ define Device/dlink_dap-1522-a1
 endef
 TARGET_DEVICES += dlink_dap-1522-a1
 
-define Device/f5d8235-v1
+define Device/belkin_f5d8235-v1
   DTS := F5D8235_V1
   IMAGE_SIZE := 7744k
   DEVICE_VENDOR := Belkin
@@ -58,44 +60,49 @@ define Device/f5d8235-v1
   DEVICE_VARIANT := V1
   DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-core kmod-usb-ohci \
     kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
+  SUPPORTED_DEVICES += f5d8235-v1
 endef
-TARGET_DEVICES += f5d8235-v1
+TARGET_DEVICES += belkin_f5d8235-v1
 
-define Device/rt-n15
+define Device/asus_rt-n15
   DTS := RT-N15
   BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_VENDOR := Asus
   DEVICE_MODEL := RT-N15
   DEVICE_PACKAGES := kmod-switch-rtl8366s
+  SUPPORTED_DEVICES += rt-n15
 endef
-TARGET_DEVICES += rt-n15
+TARGET_DEVICES += asus_rt-n15
 
-define Device/v11st-fe
+define Device/ralink_v11st-fe
   DTS := V11STFE
   BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_VENDOR := Ralink
   DEVICE_MODEL := V11ST-FE
+  SUPPORTED_DEVICES += v11st-fe
 endef
-TARGET_DEVICES += v11st-fe
+TARGET_DEVICES += ralink_v11st-fe
 
-define Device/wli-tx4-ag300n
+define Device/buffalo_wli-tx4-ag300n
   DTS := WLI-TX4-AG300N
   BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_VENDOR := Buffalo
   DEVICE_MODEL := WLI-TX4-AG300N
   DEVICE_PACKAGES := kmod-switch-ip17xx
+  SUPPORTED_DEVICES += wli-tx4-ag300n
 endef
-TARGET_DEVICES += wli-tx4-ag300n
+TARGET_DEVICES += buffalo_wli-tx4-ag300n
 
-define Device/wzr-agl300nh
+define Device/buffalo_wzr-agl300nh
   DTS := WZR-AGL300NH
   BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_VENDOR := Buffalo
   DEVICE_MODEL := WZR-AGL300NH
   DEVICE_PACKAGES := kmod-switch-rtl8366s
+  SUPPORTED_DEVICES += wzr-agl300nh
 endef
-TARGET_DEVICES += wzr-agl300nh
+TARGET_DEVICES += buffalo_wzr-agl300nh
index 4150f96cf06f9bc6c16ee1a4ef5bf454b99d1661..9e1d928603a3f2f73e03df59171a631c3b3977c6 100644 (file)
@@ -5,7 +5,7 @@ define Build/mkrtn56uimg
        $(STAGING_DIR_HOST)/bin/mkrtn56uimg $(1) $@
 endef
 
-define Device/br-6475nd
+define Device/edimax_br-6475nd
   DTS := BR-6475ND
   BLOCKSIZE := 64k
   IMAGE_SIZE := 7744k
@@ -15,10 +15,11 @@ define Device/br-6475nd
   DEVICE_VENDOR := Edimax
   DEVICE_MODEL := BR-6475nD
   DEVICE_PACKAGES := swconfig
+  SUPPORTED_DEVICES += br-6475nd
 endef
-TARGET_DEVICES += br-6475nd
+TARGET_DEVICES += edimax_br-6475nd
 
-define Device/cy-swr1100
+define Device/samsung_cy-swr1100
   $(Device/seama)
   DTS := CY-SWR1100
   BLOCKSIZE := 64k
@@ -27,11 +28,12 @@ define Device/cy-swr1100
   DEVICE_VENDOR := Samsung
   DEVICE_MODEL := CY-SWR1100
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+  SUPPORTED_DEVICES += cy-swr1100
 endef
-TARGET_DEVICES += cy-swr1100
+TARGET_DEVICES += samsung_cy-swr1100
 
 
-define Device/dir-645
+define Device/dlink_dir-645
   $(Device/seama)
   DTS := DIR-645
   BLOCKSIZE := 4k
@@ -40,8 +42,9 @@ define Device/dir-645
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DIR-645
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+  SUPPORTED_DEVICES += dir-645
 endef
-TARGET_DEVICES += dir-645
+TARGET_DEVICES += dlink_dir-645
 
 
 define Device/belkin_f9k1109v1
@@ -58,29 +61,31 @@ define Device/belkin_f9k1109v1
 endef
 TARGET_DEVICES += belkin_f9k1109v1
 
-define Device/hpm
+define Device/omnima_hpm
   DTS := HPM
   BLOCKSIZE := 64k
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Omnima
   DEVICE_MODEL := HPM
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2
+  SUPPORTED_DEVICES += hpm
 endef
-TARGET_DEVICES += hpm
+TARGET_DEVICES += omnima_hpm
 
 
-define Device/rt-n56u
+define Device/asus_rt-n56u
   DTS := RT-N56U
   BLOCKSIZE := 64k
   IMAGE/sysupgrade.bin += | mkrtn56uimg -s
   DEVICE_VENDOR := Asus
   DEVICE_MODEL := RT-N56U
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+  SUPPORTED_DEVICES += rt-n56u
 endef
-TARGET_DEVICES += rt-n56u
+TARGET_DEVICES += asus_rt-n56u
 
 
-define Device/tew-691gr
+define Device/trendnet_tew-691gr
   DTS := TEW-691GR
   BLOCKSIZE := 64k
   IMAGES += factory.bin
@@ -89,11 +94,12 @@ define Device/tew-691gr
   DEVICE_VENDOR := TRENDnet
   DEVICE_MODEL := TEW-691GR
   DEVICE_PACKAGES := swconfig
+  SUPPORTED_DEVICES += tew-691gr
 endef
-TARGET_DEVICES += tew-691gr
+TARGET_DEVICES += trendnet_tew-691gr
 
 
-define Device/tew-692gr
+define Device/trendnet_tew-692gr
   DTS := TEW-692GR
   BLOCKSIZE := 64k
   IMAGES += factory.bin
@@ -102,11 +108,12 @@ define Device/tew-692gr
   DEVICE_VENDOR := TRENDnet
   DEVICE_MODEL := TEW-692GR
   DEVICE_PACKAGES := swconfig
+  SUPPORTED_DEVICES += tew-692gr
 endef
-TARGET_DEVICES += tew-692gr
+TARGET_DEVICES += trendnet_tew-692gr
 
 
-define Device/wlr-6000
+define Device/sitecom_wlr-6000
   DTS := WLR-6000
   BLOCKSIZE := 4k
   IMAGE_SIZE := 7244k
@@ -116,14 +123,16 @@ define Device/wlr-6000
   DEVICE_VENDOR := Sitecom
   DEVICE_MODEL := WLR-6000
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+  SUPPORTED_DEVICES += wlr-6000
 endef
-TARGET_DEVICES += wlr-6000
+TARGET_DEVICES += sitecom_wlr-6000
 
 
-define Device/wmdr-143n
+define Device/loewe_wmdr-143n
   DTS := WMDR-143N
   BLOCKSIZE := 64k
   DEVICE_VENDOR := Loewe
   DEVICE_MODEL := WMDR-143N
+  SUPPORTED_DEVICES += wmdr-143n
 endef
-TARGET_DEVICES += wmdr-143n
+TARGET_DEVICES += loewe_wmdr-143n