target/ixp4xx: fix image building after r20834 (closes: #7157)
authorNicolas Thill <nico@openwrt.org>
Wed, 14 Apr 2010 14:36:41 +0000 (14:36 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 14 Apr 2010 14:36:41 +0000 (14:36 +0000)
SVN-Revision: 20854

scripts/arm-magic.sh
target/linux/iop32x/image/Makefile
target/linux/ixp4xx/image/Makefile

index e8f41d3372cfbe694afd101d7968895b371433a7..8bc35c1d4bfcb24ed134071c3dff42b441bd8360 100755 (executable)
@@ -34,5 +34,5 @@ do
     printf "\xe3\xa0\x10\x$(echo $hexid|cut -b "2 3")\xe3\x81\x1c\x$(echo $hexid|cut -b 1)" > $BIN_DIR/openwrt-$1-zImage
   fi
     # generate the image
-    cat $BIN_DIR/openwrt-ixp4xx-zImage >> $BIN_DIR/openwrt-$1-zImage
+    cat $BIN_DIR/$IMG_PREFIX-zImage >> $BIN_DIR/openwrt-$1-zImage
 done
index 808628953a3b4643fe8b1d2987111ee18a751167..160067386dbf4fe5836ce713c642c9b772e4f562 100644 (file)
@@ -16,7 +16,7 @@ define Image/BuildKernel
 #
 # XXX - FIXME
 #
-#      BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
+#      BIN_DIR=$(BIN_DIR) IMG_PREFIX="$(IMG_PREFIX)" $(TOPDIR)/scripts/arm-magic.sh
 endef
 
 define Image/Build
index da8f0fdde6c446120a43471b7a4cb95d422aeecc..6108e9166deba4660752edebabb7dda318b46840 100644 (file)
@@ -37,7 +37,7 @@ endef
 
 define Image/BuildKernel
        cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
-       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
+       BIN_DIR=$(BIN_DIR) IMG_PREFIX="$(IMG_PREFIX)" $(TOPDIR)/scripts/arm-magic.sh
 endef
 
 define Image/Build