brcm63xx: add DT support for DSL-2640B
authorJonas Gorski <jogo@openwrt.org>
Mon, 8 Dec 2014 16:10:41 +0000 (16:10 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 8 Dec 2014 16:10:41 +0000 (16:10 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 43571

target/linux/brcm63xx/dts/dsl-2640b-b.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/500-board-D4PW.patch
target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch
target/linux/brcm63xx/patches-3.18/500-board-D4PW.patch
target/linux/brcm63xx/patches-3.18/514-board_ct536_ct5621.patch
target/linux/brcm63xx/profiles/d-link.mk

diff --git a/target/linux/brcm63xx/dts/dsl-2640b-b.dts b/target/linux/brcm63xx/dts/dsl-2640b-b.dts
new file mode 100644 (file)
index 0000000..efc0dc5
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "D-Link DSL-2640B rev B2";
+       compatible = "d-link,dsl-2640b-b", "brcm,bcm6348";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x3e0000>;
+       };
+
+       nvram@3f0000 {
+               label = "nvram";
+               reg = <0x3f0000 0x010000>;
+       };
+};
index 30fb36335fc048afafc1f1e96c21439947386651..48492fabf6c28910d0a01bbc071b63856c8cc846 100755 (executable)
@@ -206,8 +206,6 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96348GW-10,6348,DG834GT_DG834PN)
        # Belkin f5d7633
        $(call Image/Build/CFE,$(1),96348GW-10,6348,F5D7633)
-       # D-Link DSL-2640B, rev B2
-       $(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B-B2)
 
        # TP-Link 8900GB
        $(call Image/Build/CFE,$(1),96348GW-11,6348,TD8900GB,$(shell printf 'PRID\x89\x10\x00\x02'))
@@ -283,6 +281,8 @@ $(eval $(call ImageDTB,CFEDTB,VR3025u,vr-3025u,96368M-1541N,6368,VR-3025u,--pad
 $(eval $(call ImageDTB,CFEDTB,VR3025un,vr-3025un,96368M-1341N,6368,VR-3025un,--pad 4))
 # Comtrend WAP-5813n
 $(eval $(call ImageDTB,CFEDTB,WAP5813n,wap-5813n,96369R-1231N,6368,WAP-5813n,--pad 4))
+# D-Link DSL-2640B, rev B2
+$(eval $(call ImageDTB,CFEDTB,DSL2640B_B,dsl-2640b-b,D-4P-W,6348,DSL2640B-B2))
 # D-Link DSL-2650U
 $(eval $(call ImageDTB,CFEDTB,DSL2650U,dsl-2650u,96358VW2,6358,DSL2650U))
 # D-Link DSL-2740B/DSL-2741B, rev C2
index b54a3e5443c25c59eca9e5c9a278c1fa6bc9288d..25b558ac5ce504817b54f07dca49f0b49d120325 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
+@@ -755,6 +806,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
+       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+       { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
++      { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
+       { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
+       { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+       { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
index 4c44094d435b54c6fa74b1ce837bf9fbf16c149f..f6a655b1350c27d843394742f2bf4186513440c4 100644 (file)
@@ -73,6 +73,6 @@
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
 +      { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
 +      { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
+       { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
        { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
-       { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
index b54a3e5443c25c59eca9e5c9a278c1fa6bc9288d..25b558ac5ce504817b54f07dca49f0b49d120325 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
+@@ -755,6 +806,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
+       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+       { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
++      { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
+       { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
+       { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
+       { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
index 4c44094d435b54c6fa74b1ce837bf9fbf16c149f..f6a655b1350c27d843394742f2bf4186513440c4 100644 (file)
@@ -73,6 +73,6 @@
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
 +      { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
 +      { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
+       { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
        { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
-       { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
index 4bfefb9ee470f8d4987189d05a9699ebb972021d..71f642153574287020da5c94b422e8fbe435cebf 100644 (file)
@@ -5,6 +5,15 @@
 # See /LICENSE for more information.
 #
 
+define Profile/DSL2640B_B
+  NAME:=D-Link DSL-2640B rev B2
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/DSL2640B_B/Description
+  Package set optimized for DSL-2640B rev B2.
+endef
+$(eval $(call Profile,DSL2640B_B))
+
 define Profile/DSL2650U
   NAME:=D-Link DSL-2650U
   PACKAGES:=kmod-b43 wpad-mini\