kexec-tools: remove useless CONFIG_KEXEC_TOOLS_TARGET_NAME indirection
authorFelix Fietkau <nbd@nbd.name>
Mon, 19 Dec 2016 18:28:33 +0000 (19:28 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 20 Dec 2016 15:24:22 +0000 (16:24 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/boot/kexec-tools/Config.in
package/boot/kexec-tools/Makefile

index 6c7558f30a50852c7145692d28ac6249f7fba9e1..03bc6ee804285d9a6f4872cf6846999259898099 100644 (file)
@@ -1,16 +1,6 @@
 menu "Configuration"
        depends on PACKAGE_kexec-tools
 
-config KEXEC_TOOLS_TARGET_NAME
-       string
-       prompt "Target name for kexec kernel"
-       default EXTRA_TARGET_ARCH_NAME  if powerpc64
-       default ARCH
-       help
-         Defines the target type of the kernels that kexec deals
-         with. This should be the target specification of
-         the kernel you're booting.
-
 config KEXEC_TOOLS_kdump
        bool
        prompt "kdump support"
index 5df8817bccdfa7f76e770e4b45166e62b17bf065..ecd2a6ea115ee0177f74c5aa433078e56c6ef04a 100644 (file)
@@ -40,7 +40,7 @@ define Package/kexec-tools/config
        source "$(SOURCE)/Config.in"
 endef
 
-KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
+KEXEC_TARGET_NAME:=$(ARCH)-linux-$(TARGET_SUFFIX)
 
 CONFIGURE_ARGS = \
                --target=$(KEXEC_TARGET_NAME) \