ar71xx: create firmware images for the TL-WR941ND v3 boards
authorGabor Juhos <juhosg@openwrt.org>
Mon, 26 Apr 2010 18:27:51 +0000 (18:27 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 26 Apr 2010 18:27:51 +0000 (18:27 +0000)
SVN-Revision: 21169

target/linux/ar71xx/image/Makefile
target/linux/ar71xx/profiles/tp-link.mk

index a5f02703c9fb591cc15e2afce197129071daf0a6..dfcc5f6f08d1d960ce15c461ad3950658e2ff7c3 100644 (file)
@@ -518,6 +518,10 @@ define Image/Build/Profile/TLWR941NDV2
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v2,board=TL-WR941ND,TL-WR941NDv2)
 endef
 
+define Image/Build/Profile/TLWR941NDV3
+       $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v3,board=TL-WR941ND,TL-WR941NDv2)
+endef
+
 define Image/Build/Profile/TLWR941NDV4
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr941nd-v4,board=TL-WR741ND,TL-WR941NDv4)
 endef
@@ -566,6 +570,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))
        $(call Image/Build/Profile/TLWR941NDV2,$(1))
+       $(call Image/Build/Profile/TLWR941NDV3,$(1))
        $(call Image/Build/Profile/TLWR941NDV4,$(1))
        $(call Image/Build/Profile/TLWR1043NDV1,$(1))
        $(call Image/Build/Profile/UBNT,$(1))
index ffb3b9e06d528ee836417c3d5dfcd809c10638d1..7efb1a3766fe643e237ef1a8ee3a73d3fa9b0172 100644 (file)
@@ -60,6 +60,17 @@ endef
 
 $(eval $(call Profile,TLWR941NDV2))
 
+define Profile/TLWR941NDV3
+       NAME:=TP-LINK TL-WR941ND v3
+       PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR941NDV3/Description
+       Package set optimized for the TP-LINK TL-WR941ND v3.
+endef
+
+$(eval $(call Profile,TLWR941NDV3))
+
 define Profile/TLWR941NDV4
        NAME:=TP-LINK TL-WR941ND v4
        PACKAGES:=kmod-ath9k wpad-mini