kernel: bump 4.9 to 4.9.177
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 17 May 2019 12:34:09 +0000 (14:34 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 21 May 2019 07:48:48 +0000 (09:48 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/509-MIPS-ath79-process-board-kernel-option.patch
target/linux/ar71xx/patches-4.9/604-MIPS-ath79-no-of.patch
target/linux/x86/patches-4.9/200-pcengines-apu2-reboot.patch

index 03dbc45f3250a20af43c7f2864d8ce3128a50f8c..1a5d781af1311b81d6b813e84b958adeef8f472d 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .176
+LINUX_VERSION-4.9 = .177
 LINUX_VERSION-4.14 = .119
 
-LINUX_KERNEL_HASH-4.9.176 = 2a94d008c0737f01d4b78f669a3c40e334cacebe4d62eb25252171cee205b178
+LINUX_KERNEL_HASH-4.9.177 = c73b1e3ebcc35b653f7b673ca151fc67b814bdb27269799fa7cda251827887ee
 LINUX_KERNEL_HASH-4.14.119 = 5615b713389d74044eaa57032dab674228116b63ed358086c33bd929d7ad3b7c
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 3091ab69b60e56079a22ed2c3c3015ed000c5cf4..139b09c1b0e7b71d07cfbaa64d0e21c05cace700 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/setup.c
 +++ b/arch/mips/ath79/setup.c
-@@ -283,6 +283,8 @@ void __init plat_time_init(void)
+@@ -277,6 +277,8 @@ void __init plat_time_init(void)
        mips_hpt_frequency = cpu_clk_rate / 2;
  }
  
index 89dd32a7c10c2a28c5eada26658650e9364f1305..ba855e15008ea8f660b721ea98992bd206e0f07b 100644 (file)
@@ -10,7 +10,7 @@
  
 --- a/arch/mips/ath79/setup.c
 +++ b/arch/mips/ath79/setup.c
-@@ -196,16 +196,20 @@ unsigned int get_c0_compare_int(void)
+@@ -190,16 +190,20 @@ unsigned int get_c0_compare_int(void)
  
  void __init plat_mem_setup(void)
  {
@@ -31,7 +31,7 @@
  
        if (mips_machtype != ATH79_MACH_GENERIC_OF) {
                ath79_reset_base = ioremap_nocache(AR71XX_RESET_BASE,
-@@ -301,17 +305,21 @@ static int __init ath79_setup(void)
+@@ -295,17 +299,21 @@ static int __init ath79_setup(void)
  
  arch_initcall(ath79_setup);
  
index 6c2b21d157bcb7e4b475fc28a61bca409f5c6416..0eaf1ed70cddbe1834a54497febcc4e9c6c5f513 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/x86/kernel/reboot.c
 +++ b/arch/x86/kernel/reboot.c
-@@ -449,6 +449,16 @@ static struct dmi_system_id __initdata r
+@@ -470,6 +470,16 @@ static struct dmi_system_id __initdata r
                },
        },