6in4: make host dependency more specific
authorSteven Barth <cyrus@openwrt.org>
Tue, 10 Mar 2015 08:43:40 +0000 (08:43 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 10 Mar 2015 08:43:40 +0000 (08:43 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 44635

package/network/ipv6/6in4/Makefile
package/network/ipv6/6in4/files/6in4.sh

index ef9691227a2269e1984b7fff82f3932b8d85be33..21e69e6f49acf8716726cbe0bca0c9b0e0f4b104 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=20
+PKG_VERSION:=21
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
index f8a43ce24b71ee5d7320198add30ec5e1619c881..0289df30316cbf48ab38fb99346ff889e647b206 100755 (executable)
@@ -36,7 +36,7 @@ proto_6in4_setup() {
                return
        }
 
                return
        }
 
-       ( proto_add_host_dependency "$cfg" 0.0.0.0 )
+       ( proto_add_host_dependency "$cfg" "$peeraddr" )
 
        [ -z "$ipaddr" ] && {
                local wanif
 
        [ -z "$ipaddr" ] && {
                local wanif