add support for the Pirelli AG226G board (#5337)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:19:47 +0000 (10:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Aug 2009 10:19:47 +0000 (10:19 +0000)
SVN-Revision: 17190

target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
target/linux/brcm63xx/image/Makefile
tools/firmware-utils/src/imagetag.c

index 4551ef613d14c53eb29118daa82290673f470b0c..2c56a3cf7830fcaaa44aa171051447f7d0ed8b7b 100644 (file)
@@ -543,6 +543,27 @@ static struct board_info __initdata board_AGPFS0 = {
        .has_ohci0 = 1,
        .has_ehci0 = 1,
 };
+
+static struct board_info __initdata board_DWVS0 = {
+       .name                           = "DWV-S0",
+       .expected_cpu_id                = 0x6358,
+
+       .has_enet0                      = 1,
+       .has_enet1                      = 1,
+       .has_pci                        = 1,
+
+       .enet0 = {
+               .has_phy                = 1,
+               .use_internal_phy       = 1,
+       },
+
+       .enet1 = {
+               .force_speed_100        = 1,
+               .force_duplex_full      = 1,
+       },
+
+       .has_ohci0 = 1,
+};
 #endif
 
 /*
@@ -570,6 +591,7 @@ static const struct board_info __initdata *bcm963xx_boards[] = {
        &board_96358vw,
        &board_96358vw2,
        &board_AGPFS0,
+       &board_DWVS0,
 #endif
 };
 
index b008ea2602d7342c0ad3a5bc37068c90bf45f811..c583aa54e13f041307ac99ca9cabc15119295b68 100644 (file)
@@ -169,6 +169,9 @@ define Image/Build
        # Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
        $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000,bccfe,,bccfe)
        $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358,0x20000,ag306,,agv2+w)
+       # Pirelli A226G
+       $(call Image/Build/CFEAGPF,$(1),DWV-S0,6358,0x10000,bccfe,,bccfe)
+       $(call Image/Build/CFEAGPF,$(1),DWV-S0,6358,0x10000,ag306,DWV_96358,a226g)
 endef
 
 $(eval $(call BuildImage))
index bd62b203390cb221d3759e30cd7504c039c9e948..e93f5f45e8081e59ea9d778a972fe1bb779bcc28 100644 (file)
@@ -219,6 +219,10 @@ int tagfile(const char *kernel, const char *rootfs, const char *bin,
        fseek(binfile, rootfsoff + rootfslen - fwaddr, SEEK_SET);
        fwrite(&deadcode, sizeof(uint32_t), 1, binfile);
        
+       /* Flush the binfile buffer so that when we read from file, it contains
+         * everything in the buffer
+        */
+       fflush(binfile);
 
        /* Choose and compute the CRC32 that should be inserted in the tag */
         if ( tagid && ( (strncmp(tagid, "bccfe", TAGID_LEN) == 0)) || ( strncmp(tagid, "bc300", TAGID_LEN) == 0)) {