ipq40xx: use upstream board-2.bin
authorSven Eckelmann <sven.eckelmann@openmesh.com>
Thu, 19 Apr 2018 07:12:22 +0000 (09:12 +0200)
committerMathias Kresin <dev@kresin.me>
Mon, 23 Apr 2018 20:07:22 +0000 (22:07 +0200)
The BDFs for all boards were upstreamed to the ath10k-firmware
repository and are now part of ath10k-firmware 2018-04-19.

Signed-off-by: Sven Eckelmann <sven.eckelmann@openmesh.com>
target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4018-fritz4040.dts
target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4018-rt-ac58u.dts
target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4029-gl-b1300.dts
target/linux/ipq40xx/files-4.14/arch/arm/boot/dts/qcom-ipq4029-mr33.dts
target/linux/ipq40xx/image/Makefile

index 3768cd87b9d83d52a7e3c2d2744309296f343ba2..6ebac16c94adeac45ebee6d0e351a76b59d787dc 100644 (file)
 
                wifi@a000000 {
                        status = "okay";
+                       qcom,ath10k-calibration-variant = "AVM-FRITZBox-4040";
                };
 
                wifi@a800000 {
                        status = "okay";
+                       qcom,ath10k-calibration-variant = "AVM-FRITZBox-4040";
                };
 
                watchdog@b017000 {
index e0bb968f5bb4603da7d9948d57a41630ed6b2136..d988275564380998e3d113353c87af47cac7a972 100644 (file)
 
                wifi@a000000 {
                        status = "okay";
-                       qcom,ath10k-calibration-variant = "ASUS-RT-AC58U";
+                       qcom,ath10k-calibration-variant = "RT-AC58U";
                };
 
                wifi@a800000 {
                        status = "okay";
-                       qcom,ath10k-calibration-variant = "ASUS-RT-AC58U";
+                       qcom,ath10k-calibration-variant = "RT-AC58U";
                };
 
                watchdog@b017000 {
index b55d9453bf82d53ab4439cadd2431c5d57477fa1..d7cc5580b82e710b0e380ac1a0bc838583b02896 100644 (file)
 
 &wifi0 {
        status = "okay";
+       qcom,ath10k-calibration-variant = "GL-B1300";
 };
 
 &wifi1 {
        status = "okay";
+       qcom,ath10k-calibration-variant = "GL-B1300";
 };
index 8bbfb0ba0bb1e1efed969d189cf7c129eeac0b1c..0be196065583107290c5a186725dd58219a54d79 100644 (file)
 
 &wifi0 {
        status = "okay";
-       /* qcom,ath10k-calibration-variant = "MERAKI-MR33"; */
+       qcom,ath10k-calibration-variant = "Meraki-MR33";
 };
 
 &wifi1 {
        status = "okay";
-       /* qcom,ath10k-calibration-variant = "MERAKI-MR33"; */
+       qcom,ath10k-calibration-variant = "Meraki-MR33";
 };
index b305ea096090c8689ebf8da00a42edbe5e6f697b..558f5529a7bdc43cd599756ab3cbee8f51eb674e 100644 (file)
@@ -51,7 +51,6 @@ define Device/8dev_jalapeno
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        DEVICE_TITLE := 8devices Jalapeno
-       DEVICE_PACKAGES := ipq-wifi-8dev_jalapeno
 endef
 TARGET_DEVICES += 8dev_jalapeno
 
@@ -71,7 +70,7 @@ define Device/asus_rt-ac58u
 #      string and call it a day.... Yeah, we do the latter!
        UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC58U')
        IMAGES := sysupgrade.bin
-       DEVICE_PACKAGES := ipq-wifi-asus_rt-ac58u kmod-usb-ledtrig-usbport
+       DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += asus_rt-ac58u
 
@@ -83,7 +82,7 @@ define Device/avm_fritzbox-4040
        IMAGE_SIZE := 29753344
        IMAGES = sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-avm_fritzbox-4040 fritz-tffs fritz-caldata u-boot-fritz4040
+       DEVICE_PACKAGES := fritz-tffs fritz-caldata u-boot-fritz4040
 endef
 TARGET_DEVICES += avm_fritzbox-4040
 
@@ -110,7 +109,6 @@ define Device/glinet_gl-b1300
        IMAGE_SIZE := 26624k
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel |append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-glinet_gl-b1300
 endef
 TARGET_DEVICES += glinet_gl-b1300
 
@@ -121,7 +119,7 @@ define Device/meraki_mr33
        PAGESIZE := 2048
        DEVICE_TITLE := Cisco Meraki MR33
        IMAGES = sysupgrade.bin
-       DEVICE_PACKAGES := -swconfig ipq-wifi-meraki_mr33 ath10k-firmware-qca9887
+       DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887
 endef
 TARGET_DEVICES += meraki_mr33
 
@@ -129,7 +127,6 @@ define Device/netgear_ex61x0v2
        $(call Device/DniImage)
        KERNEL_SIZE := 3080192
        DEVICE_DTS_CONFIG := config@4
-       DEVICE_PACKAGES := ipq-wifi-netgear_ex61x0v2
        NETGEAR_BOARD_ID := EX6150v2series
        NETGEAR_HW_ID := 29765285+16+0+128+2x2
 endef