kernel: update kernel 3.18 to 3.18.26
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 25 Jan 2016 21:43:26 +0000 (21:43 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 25 Jan 2016 21:43:26 +0000 (21:43 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 48496

include/kernel-version.mk
target/linux/generic/patches-3.18/010-KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch [deleted file]
target/linux/generic/patches-3.18/902-debloat_proc.patch
target/linux/ipq806x/patches-3.18/801-ARM-qcom-add-Netgear-Nighthawk-X4-D7800-device-tree.patch

index 93d89a0848d00544046c3565747cf2d70be891fa..572936b6e6e7b2012eed961f8f34cbe3c1c8837d 100644 (file)
@@ -2,12 +2,12 @@
 
 LINUX_RELEASE?=1
 
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .25
+LINUX_VERSION-3.18 = .26
 LINUX_VERSION-4.1 = .15
 LINUX_VERSION-4.3 = .3
 LINUX_VERSION-4.4 =
 
 LINUX_VERSION-4.1 = .15
 LINUX_VERSION-4.3 = .3
 LINUX_VERSION-4.4 =
 
-LINUX_KERNEL_MD5SUM-3.18.25 = 929e74f2e29e1b41d69e45c04d712c9e
+LINUX_KERNEL_MD5SUM-3.18.26 = fb3ef8da32a25607807887b9567a6927
 LINUX_KERNEL_MD5SUM-4.1.15 = b227333912b161c96ff3e30f5041e1c0
 LINUX_KERNEL_MD5SUM-4.3.3 = f3068333fa524ff98914cf751d0b5710
 LINUX_KERNEL_MD5SUM-4.4 = 9a78fa2eb6c68ca5a40ed5af08142599
 LINUX_KERNEL_MD5SUM-4.1.15 = b227333912b161c96ff3e30f5041e1c0
 LINUX_KERNEL_MD5SUM-4.3.3 = f3068333fa524ff98914cf751d0b5710
 LINUX_KERNEL_MD5SUM-4.4 = 9a78fa2eb6c68ca5a40ed5af08142599
diff --git a/target/linux/generic/patches-3.18/010-KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch b/target/linux/generic/patches-3.18/010-KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch
deleted file mode 100644 (file)
index 9c6a969..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-From 7ca88764d45c209791e8813131c1457c2e9e51e7 Mon Sep 17 00:00:00 2001
-From: Yevgeny Pats <yevgeny@perception-point.io>
-Date: Mon, 11 Jan 2016 12:05:28 +0000
-Subject: KEYS: Fix keyring ref leak in join_session_keyring()
-
-If a thread is asked to join as a session keyring the keyring that's already
-set as its session, we leak a keyring reference.
-
-This can be tested with the following program:
-
-       #include <stddef.h>
-       #include <stdio.h>
-       #include <sys/types.h>
-       #include <keyutils.h>
-
-       int main(int argc, const char *argv[])
-       {
-               int i = 0;
-               key_serial_t serial;
-
-               serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
-                               "leaked-keyring");
-               if (serial < 0) {
-                       perror("keyctl");
-                       return -1;
-               }
-
-               if (keyctl(KEYCTL_SETPERM, serial,
-                          KEY_POS_ALL | KEY_USR_ALL) < 0) {
-                       perror("keyctl");
-                       return -1;
-               }
-
-               for (i = 0; i < 100; i++) {
-                       serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
-                                       "leaked-keyring");
-                       if (serial < 0) {
-                               perror("keyctl");
-                               return -1;
-                       }
-               }
-
-               return 0;
-       }
-
-If, after the program has run, there something like the following line in
-/proc/keys:
-
-3f3d898f I--Q---   100 perm 3f3f0000     0     0 keyring   leaked-keyring: empty
-
-with a usage count of 100 * the number of times the program has been run,
-then the kernel is malfunctioning.  If leaked-keyring has zero usages or
-has been garbage collected, then the problem is fixed.
-
-Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
-Signed-off-by: David Howells <dhowells@redhat.com>
----
- security/keys/process_keys.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
-index a3f85d2..e6d50172 100644
---- a/security/keys/process_keys.c
-+++ b/security/keys/process_keys.c
-@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
-               ret = PTR_ERR(keyring);
-               goto error2;
-       } else if (keyring == new->session_keyring) {
-+              key_put(keyring);
-               ret = 0;
-               goto error2;
-       }
--- 
-2.7.0.rc3
-
index 5cecd1e6770573d76a334ee767654c7dfb140351..024efe080ba9fdf4868075f7db86fcbdb5f728cb 100644 (file)
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2934,6 +2934,8 @@ static __net_initdata struct pernet_oper
+@@ -2933,6 +2933,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
  
  static int __init proto_init(void)
  {
index ecc1cff9df343b325547d9f5f81ee3e022ea72a6..eaf037f57e787c60d874cf19ac7325aa617ab994 100644 (file)
@@ -1,6 +1,6 @@
---- a/arch/arm/boot/dts/Makefile       2015-09-22 18:30:09.033530282 +0530
-+++ b/arch/arm/boot/dts/Makefile       2015-09-23 17:06:44.892947581 +0530
-@@ -362,6 +362,7 @@
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -362,6 +362,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-ipq8064-ap148.dtb \
        qcom-ipq8064-db149.dtb \
        qcom-ipq8064-r7500.dtb \
        qcom-ipq8064-ap148.dtb \
        qcom-ipq8064-db149.dtb \
        qcom-ipq8064-r7500.dtb \
@@ -8,8 +8,8 @@
        qcom-msm8660-surf.dtb \
        qcom-msm8960-cdp.dtb \
        qcom-msm8974-sony-xperia-honami.dtb
        qcom-msm8660-surf.dtb \
        qcom-msm8960-cdp.dtb \
        qcom-msm8974-sony-xperia-honami.dtb
---- a/arch/arm/boot/dts/qcom-ipq8064-d7800.dts 1970-01-01 05:30:00.000000000 +0530
-+++ b/arch/arm/boot/dts/qcom-ipq8064-d7800.dts 2015-09-23 17:06:45.336947567 +0530
+--- /dev/null
++++ b/arch/arm/boot/dts/qcom-ipq8064-d7800.dts
 @@ -0,0 +1,368 @@
 +#include "qcom-ipq8064-v1.0.dtsi"
 +
 @@ -0,0 +1,368 @@
 +#include "qcom-ipq8064-v1.0.dtsi"
 +