kexec-tools: update to 2.0.21
authorRosen Penev <rosenp@gmail.com>
Wed, 30 Dec 2020 00:05:40 +0000 (16:05 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 19 Mar 2021 00:25:26 +0000 (01:25 +0100)
kdump was removed in 7acd257ae67b4ca94f8c23cb8bda0ee0709b9216

gdb can be used as an alternative.

Remove autoreconf. It's not needed as the configure files are already
generated.

Remove upstreamed patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/boot/kexec-tools/Makefile
package/boot/kexec-tools/patches/100-kexec-tools-fix-for-Unhandled-rela-relocation-R_X86_64_PLT32-error.patch [deleted file]

index 269345aa9db8f7d40b2df6ddb64858a26ea3dd1f..36fe53671ab9b307fc805ed981229df2f2da0731 100644 (file)
@@ -8,14 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kexec-tools
-PKG_VERSION:=2.0.16
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.21
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/kexec
-PKG_HASH:=5b103351ad752c9badd1d65b00eb6de4bce579f944f4df4e3ef3a755ba567010
-
-PKG_FIXUP:=autoreconf
+PKG_HASH:=e113142dee891638ad96e0f72cf9277b244477619470b30c41999d312e8e8702
 
 PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB CONFIG_KEXEC_LZMA
 
@@ -51,17 +49,6 @@ define Package/kexec/description
  The kexec utility allows to load and boot another kernel.
 endef
 
-define Package/kdump
-  $(call Package/kexec-tools/Default)
-  TITLE:=Kernel crash analysis
-  DEPENDS:=+kexec @(i386||x86_64||arm) @KERNEL_CRASH_DUMP
-endef
-
-define Package/kdump/description
- The kdump package allows to automatically boot into a
- special kernel for analyzing kernel crashes using kdump.
-endef
-
 define Package/kexec/config
        source "$(SOURCE)/Config.in"
 endef
@@ -108,28 +95,5 @@ define Package/kexec/install
        $(LN) ../usr/sbin/kexec $(1)/sbin/kexec
 endef
 
-define Package/kdump/install
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config $(1)/etc/uci-defaults
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kdump $(PKG_INSTALL_DIR)/usr/sbin/vmcore-dmesg $(1)/usr/sbin
-       $(INSTALL_BIN) ./files/kdump.init $(1)/etc/init.d/kdump
-       $(INSTALL_BIN) ./files/kdump.defaults $(1)/etc/uci-defaults/kdump
-       $(INSTALL_CONF) ./files/kdump.config $(1)/etc/config/kdump
-endef
-
-define Package/kdump/prerm
-#!/bin/sh
-
-case $$(uname -m) in
-       i?86|x86_64)
-               if grep -q " crashkernel=" /boot/grub/grub.cfg; then
-                       mount /boot -o remount,rw
-                       sed -i 's/ crashkernel=[^ ]*//' /boot/grub/grub.cfg
-                       mount /boot -o remount,ro
-               fi
-               ;;
-esac
-endef
-
 $(eval $(call BuildPackage,kexec-tools))
 $(eval $(call BuildPackage,kexec))
-$(eval $(call BuildPackage,kdump))
diff --git a/package/boot/kexec-tools/patches/100-kexec-tools-fix-for-Unhandled-rela-relocation-R_X86_64_PLT32-error.patch b/package/boot/kexec-tools/patches/100-kexec-tools-fix-for-Unhandled-rela-relocation-R_X86_64_PLT32-error.patch
deleted file mode 100644 (file)
index dfad219..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/kexec/arch/x86_64/kexec-elf-rel-x86_64.c b/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
-index 7fdde73..af33689 100644
---- a/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
-+++ b/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
-@@ -78,7 +78,8 @@ void machine_apply_elf_rel(struct mem_ehdr *UNUSED(ehdr),
-               if ((int64_t)value != *(int32_t *)location)
-                       goto overflow;
-               break;
--      case R_X86_64_PC32: 
-+      case R_X86_64_PC32:
-+      case R_X86_64_PLT32:
-               *(uint32_t *)location = value - address;
-               break;
-       default: