acx-mac80211: switch to AutoProbe
authorJonas Gorski <jonas.gorski@gmail.com>
Mon, 24 Jul 2017 11:12:28 +0000 (13:12 +0200)
committerJonas Gorski <jonas.gorski@gmail.com>
Fri, 27 Oct 2017 11:06:15 +0000 (13:06 +0200)
Now that we have working module dependency generation, we can switch to
AutoProbe and let modprobe handle loading required modules.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
package/kernel/acx-mac80211/Makefile

index 5629b050b5f1d685d806418988c81d1cf81a1b92..05b1304cd2259f17421555759deee2be308be352 100644 (file)
@@ -29,7 +29,7 @@ define KernelPackage/acx-mac80211
   TITLE:=ACX1xx mac80211 driver
   DEPENDS:=@(PCI_SUPPORT||TARGET_ar7) @mipsel @LINUX_3_18||LINUX_4_4 +kmod-mac80211
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.ko
   TITLE:=ACX1xx mac80211 driver
   DEPENDS:=@(PCI_SUPPORT||TARGET_ar7) @mipsel @LINUX_3_18||LINUX_4_4 +kmod-mac80211
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.ko
-  AUTOLOAD:=$(call AutoLoad,50,mac80211 acx-mac80211)
+  AUTOLOAD:=$(call AutoProbe,acx-mac80211)
   MAINTAINER:=Florian Fainelli <florian@openwrt.org>
   MENU:=1
 endef
   MAINTAINER:=Florian Fainelli <florian@openwrt.org>
   MENU:=1
 endef