kernel: bump 4.9 to 4.9.199
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 6 Nov 2019 16:15:39 +0000 (17:15 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 12 Nov 2019 09:33:42 +0000 (10:33 +0100)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.9/950-0031-Add-dwc_otg-driver.patch
target/linux/generic/hack-4.9/661-use_fq_codel_by_default.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 89e06f89cb4bc06b74888d5dfd7f8c5c9ee55213..f74a4015147235ca24ff1b0a850e2effff3a7155 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .198
+LINUX_VERSION-4.9 = .199
 LINUX_VERSION-4.14 = .151
 
-LINUX_KERNEL_HASH-4.9.198 = 9572ebfa6ba0efcf9f1ec7b62c7b89baa36a621ab9fd4c5ad025196c549605ac
+LINUX_KERNEL_HASH-4.9.199 = 0f2531f0908e320ee49954e8d84406db659073b202abc514bcc999ceaa3f7ed5
 LINUX_KERNEL_HASH-4.14.151 = ff519c428ee9bbb513a84db5ec32a7e3705cd8c23a57104b25b944cb79583fae
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 5903e5ad6d3d4c771fc8e5887ccf7dbb38a4a9da..b125e6a60eb8d27c29427abacb1910dd403a918a 100644 (file)
@@ -696,7 +696,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5088,7 +5088,7 @@ static void port_event(struct usb_hub *h
+@@ -5095,7 +5095,7 @@ static void port_event(struct usb_hub *h
        if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
                u16 status = 0, unused;
  
index 5461393daa78c74db9fec8b0d9f84e4d061922e9..22d5a3893a685bd836213953061b0da43a455352 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/net/sch_generic.h
 +++ b/include/net/sch_generic.h
-@@ -339,12 +339,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
+@@ -344,12 +344,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
  extern struct Qdisc_ops pfifo_fast_ops;
  extern struct Qdisc_ops mq_qdisc_ops;
  extern struct Qdisc_ops noqueue_qdisc_ops;
index c7ff28b8c0e37b8e20ca6e06838939061113df99..346305869538408e2fd2606985b3eefa64c11796 100644 (file)
@@ -156,7 +156,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        int ret;
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4447,6 +4447,14 @@ hub_port_init(struct usb_hub *hub, struc
+@@ -4454,6 +4454,14 @@ hub_port_init(struct usb_hub *hub, struc
        else
                speed = usb_speed_string(udev->speed);