bison: replace the yacc script with one that does not hardcode the path (fixes #20605)
authorFelix Fietkau <nbd@openwrt.org>
Sat, 26 Sep 2015 21:10:48 +0000 (21:10 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 26 Sep 2015 21:10:48 +0000 (21:10 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47050

tools/bison/Makefile
tools/bison/scripts/yacc [new file with mode: 0755]

index 10d872048415262f5df12361f843c3a75f9fccd4..256512116f9f7b8f90f2dcce24846286e5c50025 100644 (file)
@@ -23,4 +23,9 @@ define Host/Clean
        $(call Host/Clean/Default)
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
 $(eval $(call HostBuild))
diff --git a/tools/bison/scripts/yacc b/tools/bison/scripts/yacc
new file mode 100755 (executable)
index 0000000..8f73e26
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec bison -y "$@"