tools: remove xxd package
authorPetr Štetiar <ynezz@true.cz>
Tue, 30 Aug 2022 06:41:07 +0000 (08:41 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 6 Sep 2022 06:04:53 +0000 (08:04 +0200)
It shouldn't be needed anymore as we've now `scripts/xxdi.pl`, which
should be self contained and fully compatible `xxd -i` replacement.

Fixes: #10555
Signed-off-by: Petr Štetiar <ynezz@true.cz>
tools/Makefile
tools/xxd/Makefile [deleted file]

index 0d6e675d4ceb16a1a8f63b9e9ce6e7a5a1fb62ed..3f505459e9731d3e7250613d0d185a7b10d34a1f 100644 (file)
@@ -25,7 +25,7 @@ tools-y += autoconf autoconf-archive automake bc bison cmake cpio dosfstools
 tools-y += e2fsprogs fakeroot findutils firmware-utils flex gengetopt
 tools-y += libressl libtool lzma m4 make-ext4fs meson missing-macros mkimage
 tools-y += mklibs mtd-utils mtools ninja padjffs2 patch-image
-tools-y += patchelf pkgconf quilt squashfskit4 sstrip xxd zip zlib zstd
+tools-y += patchelf pkgconf quilt squashfskit4 sstrip zip zlib zstd
 tools-$(BUILD_B43_TOOLS) += b43-tools
 tools-$(BUILD_ISL) += isl
 tools-$(BUILD_TOOLCHAIN) += expat gmp mpc mpfr
diff --git a/tools/xxd/Makefile b/tools/xxd/Makefile
deleted file mode 100644 (file)
index c3cc686..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-# SPDX-License-Identifier: GPL-2.0-or-later
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=xxd
-PKG_VERSION:=1.10
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://grail.cba.csuohio.edu/~somos/
-PKG_HASH:=9bf05c19b9084973e3cc877696a7f9881a5c87fa5a9fa438d9962519726559f9
-PKG_CPE_ID:=cpe:/a:vim:vim
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/xxd $(STAGING_DIR_HOST)/bin/
-endef
-
-$(eval $(call HostBuild))