ipq806x: build images and add sysupgrade support for AP148
authorJonas Gorski <jogo@openwrt.org>
Fri, 4 Sep 2015 14:45:00 +0000 (14:45 +0000)
committerJonas Gorski <jogo@openwrt.org>
Fri, 4 Sep 2015 14:45:00 +0000 (14:45 +0000)
Add full ubi and sysupgrade images for AP148 and add sysupgrade support
for ipq806x to allow updating the current installation.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46789

target/linux/ipq806x/base-files/lib/upgrade/platform.sh [new file with mode: 0644]
target/linux/ipq806x/image/Makefile

diff --git a/target/linux/ipq806x/base-files/lib/upgrade/platform.sh b/target/linux/ipq806x/base-files/lib/upgrade/platform.sh
new file mode 100644 (file)
index 0000000..e834ead
--- /dev/null
@@ -0,0 +1,18 @@
+. /lib/ipq806x.sh
+
+PART_NAME=firmware
+
+platform_check_image() {
+       local board=$(ipq806x_board_name)
+
+       case "$board" in
+       AP148)
+               nand_do_platform_check $board $1
+               return $?;
+               ;;
+       *)
+               return 1;
+       esac
+}
+
+# use default for platform_do_upgrade()
index dad6ee365ed2514ea51f101d98d9d162514c0062..ac0fc8450a3162c95bbb874405f1bc6efeaf6d74 100644 (file)
@@ -35,36 +35,50 @@ define Device/Default
        DEVICE_DTS :=
        KERNEL_PREFIX := $$(IMAGE_PREFIX)
        IMAGES :=
+       KERNEL_IN_UBI :=
 endef
-DEVICE_VARS += DEVICE_DTS
+DEVICE_VARS += DEVICE_DTS KERNEL_IN_UBI
 
 define Device/LegacyImage
        KERNEL_SUFFIX := -uImage
        KERNEL = kernel-bin | append-dtb | uImage none
        KERNEL_NAME := zImage
-       KERNEL_INSTALL := 1
 endef
 
 define Device/FitImage
        KERNEL_SUFFIX := -fit-uImage.itb
        KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
        KERNEL_NAME := Image
-       KERNEL_INSTALL := 1
+endef
+
+define Device/UbiFit
+       KERNEL_IN_UBI := 1
+       IMAGES := nand-factory.ubi nand-sysupgrade.tar
+       IMAGE/nand-factory.ubi := append-ubi
+       IMAGE/nand-sysupgrade.tar := sysupgrade-nand
 endef
 
 define Device/AP148
        $(call Device/FitImage)
+       $(call Device/UbiFit)
        DEVICE_DTS := qcom-ipq8064-ap148
+       BLOCKSIZE := 128KiB
+       PAGESIZE := 2048
 endef
 
 define Device/AP148-legacy
        $(call Device/LegacyImage)
+       $(call Device/UbiFit)
        DEVICE_DTS := qcom-ipq8064-ap148
+       BLOCKSIZE := 128KiB
+       PAGESIZE := 2048
+       BOARD_NAME := AP148
 endef
 
 define Device/DB149
        $(call Device/FitImage)
        DEVICE_DTS := qcom-ipq8064-db149
+       KERNEL_INSTALL := 1
 endef
 
 TARGET_DEVICES += AP148 AP148-legacy DB149