ath10k-ct: update to latest version
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Mon, 23 Nov 2020 14:09:45 +0000 (15:09 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 24 Nov 2020 16:43:15 +0000 (17:43 +0100)
1d28d17 ath10k-ct: Fix RSSI reporting for wave-1 firmware.
0c2949e ath10k-ct: fwcfg allows configuring dma-burst setting.
13319ff ath10k-ct: stable patches, debugfs crashdump, 5.8 driver

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch
package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
package/kernel/ath10k-ct/patches/205-ath10k-Add-NL80211_EXT_FEATURE_AQL-flag.patch

index 76077ec156c2cb961fd90636de2b0fca8d8a73cd..03a605dac590fdc504e0d0c56667422cac42476b 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2020-06-30
-PKG_SOURCE_VERSION:=edfbf9161ab75e4831981284ab2d5b1b9fb6ef72
-PKG_MIRROR_HASH:=98b7f88baea7314144fa8f8d141ad0dbbf2816f9606b0a89afb396761b558d14
+PKG_SOURCE_DATE:=2020-10-08
+PKG_SOURCE_VERSION:=1d28d176e5b6e63a6583f497adf68e1d9c1dc962
+PKG_MIRROR_HASH:=f611762647822742f7c8f9da242e33d9bf6da0a14976b87408af28f280802ae0
 
 # Build the 5.4 ath10k-ct driver version.  Other option is "-4.19".
 # Probably this should match as closely as
index 4e88c8a19fa614b44d282bf30f0c848758e422f4..c13036984bdfb3fc6d5f8ee9cd4e8b927eec859b 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
 
 --- a/ath10k-5.4/mac.c
 +++ b/ath10k-5.4/mac.c
-@@ -6793,6 +6793,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6797,6 +6797,7 @@ static void ath10k_bss_info_changed(stru
                           "mac vdev %d mcast_rate %x\n",
                           arvif->vdev_id, rate);
  
@@ -19,7 +19,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
                vdev_param = ar->wmi.vdev_param->mcast_data_rate;
                ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
                                                vdev_param, rate);
-@@ -6801,6 +6802,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6805,6 +6806,7 @@ static void ath10k_bss_info_changed(stru
                                    "failed to set mcast rate on vdev %i: %d\n",
                                    arvif->vdev_id,  ret);
  
@@ -27,7 +27,7 @@ Signed-off-by: Sven Eckelmann <sven@narfation.org>
                vdev_param = ar->wmi.vdev_param->bcast_data_rate;
                ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
                                                vdev_param, rate);
-@@ -6827,6 +6829,7 @@ static void ath10k_bss_info_changed(stru
+@@ -6831,6 +6833,7 @@ static void ath10k_bss_info_changed(stru
                        return;
                }
  
index 15343abd5f8760443f96a4555642851a3ff3ee4e..c6d42679dd90f6197927aa682c9cf71452ab8e05 100644 (file)
@@ -161,7 +161,7 @@ v13:
                .patch_load_addr = QCA9888_HW_2_0_PATCH_LOAD_ADDR,
                .uart_pin = 7,
                .cc_wraparound_type = ATH10K_HW_CC_WRAP_SHIFTED_EACH,
-@@ -3573,6 +3579,10 @@ int ath10k_core_start(struct ath10k *ar,
+@@ -3579,6 +3585,10 @@ int ath10k_core_start(struct ath10k *ar,
                        ath10k_wmi_check_apply_board_power_ctl_table(ar);
        }
  
@@ -172,7 +172,7 @@ v13:
        return 0;
  
  err_hif_stop:
-@@ -3829,9 +3839,18 @@ static void ath10k_core_register_work(st
+@@ -3835,9 +3845,18 @@ static void ath10k_core_register_work(st
                goto err_spectral_destroy;
        }
  
@@ -191,7 +191,7 @@ v13:
  err_spectral_destroy:
        ath10k_spectral_destroy(ar);
  err_debug_destroy:
-@@ -3891,6 +3910,8 @@ void ath10k_core_unregister(struct ath10
+@@ -3897,6 +3916,8 @@ void ath10k_core_unregister(struct ath10
        if (!test_bit(ATH10K_FLAG_CORE_REGISTERED, &ar->dev_flags))
                return;
  
@@ -210,7 +210,7 @@ v13:
  
  #include "htt.h"
  #include "htc.h"
-@@ -1470,6 +1471,13 @@ struct ath10k {
+@@ -1476,6 +1477,13 @@ struct ath10k {
        } testmode;
  
        struct {
@@ -396,7 +396,7 @@ v13:
  /* Rates */
 --- a/ath10k-5.4/wmi-ops.h
 +++ b/ath10k-5.4/wmi-ops.h
-@@ -218,7 +218,10 @@ struct wmi_ops {
+@@ -219,7 +219,10 @@ struct wmi_ops {
        struct sk_buff *(*gen_bb_timing)
                        (struct ath10k *ar,
                         const struct wmi_bb_timing_cfg_arg *arg);
@@ -407,7 +407,7 @@ v13:
  };
  
  int ath10k_wmi_cmd_send(struct ath10k *ar, struct sk_buff *skb, u32 cmd_id);
-@@ -1105,6 +1108,35 @@ ath10k_wmi_force_fw_hang(struct ath10k *
+@@ -1115,6 +1118,35 @@ ath10k_wmi_force_fw_hang(struct ath10k *
        return ath10k_wmi_cmd_send(ar, skb, ar->wmi.cmd->force_fw_hang_cmdid);
  }
  
@@ -445,7 +445,7 @@ v13:
  {
 --- a/ath10k-5.4/wmi-tlv.c
 +++ b/ath10k-5.4/wmi-tlv.c
-@@ -4367,6 +4367,8 @@ static const struct wmi_ops wmi_tlv_ops
+@@ -4382,6 +4382,8 @@ static const struct wmi_ops wmi_tlv_ops
        .gen_echo = ath10k_wmi_tlv_op_gen_echo,
        .gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
        .gen_vdev_spectral_enable = ath10k_wmi_tlv_op_gen_vdev_spectral_enable,
@@ -456,7 +456,7 @@ v13:
  static const struct wmi_peer_flags_map wmi_tlv_peer_flags_map = {
 --- a/ath10k-5.4/wmi.c
 +++ b/ath10k-5.4/wmi.c
-@@ -8305,6 +8305,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
+@@ -8313,6 +8313,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
        return skb;
  }
  
@@ -506,7 +506,7 @@ v13:
  static struct sk_buff *
  ath10k_wmi_op_gen_set_psmode(struct ath10k *ar, u32 vdev_id,
                             enum wmi_sta_ps_mode psmode)
-@@ -10104,6 +10147,9 @@ static const struct wmi_ops wmi_ops = {
+@@ -10112,6 +10155,9 @@ static const struct wmi_ops wmi_ops = {
        .fw_stats_fill = ath10k_wmi_main_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -516,7 +516,7 @@ v13:
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10174,6 +10220,8 @@ static const struct wmi_ops wmi_10_1_ops
+@@ -10182,6 +10228,8 @@ static const struct wmi_ops wmi_10_1_ops
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -525,7 +525,7 @@ v13:
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10253,6 +10301,8 @@ static const struct wmi_ops wmi_10_2_ops
+@@ -10261,6 +10309,8 @@ static const struct wmi_ops wmi_10_2_ops
        .gen_delba_send = ath10k_wmi_op_gen_delba_send,
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
@@ -534,7 +534,7 @@ v13:
        /* .gen_pdev_enable_adaptive_cca not implemented */
  };
  
-@@ -10324,6 +10374,8 @@ static const struct wmi_ops wmi_10_2_4_o
+@@ -10332,6 +10382,8 @@ static const struct wmi_ops wmi_10_2_4_o
                ath10k_wmi_op_gen_pdev_enable_adaptive_cca,
        .get_vdev_subtype = ath10k_wmi_10_2_4_op_get_vdev_subtype,
        .gen_bb_timing = ath10k_wmi_10_2_4_op_gen_bb_timing,
@@ -543,7 +543,7 @@ v13:
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10405,6 +10457,8 @@ static const struct wmi_ops wmi_10_4_ops
+@@ -10413,6 +10465,8 @@ static const struct wmi_ops wmi_10_4_ops
        .gen_pdev_bss_chan_info_req = ath10k_wmi_10_2_op_gen_pdev_bss_chan_info,
        .gen_echo = ath10k_wmi_op_gen_echo,
        .gen_pdev_get_tpc_config = ath10k_wmi_10_2_4_op_gen_pdev_get_tpc_config,
index dd35e2937cc9951d4ce6b3615f1bd71070e427cb..25a6c12d5191526433aed21903534a2d3d65d9b6 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
 
 --- a/ath10k-5.4/core.h
 +++ b/ath10k-5.4/core.h
-@@ -1574,6 +1574,10 @@ struct ath10k {
+@@ -1580,6 +1580,10 @@ struct ath10k {
        u8 csi_data[4096];
        u16 csi_data_len;
  
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-5.4/mac.c
 +++ b/ath10k-5.4/mac.c
-@@ -10383,7 +10383,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -10387,7 +10387,7 @@ int ath10k_mac_register(struct ath10k *a
        ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
  #ifdef CPTCFG_MAC80211_LEDS
index 33d69e7975b138a492211135b259d2171896c99b..4a49909133f1f49b092cba41f4f8a28d9e5934ff 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ath10k-5.4/mac.c
 +++ b/ath10k-5.4/mac.c
-@@ -10182,6 +10182,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -10186,6 +10186,7 @@ int ath10k_mac_register(struct ath10k *a
        wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_VHT_IBSS);
        wiphy_ext_feature_set(ar->hw->wiphy,
                              NL80211_EXT_FEATURE_SET_SCAN_DWELL);