sunxi: make sdcard image with squashfs as rootfs
authorYousong Zhou <yszhou4tech@gmail.com>
Wed, 4 Jan 2017 14:19:28 +0000 (22:19 +0800)
committerFelix Fietkau <nbd@nbd.name>
Thu, 5 Jan 2017 10:09:14 +0000 (11:09 +0100)
Two things that need to be noted

 - There is no partition type id allocated for squashfs yet.  In the
   case of sunxi, any non-zero value should work and we keep it 83 (the
   value for ext4)
 - Remaining spare space within the rootfs partition, not the entire
   sdcard space will be formated as either f2fs or ext4 and mounted as
   overlay to serve the role of rootfs_data.

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
target/linux/sunxi/Makefile

index cca3a14896f051ec836b6c8dcb3149cb5646a8e2..b0bc1bab398af55b77909deccd8f059e17d96e67 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=sunxi
 BOARDNAME:=Allwinner A1x/A20/A3x
-FEATURES:=fpu usb ext4 display rtc
+FEATURES:=fpu usb ext4 display rtc squashfs
 CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
@@ -28,5 +28,6 @@ KERNELNAME:=zImage dtbs
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += uboot-envtools kmod-eeprom-sunxi kmod-wdt-sunxi
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))