elfutils: fix host compilation with Alpine Linux
authorRosen Penev <rosenp@gmail.com>
Sat, 19 Mar 2022 23:51:43 +0000 (16:51 -0700)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 27 Mar 2022 12:38:13 +0000 (14:38 +0200)
intl is not included in libc, disable it as is done with the target
package.

argp is also not included. Add build depends for argp-standalone.

fts is also not included. Add build depends for musl-fts.

Disable shared libraries to avoid having to manually add rpath.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/elfutils/Makefile

index 9aa78d8352b9979df9acae98fe01c920fad03dd2..07b3ea66c66a1d247ed81f3c6f731c6bbfac3b17 100644 (file)
@@ -24,6 +24,8 @@ PKG_INSTALL:=1
 PKG_USE_MIPS16:=1
 PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
 
+HOST_BUILD_DEPENDS:=argp-standalone/host musl-fts/host
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 include $(INCLUDE_DIR)/host-build.mk
@@ -62,6 +64,8 @@ CONFIGURE_ARGS += --disable-nls
 endif
 
 HOST_CONFIGURE_ARGS += \
+       --disable-shared \
+       --disable-nls \
        --disable-debuginfod \
        --disable-libdebuginfod \
        --without-lzma \