busybox: fix compilation with GCC 10
authorStijn Tintel <stijn@linux-ipv6.be>
Thu, 13 May 2021 13:23:26 +0000 (16:23 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Wed, 18 Aug 2021 17:48:38 +0000 (20:48 +0300)
When compiling busybox with GCC 10 and CONFIG_PKG_ASLR_PIE_ALL=y, there
are hundreds of errors like:

relocation R_MIPS16_26 against `xzalloc' cannot be used when making a
shared object; recompile with -fPIC

Simply solve this by no longer disabling PKG_ASLR_PIE, so that $(FPIC)
is properly added to the CFLAGS and LDFLAGS.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
package/utils/busybox/Makefile

index 32f0d2c75598147bc4d0f1512ab3166dfa8b4569..76a1de33b7272dffb82915020ecc05afe466350b 100644 (file)
@@ -18,9 +18,6 @@ PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_PAM:libpam
 PKG_BUILD_PARALLEL:=1
 PKG_CHECK_FORMAT_SECURITY:=0
 
-#Busybox use it's own PIE config flag and LDFLAGS are used with ld, not gcc.
-PKG_ASLR_PIE:=0
-
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=LICENSE archival/libarchive/bz/LICENSE
 PKG_CPE_ID:=cpe:/a:busybox:busybox