ipq806x: add support for Netgear Nighthawk X4 R7500
authorJonas Gorski <jogo@openwrt.org>
Fri, 4 Sep 2015 14:46:06 +0000 (14:46 +0000)
committerJonas Gorski <jogo@openwrt.org>
Fri, 4 Sep 2015 14:46:06 +0000 (14:46 +0000)
Add support for the Netgear Nighthawk X4 R7500 and build
appropariate sysupgrade and factory images.

Known issues:
 * 5 GHz wifi not working - there is no quantenna driver
 * One of the USB ports is not working

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46796

target/linux/ipq806x/base-files/etc/uci-defaults/leds [new file with mode: 0644]
target/linux/ipq806x/base-files/etc/uci-defaults/network
target/linux/ipq806x/base-files/lib/ipq806x.sh
target/linux/ipq806x/base-files/lib/upgrade/platform.sh
target/linux/ipq806x/image/Makefile
target/linux/ipq806x/patches-3.18/301-ARM-qcom-add-Netgear-Nighthawk-X4-R7500-device-tree.patch [new file with mode: 0644]
target/linux/ipq806x/patches-4.1/301-ARM-qcom-add-Netgear-Nighthawk-X4-R7500-device-tree.patch [new file with mode: 0644]
target/linux/ipq806x/profiles/netgear.mk [new file with mode: 0644]

diff --git a/target/linux/ipq806x/base-files/etc/uci-defaults/leds b/target/linux/ipq806x/base-files/etc/uci-defaults/leds
new file mode 100644 (file)
index 0000000..362c5b6
--- /dev/null
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+
+. /lib/functions/uci-defaults.sh
+. /lib/ipq806x.sh
+
+board=$(ipq806x_board_name)
+
+case "$board" in
+r7500)
+       ucidef_set_led_usbdev "usb1" "USB 1" "r7500:white:usb1" "1-1"
+       ucidef_set_led_usbdev "usb2" "USB 2" "r7500:white:usb3" "3-1"
+       ucidef_set_led_netdev "wan" "WAN" "r7500:white:wan" "eth0"
+       ucidef_set_led_ide_disk "esata" "eSATA" "r7500:amber:esata"
+       ucidef_set_led_default "wps" "WPS" "r7500:white:wps" "0"
+       ucidef_set_led_default "rfkill" "rfkill" "r7500:white:rfkill" "0"
+       ;;
+*)
+       ;;
+esac
+
+ucidef_commit_leds
+
+exit 0
index 354cea9e3d9a1deabc1cac627a093c606d642aba..7742b7301da2d7ddb13f36f3e0a333e702ab34cb 100755 (executable)
@@ -16,7 +16,8 @@ ucidef_set_interface_loopback
 board=$(ipq806x_board_name)
 
 case "$board" in
-ap148)
+ap148 |\
+r7500)
        ucidef_set_interfaces_lan_wan "eth1" "eth0"
        ucidef_add_switch "switch0" "1" "1"
        ucidef_add_switch_vlan "switch0" "1" "6 1 2 3 4"
index 2790f3f38651d1783f37bd51bfbf304189fe40a1..5b27bde75899ad6a2198998cb79607fb3aa32552 100644 (file)
@@ -20,6 +20,9 @@ ipq806x_board_detect() {
        *"DB149")
                name="db149"
                ;;
+       *"R7500")
+               name="r7500"
+               ;;
        esac
 
        [ -z "$name" ] && name="unknown"
index e834ead0fd8caccd3fe5d4721f08471059115146..75a01b7d776188db6c0a34eb6108772fb2b1e710 100644 (file)
@@ -6,7 +6,8 @@ platform_check_image() {
        local board=$(ipq806x_board_name)
 
        case "$board" in
-       AP148)
+       AP148 |\
+       r7500)
                nand_do_platform_check $board $1
                return $?;
                ;;
index ac0fc8450a3162c95bbb874405f1bc6efeaf6d74..316e0d3cebabb2e29ddaac16b6867412c7787443 100644 (file)
@@ -10,6 +10,12 @@ KERNEL_LOADADDR := 0x42208000
 
 define Image/Prepare
        $(CP) $(LINUX_DIR)/vmlinux $(KDIR)/$(IMG_PREFIX)-vmlinux.elf
+       mkimage -A arm -O linux -T filesystem -C none \
+               -a $(KERNEL_LOADADDR) -e $(KERNEL_LOADADDR) \
+               -n 'ARM OpenWrt fakeroot' \
+               -s $(KDIR_TMP)/root.dummy-uImage.tmp
+       echo -ne '\xff' > $(KDIR_TMP)/root.dummy
+       cat $(KDIR_TMP)/root.dummy $(KDIR_TMP)/root.dummy-uImage.tmp > $(KDIR)/root.dummy
 endef
 
 define Image/BuildKernel
@@ -17,6 +23,7 @@ define Image/BuildKernel
 endef
 
 define Image/Build/squashfs
+       cp $(KDIR)/root.squashfs $(KDIR)/root.squashfs-raw
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef
 
@@ -29,6 +36,10 @@ define Build/append-dtb
        cat $(DTS_DIR)/$(DEVICE_DTS).dtb >> $@
 endef
 
+define Build/append-file
+       cat $(1) >> $@
+endef
+
 define Device/Default
        PROFILES := Default
        KERNEL_INITRAMFS_PREFIX := $$(IMG_PREFIX)-$(1)-initramfs
@@ -58,6 +69,22 @@ define Device/UbiFit
        IMAGE/nand-sysupgrade.tar := sysupgrade-nand
 endef
 
+define Device/DniImage
+       PROFILES += $$(DEVICE_NAME)
+       FILESYSTEMS := squashfs
+       KERNEL_SUFFIX := -uImage
+       KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
+       KERNEL = kernel-bin | append-dtb | pad-to $$$$(($$(KERNEL_SIZE)-2*64-1)) | append-file $(KDIR)/root.dummy | uImage none
+       KERNEL_NAME := zImage
+       NETGEAR_BOARD_ID :=
+       NETGEAR_HW_ID :=
+       BOARD_NAME :=
+       IMAGES := factory.img sysupgrade.tar
+       IMAGE/factory.img := append-kernel | append-ubi | netgear-dni
+       IMAGE/sysupgrade.tar = sysupgrade-nand
+endef
+DEVICE_VARS += KERNEL_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID DEVICE_BLOCK_SIZE DEVICE_PAGE_SIZE BOARD_NAME
+
 define Device/AP148
        $(call Device/FitImage)
        $(call Device/UbiFit)
@@ -81,6 +108,17 @@ define Device/DB149
        KERNEL_INSTALL := 1
 endef
 
-TARGET_DEVICES += AP148 AP148-legacy DB149
+define Device/R7500
+       $(call Device/DniImage)
+       DEVICE_DTS := qcom-ipq8064-r7500
+       KERNEL_SIZE := 2097152
+       NETGEAR_BOARD_ID := R7500
+       NETGEAR_HW_ID := 29764841+0+128+256+3x3+4x4
+       BLOCKSIZE := 128KiB
+       PAGESIZE := 2048
+       BOARD_NAME := r7500
+endef
+
+TARGET_DEVICES += AP148 AP148-legacy DB149 R7500
 
 $(eval $(call BuildImage))
diff --git a/target/linux/ipq806x/patches-3.18/301-ARM-qcom-add-Netgear-Nighthawk-X4-R7500-device-tree.patch b/target/linux/ipq806x/patches-3.18/301-ARM-qcom-add-Netgear-Nighthawk-X4-R7500-device-tree.patch
new file mode 100644 (file)
index 0000000..a9b83a1
--- /dev/null
@@ -0,0 +1,387 @@
+From 7e77aa188a7a7c4391856a9e5ef5ef58f769e679 Mon Sep 17 00:00:00 2001
+From: Jonas Gorski <jogo@openwrt.org>
+Date: Sun, 9 Aug 2015 13:02:38 +0200
+Subject: [PATCH] ARM: qcom: add Netgear Nighthawk X4 R7500 device tree
+
+Signed-off-by: Jonas Gorski <jogo@openwrt.org>
+---
+ arch/arm/boot/dts/Makefile               |   1 +
+ arch/arm/boot/dts/qcom-ipq8064-r7500.dts | 370 +++++++++++++++++++++++++++++++
+ 2 files changed, 371 insertions(+)
+ create mode 100644 arch/arm/boot/dts/qcom-ipq8064-r7500.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -361,6 +361,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+       qcom-apq8084-mtp.dtb \
+       qcom-ipq8064-ap148.dtb \
+       qcom-ipq8064-db149.dtb \
++      qcom-ipq8064-r7500.dtb \
+       qcom-msm8660-surf.dtb \
+       qcom-msm8960-cdp.dtb \
+       qcom-msm8974-sony-xperia-honami.dtb
+--- /dev/null
++++ b/arch/arm/boot/dts/qcom-ipq8064-r7500.dts
+@@ -0,0 +1,362 @@
++#include "qcom-ipq8064-v1.0.dtsi"
++
++#include <dt-bindings/input/input.h>
++
++/ {
++      model = "Netgear Nighthawk X4 R7500";
++      compatible = "netgear,r7500", "qcom,ipq8064";
++
++      memory@0 {
++              reg = <0x42000000 0xe000000>;
++              device_type = "memory";
++      };
++
++      reserved-memory {
++              #address-cells = <1>;
++              #size-cells = <1>;
++              ranges;
++              rsvd@41200000 {
++                      reg = <0x41200000 0x300000>;
++                      no-map;
++              };
++      };
++
++      aliases {
++              serial0 = &uart4;
++              mdio-gpio0 = &mdio0;
++      };
++
++      chosen {
++              bootargs = "rootfstype=squashfs noinitrd";
++              linux,stdout-path = "serial0:115200n8";
++      };
++
++      soc {
++              pinmux@800000 {
++                      i2c4_pins: i2c4_pinmux {
++                              pins = "gpio12", "gpio13";
++                              function = "gsbi4";
++                              bias-disable;
++                      };
++
++                      pcie0_pins: pcie0_pinmux {
++                              mux {
++                                      pins = "gpio3";
++                                      function = "pcie1_rst";
++                                      drive-strength = <12>;
++                                      bias-disable;
++                              };
++                      };
++
++                      pcie1_pins: pcie1_pinmux {
++                              mux {
++                                      pins = "gpio48";
++                                      function = "pcie2_rst";
++                                      drive-strength = <12>;
++                                      bias-disable;
++                              };
++                      };
++
++                      nand_pins: nand_pins {
++                              mux {
++                                      pins = "gpio34", "gpio35", "gpio36",
++                                             "gpio37", "gpio38", "gpio39",
++                                             "gpio40", "gpio41", "gpio42",
++                                             "gpio43", "gpio44", "gpio45",
++                                             "gpio46", "gpio47";
++                                      function = "nand";
++                                      drive-strength = <10>;
++                                      bias-disable;
++                              };
++                              pullups {
++                                      pins = "gpio39";
++                                      bias-pull-up;
++                              };
++                              hold {
++                                      pins = "gpio40", "gpio41", "gpio42",
++                                             "gpio43", "gpio44", "gpio45",
++                                             "gpio46", "gpio47";
++                                      bias-bus-hold;
++                              };
++                      };
++
++                      mdio0_pins: mdio0_pins {
++                              mux {
++                                      pins = "gpio0", "gpio1";
++                                      function = "gpio";
++                                      drive-strength = <8>;
++                                      bias-disable;
++                              };
++                      };
++
++                      rgmii2_pins: rgmii2_pins {
++                              mux {
++                                      pins = "gpio27", "gpio28", "gpio29", "gpio30", "gpio31", "gpio32",
++                                             "gpio51", "gpio52", "gpio59", "gpio60", "gpio61", "gpio62" ;
++                                      function = "rgmii2";
++                                      drive-strength = <8>;
++                                      bias-disable;
++                              };
++                      };
++              };
++
++              gsbi@16300000 {
++                      qcom,mode = <GSBI_PROT_I2C_UART>;
++                      status = "ok";
++                      serial@16340000 {
++                              status = "ok";
++                      };
++                      /*
++                       * The i2c device on gsbi4 should not be enabled.
++                       * On ipq806x designs gsbi4 i2c is meant for exclusive
++                       * RPM usage. Turning this on in kernel manifests as
++                       * i2c failure for the RPM.
++                       */
++              };
++
++              sata-phy@1b400000 {
++                      status = "ok";
++              };
++
++              sata@29000000 {
++                      status = "ok";
++              };
++
++              phy@100f8800 {          /* USB3 port 1 HS phy */
++                      status = "ok";
++              };
++
++              phy@100f8830 {          /* USB3 port 1 SS phy */
++                      status = "ok";
++              };
++
++              phy@110f8800 {          /* USB3 port 0 HS phy */
++                      status = "ok";
++              };
++
++              phy@110f8830 {          /* USB3 port 0 SS phy */
++                      status = "ok";
++              };
++
++              usb30@0 {
++                      status = "ok";
++              };
++
++              usb30@1 {
++                      status = "ok";
++              };
++
++              pcie0: pci@1b500000 {
++                      status = "ok";
++                      reset-gpio = <&qcom_pinmux 3 0>;
++                      pinctrl-0 = <&pcie0_pins>;
++                      pinctrl-names = "default";
++              };
++
++              pcie1: pci@1b700000 {
++                      status = "ok";
++                      reset-gpio = <&qcom_pinmux 48 0>;
++                      pinctrl-0 = <&pcie1_pins>;
++                      pinctrl-names = "default";
++              };
++
++              nand@1ac00000 {
++                      status = "ok";
++
++                      pinctrl-0 = <&nand_pins>;
++                      pinctrl-names = "default";
++
++                      nand-ecc-strength = <4>;
++                      nand-bus-width = <8>;
++
++                      #address-cells = <1>;
++                      #size-cells = <1>;
++
++                      qcadata@0 {
++                              label = "qcadata";
++                              reg = <0x0000000 0x0c80000>;
++                              read-only;
++                      };
++
++                      APPSBL@c80000 {
++                              label = "APPSBL";
++                              reg = <0x0c80000 0x0500000>;
++                              read-only;
++                      };
++
++                      APPSBLENV@1180000 {
++                              label = "APPSBLENV";
++                              reg = <0x1180000 0x0080000>;
++                              read-only;
++                      };
++
++                      art: art@1200000 {
++                              label = "art";
++                              reg = <0x1200000 0x0140000>;
++                              read-only;
++                      };
++
++                      kernel@1340000 {
++                              label = "kernel";
++                              reg = <0x1340000 0x0200000>;
++                      };
++
++                      ubi@1540000 {
++                              label = "ubi";
++                              reg = <0x1540000 0x1800000>;
++                      };
++
++                      netgear@2d40000 {
++                              label = "netgear";
++                              reg = <0x2d40000 0x0c00000>;
++                              read-only;
++                      };
++
++                      reserve@3940000 {
++                              label = "reserve";
++                              reg = <0x3940000 0x46c0000>;
++                              read-only;
++                      };
++
++                      firmware@1340000 {
++                              label = "firmware";
++                              reg = <0x1340000 0x1a00000>;
++                      };
++
++              };
++
++              mdio0: mdio {
++                      compatible = "virtual,mdio-gpio";
++                      #address-cells = <1>;
++                      #size-cells = <0>;
++                      gpios = <&qcom_pinmux 1 0 &qcom_pinmux 0 0>;
++                      pinctrl-0 = <&mdio0_pins>;
++                      pinctrl-names = "default";
++
++                      phy0: ethernet-phy@0 {
++                              device_type = "ethernet-phy";
++                              reg = <0>;
++                              qca,ar8327-initvals = <
++                                      0x00004 0x7600000   /* PAD0_MODE */
++                                      0x00008 0x1000000   /* PAD5_MODE */
++                                      0x0000c 0x80        /* PAD6_MODE */
++                                      0x000e4 0xaa545     /* MAC_POWER_SEL */
++                                      0x000e0 0xc74164de  /* SGMII_CTRL */
++                                      0x0007c 0x4e        /* PORT0_STATUS */
++                                      0x00094 0x4e        /* PORT6_STATUS */
++                                      >;
++                      };
++
++                      phy4: ethernet-phy@4 {
++                              device_type = "ethernet-phy";
++                              reg = <4>;
++                      };
++              };
++
++              gmac1: ethernet@37200000 {
++                      status = "ok";
++                      phy-mode = "rgmii";
++                      phy-handle = <&phy4>;
++                      qcom,id = <1>;
++
++                      pinctrl-0 = <&rgmii2_pins>;
++                      pinctrl-names = "default";
++
++                      mtd-mac-address = <&art 6>;
++              };
++
++              gmac2: ethernet@37400000 {
++                      status = "ok";
++                      phy-mode = "sgmii";
++                      qcom,id = <2>;
++
++                      mtd-mac-address = <&art 0>;
++
++                      fixed-link {
++                              speed = <1000>;
++                              full-duplex;
++                      };
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++
++              wifi {
++                      label = "wifi";
++                      gpios = <&qcom_pinmux 6 1>;
++                      linux,code = <KEY_WLAN>;
++              };
++
++              reset {
++                      label = "reset";
++                      gpios = <&qcom_pinmux 54 1>;
++                      linux,code = <KEY_RESTART>;
++              };
++
++              wps {
++                      label = "wps";
++                      gpios = <&qcom_pinmux 65 1>;
++                      linux,code = <KEY_WPS_BUTTON>;
++              };
++      };
++
++      gpio-leds {
++              compatible = "gpio-leds";
++
++              usb1 {
++                      label = "r7500:amber:usb1";
++                      gpios = <&qcom_pinmux 7 0>;
++              };
++
++              usb3 {
++                      label = "r7500:amber:usb3";
++                      gpios = <&qcom_pinmux 8 0>;
++              };
++
++              status {
++                      label = "r7500:amber:status";
++                      gpios = <&qcom_pinmux 9 0>;
++              };
++
++              internet {
++                      label = "r7500:white:internet";
++                      gpios = <&qcom_pinmux 22 0>;
++              };
++
++              wan {
++                      label = "r7500:white:wan";
++                      gpios = <&qcom_pinmux 23 0>;
++              };
++
++              wps {
++                      label = "r7500:white:wps";
++                      gpios = <&qcom_pinmux 24 0>;
++              };
++
++              esata {
++                      label = "r7500:white:esata";
++                      gpios = <&qcom_pinmux 26 0>;
++              };
++
++              power {
++                      label = "r7500:white:power";
++                      gpios = <&qcom_pinmux 53 0>;
++                      default-state = "on";
++              };
++
++              rfkill {
++                      label = "r7500:white:rfkill";
++                      gpios = <&qcom_pinmux 64 0>;
++              };
++
++              wifi5g {
++                      label = "r7500:white:wifi5g";
++                      gpios = <&qcom_pinmux 67 0>;
++              };
++      };
++};
++
++&adm_dma {
++      status = "ok";
++};
diff --git a/target/linux/ipq806x/patches-4.1/301-ARM-qcom-add-Netgear-Nighthawk-X4-R7500-device-tree.patch b/target/linux/ipq806x/patches-4.1/301-ARM-qcom-add-Netgear-Nighthawk-X4-R7500-device-tree.patch
new file mode 100644 (file)
index 0000000..12e06d2
--- /dev/null
@@ -0,0 +1,387 @@
+From 7e77aa188a7a7c4391856a9e5ef5ef58f769e679 Mon Sep 17 00:00:00 2001
+From: Jonas Gorski <jogo@openwrt.org>
+Date: Sun, 9 Aug 2015 13:02:38 +0200
+Subject: [PATCH] ARM: qcom: add Netgear Nighthawk X4 R7500 device tree
+
+Signed-off-by: Jonas Gorski <jogo@openwrt.org>
+---
+ arch/arm/boot/dts/Makefile               |   1 +
+ arch/arm/boot/dts/qcom-ipq8064-r7500.dts | 370 +++++++++++++++++++++++++++++++
+ 2 files changed, 371 insertions(+)
+ create mode 100644 arch/arm/boot/dts/qcom-ipq8064-r7500.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -452,6 +452,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+       qcom-apq8084-mtp.dtb \
+       qcom-ipq8064-ap148.dtb \
+       qcom-ipq8064-db149.dtb \
++      qcom-ipq8064-r7500.dtb \
+       qcom-msm8660-surf.dtb \
+       qcom-msm8960-cdp.dtb \
+       qcom-msm8974-sony-xperia-honami.dtb
+--- /dev/null
++++ b/arch/arm/boot/dts/qcom-ipq8064-r7500.dts
+@@ -0,0 +1,362 @@
++#include "qcom-ipq8064-v1.0.dtsi"
++
++#include <dt-bindings/input/input.h>
++
++/ {
++      model = "Netgear Nighthawk X4 R7500";
++      compatible = "netgear,r7500", "qcom,ipq8064";
++
++      memory@0 {
++              reg = <0x42000000 0xe000000>;
++              device_type = "memory";
++      };
++
++      reserved-memory {
++              #address-cells = <1>;
++              #size-cells = <1>;
++              ranges;
++              rsvd@41200000 {
++                      reg = <0x41200000 0x300000>;
++                      no-map;
++              };
++      };
++
++      aliases {
++              serial0 = &uart4;
++              mdio-gpio0 = &mdio0;
++      };
++
++      chosen {
++              bootargs = "rootfstype=squashfs noinitrd";
++              linux,stdout-path = "serial0:115200n8";
++      };
++
++      soc {
++              pinmux@800000 {
++                      i2c4_pins: i2c4_pinmux {
++                              pins = "gpio12", "gpio13";
++                              function = "gsbi4";
++                              bias-disable;
++                      };
++
++                      pcie0_pins: pcie0_pinmux {
++                              mux {
++                                      pins = "gpio3";
++                                      function = "pcie1_rst";
++                                      drive-strength = <12>;
++                                      bias-disable;
++                              };
++                      };
++
++                      pcie1_pins: pcie1_pinmux {
++                              mux {
++                                      pins = "gpio48";
++                                      function = "pcie2_rst";
++                                      drive-strength = <12>;
++                                      bias-disable;
++                              };
++                      };
++
++                      nand_pins: nand_pins {
++                              mux {
++                                      pins = "gpio34", "gpio35", "gpio36",
++                                             "gpio37", "gpio38", "gpio39",
++                                             "gpio40", "gpio41", "gpio42",
++                                             "gpio43", "gpio44", "gpio45",
++                                             "gpio46", "gpio47";
++                                      function = "nand";
++                                      drive-strength = <10>;
++                                      bias-disable;
++                              };
++                              pullups {
++                                      pins = "gpio39";
++                                      bias-pull-up;
++                              };
++                              hold {
++                                      pins = "gpio40", "gpio41", "gpio42",
++                                             "gpio43", "gpio44", "gpio45",
++                                             "gpio46", "gpio47";
++                                      bias-bus-hold;
++                              };
++                      };
++
++                      mdio0_pins: mdio0_pins {
++                              mux {
++                                      pins = "gpio0", "gpio1";
++                                      function = "gpio";
++                                      drive-strength = <8>;
++                                      bias-disable;
++                              };
++                      };
++
++                      rgmii2_pins: rgmii2_pins {
++                              mux {
++                                      pins = "gpio27", "gpio28", "gpio29", "gpio30", "gpio31", "gpio32",
++                                             "gpio51", "gpio52", "gpio59", "gpio60", "gpio61", "gpio62" ;
++                                      function = "rgmii2";
++                                      drive-strength = <8>;
++                                      bias-disable;
++                              };
++                      };
++              };
++
++              gsbi@16300000 {
++                      qcom,mode = <GSBI_PROT_I2C_UART>;
++                      status = "ok";
++                      serial@16340000 {
++                              status = "ok";
++                      };
++                      /*
++                       * The i2c device on gsbi4 should not be enabled.
++                       * On ipq806x designs gsbi4 i2c is meant for exclusive
++                       * RPM usage. Turning this on in kernel manifests as
++                       * i2c failure for the RPM.
++                       */
++              };
++
++              sata-phy@1b400000 {
++                      status = "ok";
++              };
++
++              sata@29000000 {
++                      status = "ok";
++              };
++
++              phy@100f8800 {          /* USB3 port 1 HS phy */
++                      status = "ok";
++              };
++
++              phy@100f8830 {          /* USB3 port 1 SS phy */
++                      status = "ok";
++              };
++
++              phy@110f8800 {          /* USB3 port 0 HS phy */
++                      status = "ok";
++              };
++
++              phy@110f8830 {          /* USB3 port 0 SS phy */
++                      status = "ok";
++              };
++
++              usb30@0 {
++                      status = "ok";
++              };
++
++              usb30@1 {
++                      status = "ok";
++              };
++
++              pcie0: pci@1b500000 {
++                      status = "ok";
++                      reset-gpio = <&qcom_pinmux 3 0>;
++                      pinctrl-0 = <&pcie0_pins>;
++                      pinctrl-names = "default";
++              };
++
++              pcie1: pci@1b700000 {
++                      status = "ok";
++                      reset-gpio = <&qcom_pinmux 48 0>;
++                      pinctrl-0 = <&pcie1_pins>;
++                      pinctrl-names = "default";
++              };
++
++              nand@1ac00000 {
++                      status = "ok";
++
++                      pinctrl-0 = <&nand_pins>;
++                      pinctrl-names = "default";
++
++                      nand-ecc-strength = <4>;
++                      nand-bus-width = <8>;
++
++                      #address-cells = <1>;
++                      #size-cells = <1>;
++
++                      qcadata@0 {
++                              label = "qcadata";
++                              reg = <0x0000000 0x0c80000>;
++                              read-only;
++                      };
++
++                      APPSBL@c80000 {
++                              label = "APPSBL";
++                              reg = <0x0c80000 0x0500000>;
++                              read-only;
++                      };
++
++                      APPSBLENV@1180000 {
++                              label = "APPSBLENV";
++                              reg = <0x1180000 0x0080000>;
++                              read-only;
++                      };
++
++                      art: art@1200000 {
++                              label = "art";
++                              reg = <0x1200000 0x0140000>;
++                              read-only;
++                      };
++
++                      kernel@1340000 {
++                              label = "kernel";
++                              reg = <0x1340000 0x0200000>;
++                      };
++
++                      ubi@1540000 {
++                              label = "ubi";
++                              reg = <0x1540000 0x1800000>;
++                      };
++
++                      netgear@2d40000 {
++                              label = "netgear";
++                              reg = <0x2d40000 0x0c00000>;
++                              read-only;
++                      };
++
++                      reserve@3940000 {
++                              label = "reserve";
++                              reg = <0x3940000 0x46c0000>;
++                              read-only;
++                      };
++
++                      firmware@1340000 {
++                              label = "firmware";
++                              reg = <0x1340000 0x1a00000>;
++                      };
++
++              };
++
++              mdio0: mdio {
++                      compatible = "virtual,mdio-gpio";
++                      #address-cells = <1>;
++                      #size-cells = <0>;
++                      gpios = <&qcom_pinmux 1 0 &qcom_pinmux 0 0>;
++                      pinctrl-0 = <&mdio0_pins>;
++                      pinctrl-names = "default";
++
++                      phy0: ethernet-phy@0 {
++                              device_type = "ethernet-phy";
++                              reg = <0>;
++                              qca,ar8327-initvals = <
++                                      0x00004 0x7600000   /* PAD0_MODE */
++                                      0x00008 0x1000000   /* PAD5_MODE */
++                                      0x0000c 0x80        /* PAD6_MODE */
++                                      0x000e4 0xaa545     /* MAC_POWER_SEL */
++                                      0x000e0 0xc74164de  /* SGMII_CTRL */
++                                      0x0007c 0x4e        /* PORT0_STATUS */
++                                      0x00094 0x4e        /* PORT6_STATUS */
++                                      >;
++                      };
++
++                      phy4: ethernet-phy@4 {
++                              device_type = "ethernet-phy";
++                              reg = <4>;
++                      };
++              };
++
++              gmac1: ethernet@37200000 {
++                      status = "ok";
++                      phy-mode = "rgmii";
++                      phy-handle = <&phy4>;
++                      qcom,id = <1>;
++
++                      pinctrl-0 = <&rgmii2_pins>;
++                      pinctrl-names = "default";
++
++                      mtd-mac-address = <&art 6>;
++              };
++
++              gmac2: ethernet@37400000 {
++                      status = "ok";
++                      phy-mode = "sgmii";
++                      qcom,id = <2>;
++
++                      mtd-mac-address = <&art 0>;
++
++                      fixed-link {
++                              speed = <1000>;
++                              full-duplex;
++                      };
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++
++              wifi {
++                      label = "wifi";
++                      gpios = <&qcom_pinmux 6 1>;
++                      linux,code = <KEY_WLAN>;
++              };
++
++              reset {
++                      label = "reset";
++                      gpios = <&qcom_pinmux 54 1>;
++                      linux,code = <KEY_RESTART>;
++              };
++
++              wps {
++                      label = "wps";
++                      gpios = <&qcom_pinmux 65 1>;
++                      linux,code = <KEY_WPS_BUTTON>;
++              };
++      };
++
++      gpio-leds {
++              compatible = "gpio-leds";
++
++              usb1 {
++                      label = "r7500:amber:usb1";
++                      gpios = <&qcom_pinmux 7 0>;
++              };
++
++              usb3 {
++                      label = "r7500:amber:usb3";
++                      gpios = <&qcom_pinmux 8 0>;
++              };
++
++              status {
++                      label = "r7500:amber:status";
++                      gpios = <&qcom_pinmux 9 0>;
++              };
++
++              internet {
++                      label = "r7500:white:internet";
++                      gpios = <&qcom_pinmux 22 0>;
++              };
++
++              wan {
++                      label = "r7500:white:wan";
++                      gpios = <&qcom_pinmux 23 0>;
++              };
++
++              wps {
++                      label = "r7500:white:wps";
++                      gpios = <&qcom_pinmux 24 0>;
++              };
++
++              esata {
++                      label = "r7500:white:esata";
++                      gpios = <&qcom_pinmux 26 0>;
++              };
++
++              power {
++                      label = "r7500:white:power";
++                      gpios = <&qcom_pinmux 53 0>;
++                      default-state = "on";
++              };
++
++              rfkill {
++                      label = "r7500:white:rfkill";
++                      gpios = <&qcom_pinmux 64 0>;
++              };
++
++              wifi5g {
++                      label = "r7500:white:wifi5g";
++                      gpios = <&qcom_pinmux 67 0>;
++              };
++      };
++};
++
++&adm_dma {
++      status = "ok";
++};
diff --git a/target/linux/ipq806x/profiles/netgear.mk b/target/linux/ipq806x/profiles/netgear.mk
new file mode 100644 (file)
index 0000000..3402f45
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (c) 2014 The Linux Foundation. All rights reserved.
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/R7500
+       NAME:=Netgear Nighthawk X4 R7500
+       PACKAGES:= \
+               kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+               kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
+               kmod-ath10k wpad-mini
+endef
+
+define Profile/R7500/Description
+       Package set for the Netgear Nighthawk X4 R7500.
+endef
+$(eval $(call Profile,R7500))