wolfssl: make shared again
authorJo-Philipp Wich <jo@mein.io>
Sun, 24 Jul 2022 11:23:36 +0000 (13:23 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 30 Jul 2022 15:22:16 +0000 (17:22 +0200)
Disable the usage of target specific CPU crypto instructions by default
to allow the package being shared again. Since WolfSSL does not offer
a stable ABI or a long term support version suitable for OpenWrt release
timeframes, we're forced to frequently update it which is greatly
complicated by the package being nonshared.

People who want or need CPU crypto instruction support can enable it in
menuconfig while building custom images for the few platforms that support
them.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit 0063e3421de4575e088bb428e758751931bbe6fd)

package/libs/wolfssl/Config.in
package/libs/wolfssl/Makefile

index 9a7a06d04fa03132e8a7cd86f16ecaf52c82d3d4..025362ff6ff43a61293174f08831524f719eff1e 100644 (file)
@@ -69,7 +69,6 @@ config WOLFSSL_ASM_CAPABLE
 
 choice
        prompt "Hardware Acceleration"
-       default WOLFSSL_HAS_CPU_CRYPTO if WOLFSSL_ASM_CAPABLE && !TARGET_armvirt
        default WOLFSSL_HAS_NO_HW
 
        config WOLFSSL_HAS_NO_HW
index 486eaf70aed4f2a5cca81893a826b4f1d2c2ecd6..f26c18bab13dae7559ea947295ed29edeea1812c 100644 (file)
@@ -60,7 +60,6 @@ endef
 define Package/libwolfssl
 $(call Package/libwolfssl/Default)
   TITLE:=wolfSSL library
-  PKGFLAGS:=nonshared
   MENU:=1
   PROVIDES:=libcyassl
   DEPENDS:=+WOLFSSL_HAS_DEVCRYPTO:kmod-cryptodev +WOLFSSL_HAS_AFALG:kmod-crypto-user