linux: update 3.0 to 3.0.9
authorJonas Gorski <jogo@openwrt.org>
Sat, 19 Nov 2011 18:39:12 +0000 (18:39 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sat, 19 Nov 2011 18:39:12 +0000 (18:39 +0000)
SVN-Revision: 29264

22 files changed:
include/kernel-version.mk
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch
target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch
target/linux/brcm47xx/patches-3.0/302-kmod-fuse-dcache-bug-fuse.patch
target/linux/brcm47xx/patches-3.0/700-ssb-gigabit-ethernet-driver.patch
target/linux/brcm63xx/patches-3.0/011-add_bcm63xx_ehci_controller.patch
target/linux/generic/patches-3.0/100-overlayfs_v10.patch
target/linux/generic/patches-3.0/102-ehci_hcd_ignore_oc.patch
target/linux/generic/patches-3.0/400-rootfs_split.patch
target/linux/generic/patches-3.0/630-packet_socket_type.patch
target/linux/generic/patches-3.0/811-pci_disable_usb_common_quirks.patch
target/linux/generic/patches-3.0/950-vm_exports.patch
target/linux/malta/Makefile
target/linux/malta/patches-3.0/001-mips-malta-fix-crash-smp-kernel-on-non-cmp-systems.patch
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/uml/patches-3.0/002-export___sprintf_chk.patch
target/linux/uml/patches-3.0/901-lib_zlib_deflate_visible.patch

index a512ffb2d02c3951ab1f28ec041d87ff5cc30134..3220afaf4bec237e3880e9ba5c06b4ff2a2035c8 100644 (file)
@@ -29,8 +29,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.39.4)
   LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
 endif
-ifeq ($(LINUX_VERSION),3.0.3)
-  LINUX_KERNEL_MD5SUM:=6a8af5f6733b3db970197e65b3db712c
+ifeq ($(LINUX_VERSION),3.0.9)
+  LINUX_KERNEL_MD5SUM:=71992fa4dfc289a959f9ce266d08d77b
 endif
 ifeq ($(LINUX_VERSION),3.1.1)
   LINUX_KERNEL_MD5SUM:=4db653798a325f759b8cf49a1b5e6011
index ce5e8624c87f8cfc435ae847726f2b869466b26b..ea18b7c772fffb437ca8098f6c6d771c3883ae8c 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.0.3
+LINUX_VERSION:=3.0.9
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index bd5158754330ddb53301257e04567e8dd93e0299..33e23c231901ec6a825671c91480911c02c1a8a8 100644 (file)
@@ -22,7 +22,7 @@
        depends on USB
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1284,9 +1284,14 @@ MODULE_LICENSE ("GPL");
+@@ -1312,9 +1312,14 @@ MODULE_LICENSE ("GPL");
  #define PLATFORM_DRIVER               ehci_grlib_driver
  #endif
  
@@ -38,7 +38,7 @@
  #error "missing bus glue for ehci-hcd"
  #endif
  
-@@ -1346,10 +1351,20 @@ static int __init ehci_hcd_init(void)
+@@ -1374,10 +1379,20 @@ static int __init ehci_hcd_init(void)
        if (retval < 0)
                goto clean4;
  #endif
@@ -60,7 +60,7 @@
  clean4:
  #endif
  #ifdef OF_PLATFORM_DRIVER
-@@ -1380,6 +1395,9 @@ module_init(ehci_hcd_init);
+@@ -1408,6 +1423,9 @@ module_init(ehci_hcd_init);
  
  static void __exit ehci_hcd_cleanup(void)
  {
index ed444548be91cd3f89aac1c26edd450ab448ed0a..5140a723ec3439d3a3fdb77188fae403f851f023 100644 (file)
 +#endif
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1352,17 +1352,21 @@ static int __init ehci_hcd_init(void)
+@@ -1380,17 +1380,21 @@ static int __init ehci_hcd_init(void)
                goto clean4;
  #endif
  
  #ifdef XILINX_OF_PLATFORM_DRIVER
        platform_driver_unregister(&XILINX_OF_PLATFORM_DRIVER);
  clean4:
-@@ -1395,9 +1399,11 @@ module_init(ehci_hcd_init);
+@@ -1423,9 +1427,11 @@ module_init(ehci_hcd_init);
  
  static void __exit ehci_hcd_cleanup(void)
  {
index 6756a0bf647085908071609bd6ad7db271c78502..12e72510611127cd9ab664ebb1f4facda8be80a7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/fuse/dev.c
 +++ b/fs/fuse/dev.c
-@@ -647,11 +647,20 @@ static int fuse_copy_fill(struct fuse_co
+@@ -651,11 +651,20 @@ static int fuse_copy_fill(struct fuse_co
        return lock_request(cs->fc, cs->req);
  }
  
index bde1fb143167a160dc69862a97da03d63ce8e901..d429573f2d169fd7ab10349d4c7329cf73d91e60 100644 (file)
        tw32(GRC_MODE, tp->grc_mode);
  
        if (tp->pci_chip_rev_id == CHIPREV_ID_5705_A0) {
-@@ -7408,9 +7446,12 @@ static int tg3_halt_cpu(struct tg3 *tp,
+@@ -7403,9 +7441,12 @@ static int tg3_halt_cpu(struct tg3 *tp,
                return -ENODEV;
        }
  
        return 0;
  }
  
-@@ -7472,6 +7513,11 @@ static int tg3_load_5701_a0_firmware_fix
+@@ -7467,6 +7508,11 @@ static int tg3_load_5701_a0_firmware_fix
        const __be32 *fw_data;
        int err, i;
  
        fw_data = (void *)tp->fw->data;
  
        /* Firmware blob starts with version numbers, followed by
-@@ -7528,6 +7574,11 @@ static int tg3_load_tso_firmware(struct
+@@ -7523,6 +7569,11 @@ static int tg3_load_tso_firmware(struct
        unsigned long cpu_base, cpu_scratch_base, cpu_scratch_size;
        int err, i;
  
        if (tg3_flag(tp, HW_TSO_1) ||
            tg3_flag(tp, HW_TSO_2) ||
            tg3_flag(tp, HW_TSO_3))
-@@ -8825,6 +8876,11 @@ static void tg3_timer(unsigned long __op
+@@ -8819,6 +8870,11 @@ static void tg3_timer(unsigned long __op
  
        spin_lock(&tp->lock);
  
        if (!tg3_flag(tp, TAGGED_STATUS)) {
                /* All of this garbage is because when using non-tagged
                 * IRQ status the mailbox/status_block protocol the chip
-@@ -10448,6 +10504,11 @@ static int tg3_test_nvram(struct tg3 *tp
+@@ -10446,6 +10502,11 @@ static int tg3_test_nvram(struct tg3 *tp
        if (tg3_flag(tp, NO_NVRAM))
                return 0;
  
        if (tg3_nvram_read(tp, 0, &magic) != 0)
                return -EIO;
  
-@@ -11442,7 +11503,7 @@ static int tg3_ioctl(struct net_device *
+@@ -11440,7 +11501,7 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
                spin_unlock_bh(&tp->lock);
  
                data->val_out = mii_regval;
-@@ -11458,7 +11519,7 @@ static int tg3_ioctl(struct net_device *
+@@ -11456,7 +11517,7 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
                spin_unlock_bh(&tp->lock);
  
                return err;
-@@ -12188,6 +12249,13 @@ static void __devinit tg3_get_5720_nvram
+@@ -12186,6 +12247,13 @@ static void __devinit tg3_get_5720_nvram
  /* Chips other than 5700/5701 use the NVRAM for fetching info. */
  static void __devinit tg3_nvram_init(struct tg3 *tp)
  {
        tw32_f(GRC_EEPROM_ADDR,
             (EEPROM_ADDR_FSM_RESET |
              (EEPROM_DEFAULT_CLOCK_PERIOD <<
-@@ -12454,6 +12522,9 @@ static int tg3_nvram_write_block(struct
+@@ -12452,6 +12520,9 @@ static int tg3_nvram_write_block(struct
  {
        int ret;
  
index ef059f9b75a16cbef412e72dd9e7903b654bdda4..466b988ef17f309f86384d612ce17917f1bb1d91 100644 (file)
@@ -165,7 +165,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
 +MODULE_ALIAS("platform:bcm63xx_ehci");
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1284,6 +1284,11 @@ MODULE_LICENSE ("GPL");
+@@ -1312,6 +1312,11 @@ MODULE_LICENSE ("GPL");
  #define PLATFORM_DRIVER               ehci_grlib_driver
  #endif
  
index 2d6dcf12883f7f9f98acd9e76f0e3d7eb6ce88f1..e4fe1a57e428076d4b9fd6225e9a2a5875a175f6 100644 (file)
                               struct pipe_inode_info *opipe,
 --- a/fs/namespace.c
 +++ b/fs/namespace.c
-@@ -1494,6 +1494,23 @@ void drop_collected_mounts(struct vfsmou
+@@ -1495,6 +1495,23 @@ void drop_collected_mounts(struct vfsmou
        release_mounts(&umount_list);
  }
  
index 79e26b32db57d1fcc48c98ea0c748ac7db7f7690..2da61397da4bb29ef04eb3ad92da6ecaa3c8f2a4 100644 (file)
@@ -11,7 +11,7 @@
                    &ehci->regs->intr_enable); /* Turn On Interrupts */
 --- a/drivers/usb/host/ehci-hub.c
 +++ b/drivers/usb/host/ehci-hub.c
-@@ -656,7 +656,7 @@ ehci_hub_status_data (struct usb_hcd *hc
+@@ -655,7 +655,7 @@ ehci_hub_status_data (struct usb_hcd *hc
         * always set, seem to clear PORT_OCC and PORT_CSC when writing to
         * PORT_POWER; that's surprising, but maybe within-spec.
         */
@@ -20,7 +20,7 @@
                mask = PORT_CSC | PORT_PEC | PORT_OCC;
        else
                mask = PORT_CSC | PORT_PEC;
-@@ -881,7 +881,7 @@ static int ehci_hub_control (
+@@ -880,7 +880,7 @@ static int ehci_hub_control (
                if (temp & PORT_PEC)
                        status |= USB_PORT_STAT_C_ENABLE << 16;
  
                        /*
 --- a/drivers/usb/host/ehci.h
 +++ b/drivers/usb/host/ehci.h
-@@ -137,6 +137,7 @@ struct ehci_hcd {                  /* one per controlle
-       unsigned                fs_i_thresh:1;  /* Intel iso scheduling */
+@@ -138,6 +138,7 @@ struct ehci_hcd {                  /* one per controlle
        unsigned                use_dummy_qh:1; /* AMD Frame List table quirk*/
        unsigned                has_synopsys_hc_bug:1; /* Synopsys HC */
+       unsigned                frame_index_bug:1; /* MosChip (AKA NetMos) */
 +      unsigned                ignore_oc:1;
  
        /* required for usb32 quirk */
index ccbe83ea3c658e0e50c4846eebbf37e215ef163a..9eb05c4af63a4c516efe0594f75288e962cea7f8 100644 (file)
  
 --- a/drivers/mtd/mtdchar.c
 +++ b/drivers/mtd/mtdchar.c
-@@ -948,6 +948,12 @@ static int mtd_ioctl(struct file *file,
+@@ -949,6 +949,12 @@ static int mtd_ioctl(struct file *file,
                break;
        }
  
index 934e195b8d4d8b3d6d3c5b51aa96882b8803ebf9..99b5553b45892384f81dcdcb57d0e560fb0eb4b9 100644 (file)
@@ -75,7 +75,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -687,12 +690,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -690,12 +693,12 @@ static int tpacket_rcv(struct sk_buff *s
        struct timespec ts;
        struct skb_shared_hwtstamps *shhwtstamps = skb_hwtstamps(skb);
  
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -1529,6 +1532,7 @@ static int packet_create(struct net *net
+@@ -1532,6 +1535,7 @@ static int packet_create(struct net *net
        spin_lock_init(&po->bind_lock);
        mutex_init(&po->pg_vec_lock);
        po->prot_hook.func = packet_rcv;
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -2102,6 +2106,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -2105,6 +2109,16 @@ packet_setsockopt(struct socket *sock, i
                po->tp_tstamp = val;
                return 0;
        }
@@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        default:
                return -ENOPROTOOPT;
        }
-@@ -2159,6 +2173,13 @@ static int packet_getsockopt(struct sock
+@@ -2162,6 +2176,13 @@ static int packet_getsockopt(struct sock
  
                data = &val;
                break;
index 1a003ee3ccad381e0a19ed56b30271c0908a545e..3bbadd42a8c3bd02e5ccd5fbb0776654c0f65b47 100644 (file)
@@ -10,7 +10,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -869,3 +871,5 @@ static void __devinit quirk_usb_early_ha
+@@ -883,3 +885,5 @@ static void __devinit quirk_usb_early_ha
                quirk_usb_handoff_xhci(pdev);
  }
  DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
index 4be67a3a8e31618ab49ffeb89c2dbfc27cba42a3..7e80ced39818d6b48ccb78882dd960b772c75e29 100644 (file)
@@ -61,7 +61,7 @@
  {
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -4937,6 +4937,7 @@ int can_nice(const struct task_struct *p
+@@ -4923,6 +4923,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
@@ -97,7 +97,7 @@
  
  int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
  {
-@@ -1361,6 +1362,7 @@ struct vm_struct *get_vm_area(unsigned l
+@@ -1383,6 +1384,7 @@ struct vm_struct *get_vm_area(unsigned l
        return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
                                -1, GFP_KERNEL, __builtin_return_address(0));
  }
                                void *caller)
 --- a/include/linux/mm.h
 +++ b/include/linux/mm.h
-@@ -871,6 +871,7 @@ extern bool skip_free_areas_node(unsigne
+@@ -870,6 +870,7 @@ extern bool skip_free_areas_node(unsigne
  
  int shmem_lock(struct file *file, int lock, struct user_struct *user);
  struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
index 2c884dfa430bb120cfe13a49bbb8b7216ef64712..03be924846d6f954bad0906e1cab10f9df3ba53f 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.3
+LINUX_VERSION:=3.0.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 03866df7fe8c4b306f3479cdd48e38c256dd2abc..2f29a33d95edbd68e9814641fa98885a280cb5a3 100644 (file)
@@ -24,11 +24,9 @@ Patchwork: https://patchwork.linux-mips.org/patch/2413/
  arch/mips/pmc-sierra/msp71xx/msp_setup.c |    8 ++---
  4 files changed, 56 insertions(+), 24 deletions(-)
 
-diff --git a/arch/mips/include/asm/smp-ops.h b/arch/mips/include/asm/smp-ops.h
-index 9e09af3..48b03ff 100644
 --- a/arch/mips/include/asm/smp-ops.h
 +++ b/arch/mips/include/asm/smp-ops.h
-@@ -56,8 +56,43 @@ static inline void register_smp_ops(struct plat_smp_ops *ops)
+@@ -56,8 +56,43 @@ static inline void register_smp_ops(stru
  
  #endif /* !CONFIG_SMP */
  
@@ -75,8 +73,6 @@ index 9e09af3..48b03ff 100644
 +}
  
  #endif /* __ASM_SMP_OPS_H */
-diff --git a/arch/mips/mipssim/sim_setup.c b/arch/mips/mipssim/sim_setup.c
-index 55f22a3..1970069 100644
 --- a/arch/mips/mipssim/sim_setup.c
 +++ b/arch/mips/mipssim/sim_setup.c
 @@ -59,18 +59,17 @@ void __init prom_init(void)
@@ -106,8 +102,6 @@ index 55f22a3..1970069 100644
  }
  
  static void __init serial_init(void)
-diff --git a/arch/mips/mti-malta/malta-init.c b/arch/mips/mti-malta/malta-init.c
-index 31180c3..4b988b9 100644
 --- a/arch/mips/mti-malta/malta-init.c
 +++ b/arch/mips/mti-malta/malta-init.c
 @@ -28,6 +28,7 @@
@@ -140,8 +134,6 @@ index 31180c3..4b988b9 100644
  #ifdef CONFIG_MIPS_MT_SMTC
        register_smp_ops(&msmtc_smp_ops);
  #endif
-diff --git a/arch/mips/pmc-sierra/msp71xx/msp_setup.c b/arch/mips/pmc-sierra/msp71xx/msp_setup.c
-index 2413ea6..0abfbe0 100644
 --- a/arch/mips/pmc-sierra/msp71xx/msp_setup.c
 +++ b/arch/mips/pmc-sierra/msp71xx/msp_setup.c
 @@ -228,13 +228,11 @@ void __init prom_init(void)
@@ -161,6 +153,3 @@ index 2413ea6..0abfbe0 100644
  
  #ifdef CONFIG_PMCTWILED
        /*
--- 
-1.7.3.4
-
index 54e0c37ff2e84e6be4917adc480e268ca248423b..fcd0bb5eabe78bae02bf904df9a5e9ef99118c16 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.3
+LINUX_VERSION:=3.0.9
 
 include $(INCLUDE_DIR)/target.mk
 
index b2cb3a25a5068ae433466e375bcbfb3ea82f31d2..450849d5d36b2a44fda46b9e82af4d56998a3391 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.3
+LINUX_VERSION:=3.0.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 0de828259b86bdfdb01228265ad6fc4c92d99f75..3a7e6c694971a5954a41120029a8feb2f545e417 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.3
+LINUX_VERSION:=3.0.9
 
 include $(INCLUDE_DIR)/target.mk
 
index e758ea77eaa7a62be1f0877ab8215c8ff7990a84..be09630254e8b68150f6f9542a0a7b2d7112cf04 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.3
+LINUX_VERSION:=3.0.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 1f7b3fbcadcaf5cb3e38bb4d17dea661c9d93645..f6c4586e28878778736cf83a76883eab7ee28914 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.3
+LINUX_VERSION:=3.0.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 1d3cf4911a9a5b2d012418aa88d4e92639509024..cda1ffe6f2f0d1a993316b2cb299d592ddd43c70 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/arch/um/os-Linux/user_syms.c b/arch/um/os-Linux/user_syms.c
-index 05f5ea8..9e71e7e 100644
 --- a/arch/um/os-Linux/user_syms.c
 +++ b/arch/um/os-Linux/user_syms.c
-@@ -18,6 +18,9 @@ extern void *memmove(void *, const void *, size_t);
+@@ -18,6 +18,9 @@ extern void *memmove(void *, const void
  extern void *memset(void *, int, size_t);
  extern int printf(const char *, ...);
  
index f4aba9bd7a702cac5a624f115cd6334e6ec3274c..e9ec0cbc976a9052414adb9519b33c315219c358 100644 (file)
@@ -3,7 +3,7 @@ or as a module
 
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -98,7 +98,7 @@ config ZLIB_INFLATE
+@@ -91,7 +91,7 @@ config ZLIB_INFLATE
        tristate
  
  config ZLIB_DEFLATE