bpf-headers: fix build error from within the SDK
authorFelix Fietkau <nbd@nbd.name>
Fri, 4 Feb 2022 11:48:45 +0000 (12:48 +0100)
committerFelix Fietkau <nbd@nbd.name>
Fri, 4 Feb 2022 11:51:48 +0000 (12:51 +0100)
The SDK does not ship the generic platform files. Use relative path for
GENERIC_PLATFORM_DIR to make it work. This points it at the files from
the feed directory instead of the base SDK path

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/bpf-headers/Makefile

index f3c058400716cb895bc8d314b9e4bb0626912eb3..0f0857133a872f19fd4bff2c7f90a551e5c39bd5 100644 (file)
@@ -20,6 +20,7 @@ PKG_SOURCE_URL:=$(LINUX_SITE)
 PKG_HASH:=$(LINUX_KERNEL_HASH-$(strip $(PKG_VERSION)))
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/bpf-headers/$(PKG_NAME)-$(PKG_VERSION)
 
+GENERIC_PLATFORM_DIR := $(CURDIR)/../../../target/linux/generic
 GENERIC_BACKPORT_DIR := $(GENERIC_PLATFORM_DIR)/backport$(if $(wildcard $(GENERIC_PLATFORM_DIR)/backport-$(PKG_PATCHVER)),-$(PKG_PATCHVER))
 GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/pending$(if $(wildcard $(GENERIC_PLATFORM_DIR)/pending-$(PKG_PATCHVER)),-$(PKG_PATCHVER))
 GENERIC_HACK_DIR := $(GENERIC_PLATFORM_DIR)/hack$(if $(wildcard $(GENERIC_PLATFORM_DIR)/hack-$(PKG_PATCHVER)),-$(PKG_PATCHVER))